aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/jwm
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-03-11 02:42:14 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-03-11 02:42:14 +0000
commit0223362effb890962a2db3fe030cf58c9f0ed123 (patch)
treeef09163a3150b3e94a54c2cae0a5674f804e83c4 /x11-wm/jwm
parent87f4647a825a288f1b21bd33c2f637d07ec81847 (diff)
downloadports-0223362effb890962a2db3fe030cf58c9f0ed123.tar.gz
ports-0223362effb890962a2db3fe030cf58c9f0ed123.zip
- Update to 2.2.1
- Convert to options helper PR: 187295 Submitted by: ports fury
Notes
Notes: svn path=/head/; revision=347836
Diffstat (limited to 'x11-wm/jwm')
-rw-r--r--x11-wm/jwm/Makefile135
-rw-r--r--x11-wm/jwm/distinfo4
-rw-r--r--x11-wm/jwm/files/patch-example.jwmrc40
-rw-r--r--x11-wm/jwm/pkg-plist10
4 files changed, 84 insertions, 105 deletions
diff --git a/x11-wm/jwm/Makefile b/x11-wm/jwm/Makefile
index b0faae836aa5..502d788f8b4b 100644
--- a/x11-wm/jwm/Makefile
+++ b/x11-wm/jwm/Makefile
@@ -2,24 +2,16 @@
# $FreeBSD$
PORTNAME= jwm
-PORTVERSION= 2.1.0
+PORTVERSION= 2.2.1
CATEGORIES= x11-wm
-MASTER_SITES= SF \
- http://joewing.net/programs/jwm/releases/
+MASTER_SITES= http://joewing.net/programs/jwm/releases/
MAINTAINER= ports@FreeBSD.org
COMMENT= Joe's Window Manager
LICENSE= GPLv2
-OPTIONS_DEFINE= FRIBIDI XEXT XFT XINERAMA XMU XPM XRENDER JPEG PNG DEBUG
-OPTIONS_DEFAULT=FRIBIDI XEXT XFT XINERAMA XMU XPM XRENDER JPEG PNG
-FRIBIDI_DESC= Unicode Bidirectional Algorithm support
-XEXT_DESC= X11 Shape Extension support
-XMU_DESC= X11 Miscellaneous Utilities support
-XRENDER_DESC= X11 Render Extension support
-
-USE_BZIP2= yes
+USE_XZ= yes
USES= pkgconfig
USE_XORG= x11
GNU_CONFIGURE= yes
@@ -27,86 +19,63 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MFRIBIDI}
-LIB_DEPENDS+= libfribidi.so:${PORTSDIR}/converters/fribidi
-.else
-CONFIGURE_ARGS+= --disable-fribidi
-.endif
-
-.if ${PORT_OPTIONS:MXEXT}
-USE_XORG+= xext
-.else
-CONFIGURE_ARGS+= --disable-shape
-.endif
-
-.if ${PORT_OPTIONS:MXFT}
-.if empty(PORT_OPTIONS:MXRENDER)
-IGNORE= XFT support requires XRENDER
-.endif
-USE_XORG+= xft
-.else
-CONFIGURE_ARGS+= --disable-xft
-.endif
-
-.if ${PORT_OPTIONS:MXINERAMA}
-USE_XORG+= xinerama
-.else
-CONFIGURE_ARGS+= --disable-xinerama
-.endif
-
-.if ${PORT_OPTIONS:MXMU}
-.if empty(PORT_OPTIONS:MXEXT)
-IGNORE= XMU support requires XEXT
-.endif
-USE_XORG+= xmu
-.else
-CONFIGURE_ARGS+= --disable-xmu
-.endif
-
-.if ${PORT_OPTIONS:MXPM}
-.if empty(PORT_OPTIONS:MXEXT)
-IGNORE= XPM support requires XEXT
-.endif
-USE_XORG+= xpm
-.else
-CONFIGURE_ARGS+= --disable-xpm
-.endif
+OPTIONS_DEFINE= CAIRO DEBUG FRIBIDI JPEG NLS PNG SVG XEXT XFT \
+ XINERAMA XMU XPM XRENDER
+OPTIONS_DEFAULT= JPEG NLS PNG FRIBIDI XEXT XFT XINERAMA XMU XPM XRENDER
+OPTIONS_SUB= yes
+
+CAIRO_USE= GNOME=cairo
+CAIRO_CONFIGURE_ENABLE= cairo
+DEBUG_CONFIGURE_ENABLE= debug
+FRIBIDI_DESC= Unicode Bidirectional Algorithm support
+FRIBIDI_LIB_DEPENDS= libfribidi.so:${PORTSDIR}/converters/fribidi
+FRIBIDI_CONFIGURE_ENABLE=fribidi
+JPEG_LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
+JPEG_CONFIGURE_ENABLE= jpeg
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+PNG_LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
+PNG_CONFIGURE_ENABLE= png
+SVG_USE= GNOME=librsvg2
+SVG_CONFIGURE_ENABLE= rsvg
+XEXT_DESC= X11 Shape Extension support
+XEXT_USE= XORG=xext
+XEXT_CONFIGURE_ENABLE= shape
+XFT_USE= XORG=xft
+XFT_CONFIGURE_ENABLE= xft
+XINERAMA_USE= XORG=xinerama
+XINERAMA_CONFIGURE_ENABLE=xinerama
+XMU_DESC= X11 Miscellaneous Utilities support
+XMU_USE= XORG=xmu
+XMU_CONFIGURE_ENABLE= xmu
+XPM_USE= XORG=xpm
+XPM_CONFIGURE_ENABLE= xpm
+XRENDER_DESC= X11 Render Extension support
+XRENDER_USE= XORG=xrender
+XRENDER_CONFIGURE_ENABLE=xrender
-.if ${PORT_OPTIONS:MXRENDER}
-USE_XORG+= xrender
-.else
-CONFIGURE_ARGS+= --disable-xrender
-.endif
+.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MJPEG}
-LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg
-.else
-CONFIGURE_ARGS+= --disable-jpeg
+.if ${PORT_OPTIONS:MXFT} && empty(PORT_OPTIONS:MXRENDER)
+IGNORE= XFT support requires XRENDER
.endif
-.if ${PORT_OPTIONS:MPNG}
-LIB_DEPENDS+= libpng15.so:${PORTSDIR}/graphics/png
-.else
-CONFIGURE_ARGS+= --disable-png
+.if ${PORT_OPTIONS:MXMU} && empty(PORT_OPTIONS:MXEXT)
+IGNORE= XMU support requires XEXT
.endif
-.if ${PORT_OPTIONS:MDEBUG}
-CONFIGURE_ARGS+= --enable-debug
+.if ${PORT_OPTIONS:MXPM} && empty(PORT_OPTIONS:MXEXT)
+IGNORE= XPM support requires XEXT
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/example.jwmrc
- @${REINPLACE_CMD} -e 's|fribidi_char_sets_utf8.h|fribidi-char-sets.h|' ${WRKSRC}/src/jwm.h
-
-do-install:
- (cd ${WRKSRC}/src && ${INSTALL_PROGRAM} jwm \
- ${STAGEDIR}${PREFIX}/bin)
- (cd ${WRKSRC} && ${INSTALL_MAN} jwm.1 \
- ${STAGEDIR}${MANPREFIX}/man/man1)
- (cd ${WRKSRC} && ${INSTALL_DATA} example.jwmrc \
- ${STAGEDIR}${PREFIX}/etc/system.jwmrc.sample)
+ @${REINPLACE_CMD} -e \
+ 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/example.jwmrc
+ @${REINPLACE_CMD} -e \
+ 's|install -m 644|@INSTALL_DATA@| ; \
+ s|jwmrc$$|jwmrc.sample|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e \
+ '/EXE/s|install|@INSTALL_PROGRAM@| ; \
+ /strip/s|^|#|' ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>
diff --git a/x11-wm/jwm/distinfo b/x11-wm/jwm/distinfo
index 20d522435cd0..13162641620a 100644
--- a/x11-wm/jwm/distinfo
+++ b/x11-wm/jwm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (jwm-2.1.0.tar.bz2) = 5c99f9023dc8c2597effdaacc240ff4c2e07e77c8244f3bf1de5cc483bcf08ab
-SIZE (jwm-2.1.0.tar.bz2) = 163590
+SHA256 (jwm-2.2.1.tar.xz) = 27e1cd786494d3ac32806220ff141dd6bdfa4ced63a57859999d7ec8b5fb8a0b
+SIZE (jwm-2.2.1.tar.xz) = 282896
diff --git a/x11-wm/jwm/files/patch-example.jwmrc b/x11-wm/jwm/files/patch-example.jwmrc
index bca47fa29caa..e251da534bfb 100644
--- a/x11-wm/jwm/files/patch-example.jwmrc
+++ b/x11-wm/jwm/files/patch-example.jwmrc
@@ -3,25 +3,25 @@ $FreeBSD$
--- example.jwmrc.orig
+++ example.jwmrc
-@@ -5,7 +5,8 @@
- <!-- The root menu, if this is undefined you will not get a menu. -->
- <!-- Additional RootMenu attributes: onroot, labeled, label -->
- <RootMenu height="32" onroot="12">
-- <Program icon="terminal.png" label="Terminal">xterm</Program>
-+ <Program icon="rxvt.png" label="rxvt">rxvt</Program>
-+ <Program icon="xterm.png" label="xterm">xterm</Program>
+@@ -4,7 +4,8 @@
- <Menu icon="folder.png" label="Applications">
- <Program icon="editor.png" label="Dia">dia</Program>
-@@ -150,7 +151,10 @@
- </PopupStyle>
+ <!-- The root menu. -->
+ <RootMenu onroot="12">
+- <Program icon="terminal.png" label="Terminal">xterm</Program>
++ <Program icon="rxvt.png" label="Terminal">rxvt</Program>
++ <Program icon="xterm.png" label="Terminal">xterm</Program>
+ <Menu icon="folder.png" label="Applications">
+ <Program icon="music.png" label="Audacious">audacious</Program>
+ <Program icon="calculator.png" label="Calculator">xcalc</Program>
+@@ -120,7 +121,10 @@
+ for icons in multiple paths.
+ -->
+ <IconPath>
+- /usr/share/icons/wm-icons/32x32-gant
++ $HOME/.icons
++ %%PREFIX%%/share/icons
++ %%PREFIX%%/share/pixmaps
++ %%PREFIX%%/lib/X11/icons
+ </IconPath>
- <IconPath>
-- /usr/share/icons/wm-icons/32x32-gant
-+ $HOME/.icons
-+ %%PREFIX%%/share/icons
-+ %%PREFIX%%/share/pixmaps
-+ %%PREFIX%%/lib/X11/icons
- </IconPath>
-
- <!-- Virtual Desktops -->
+ <!-- Virtual Desktops -->
diff --git a/x11-wm/jwm/pkg-plist b/x11-wm/jwm/pkg-plist
index b76d79b53896..1266c14a6224 100644
--- a/x11-wm/jwm/pkg-plist
+++ b/x11-wm/jwm/pkg-plist
@@ -3,3 +3,13 @@ man/man1/jwm.1.gz
@unexec if cmp -s %D/etc/system.jwmrc %D/etc/system.jwmrc.sample; then rm -f %D/etc/system.jwmrc; fi
etc/system.jwmrc.sample
@exec if [ ! -f %D/etc/system.jwmrc ]; then cp -p %D/etc/system.jwmrc.sample %D/etc/system.jwmrc; fi
+%%NLS%%share/locale/de/LC_MESSAGES/jwm.mo
+%%NLS%%share/locale/es/LC_MESSAGES/jwm.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/jwm.mo
+%%NLS%%share/locale/it/LC_MESSAGES/jwm.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/jwm.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/jwm.mo
+%%NLS%%share/locale/pt-PT/LC_MESSAGES/jwm.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/jwm.mo
+%%NLS%%@dirrmtry share/locale/pt-PT/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/pt-PT