aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/lxsession
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2008-06-21 12:02:17 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2008-06-21 12:02:17 +0000
commit956401dd6b495aec6675a459a864596b74983146 (patch)
treeeaeba3ab2259e34926ed91266d33cf08b8f0fed6 /x11-wm/lxsession
parent4f9d41e728af3f553204d55234d2c713ac6e6809 (diff)
downloadports-956401dd6b495aec6675a459a864596b74983146.tar.gz
ports-956401dd6b495aec6675a459a864596b74983146.zip
lxsession is a standard-compliant X11 session manager with
shutdown/reboot/suspend supports via HAL and gdm. WWW: http://lxde.sourceforge.net/
Notes
Notes: svn path=/head/; revision=215455
Diffstat (limited to 'x11-wm/lxsession')
-rw-r--r--x11-wm/lxsession/Makefile41
-rw-r--r--x11-wm/lxsession/distinfo3
-rw-r--r--x11-wm/lxsession/pkg-descr4
-rw-r--r--x11-wm/lxsession/pkg-plist15
4 files changed, 63 insertions, 0 deletions
diff --git a/x11-wm/lxsession/Makefile b/x11-wm/lxsession/Makefile
new file mode 100644
index 000000000000..68b072983abe
--- /dev/null
+++ b/x11-wm/lxsession/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: lxsession
+# Date created: 2008/06/20
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= lxsession
+PORTVERSION= 0.3.2
+CATEGORIES= x11-wm gnome
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= lxde
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= LXDE Session Manager
+
+LIB_DEPENDS= hal.1:${PORTSDIR}/sysutils/hal
+BUILD_DEPENDS= docbook-to-man:${PORTSDIR}/textproc/docbook-to-man
+
+USE_GNOME= gtk20 intlhack libgnome
+
+USE_GCC= 3.3+
+USE_GMAKE= yes
+USE_ICONV= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+MAN1= lxsession.1 lxsession-logout.1
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-wm/lxsession/distinfo b/x11-wm/lxsession/distinfo
new file mode 100644
index 000000000000..2c276a75443f
--- /dev/null
+++ b/x11-wm/lxsession/distinfo
@@ -0,0 +1,3 @@
+MD5 (lxsession-0.3.2.tar.gz) = 15f7bbeb83c1f425b17ad39622d6115d
+SHA256 (lxsession-0.3.2.tar.gz) = 865321631a08b6507a77ccce7f23578b85a1e55f7e3ca197f88b595452331537
+SIZE (lxsession-0.3.2.tar.gz) = 259576
diff --git a/x11-wm/lxsession/pkg-descr b/x11-wm/lxsession/pkg-descr
new file mode 100644
index 000000000000..2f6a25f1fbfb
--- /dev/null
+++ b/x11-wm/lxsession/pkg-descr
@@ -0,0 +1,4 @@
+lxsession is a standard-compliant X11 session manager with
+shutdown/reboot/suspend supports via HAL and gdm.
+
+WWW: http://lxde.sourceforge.net/
diff --git a/x11-wm/lxsession/pkg-plist b/x11-wm/lxsession/pkg-plist
new file mode 100644
index 000000000000..713842e55888
--- /dev/null
+++ b/x11-wm/lxsession/pkg-plist
@@ -0,0 +1,15 @@
+bin/lxsession
+bin/lxsession-logout
+%%NLS%%share/locale/es/LC_MESSAGES/lxsession.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/lxsession.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/lxsession.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/lxsession.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/lxsession.mo
+%%DATADIR%%/images/gnome-session-halt.png
+%%DATADIR%%/images/gnome-session-hibernate.png
+%%DATADIR%%/images/gnome-session-logout.png
+%%DATADIR%%/images/gnome-session-reboot.png
+%%DATADIR%%/images/gnome-session-suspend.png
+%%DATADIR%%/images/gnome-session-switch.png
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%