aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/lxsession
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2017-01-24 21:27:10 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2017-01-24 21:27:10 +0000
commite147c6761a51467a8a792a36ee37c35f6b63eed0 (patch)
tree8b9335c9cc047dcd05a28ba93045ae006a0bf277 /x11-wm/lxsession
parent57615df9abf19dcea0df6b21c934cb7503bd059d (diff)
downloadports-e147c6761a51467a8a792a36ee37c35f6b63eed0.tar.gz
ports-e147c6761a51467a8a792a36ee37c35f6b63eed0.zip
- Update to 0.5.3
- Add new option, UPOWER - Adjust dependencies
Notes
Notes: svn path=/head/; revision=432390
Diffstat (limited to 'x11-wm/lxsession')
-rw-r--r--x11-wm/lxsession/Makefile47
-rw-r--r--x11-wm/lxsession/distinfo5
-rw-r--r--x11-wm/lxsession/files/patch-lxsession-default-apps_main.c11
-rw-r--r--x11-wm/lxsession/files/patch-lxsession-default-apps_main.vala11
-rw-r--r--x11-wm/lxsession/files/patch-lxsession_environement.c11
-rw-r--r--x11-wm/lxsession/files/patch-lxsession_environement.vala11
-rw-r--r--x11-wm/lxsession/files/pkg-message.in11
-rw-r--r--x11-wm/lxsession/pkg-descr6
-rw-r--r--x11-wm/lxsession/pkg-plist31
9 files changed, 125 insertions, 19 deletions
diff --git a/x11-wm/lxsession/Makefile b/x11-wm/lxsession/Makefile
index 1c68234d2df9..ce2b86b5d2d7 100644
--- a/x11-wm/lxsession/Makefile
+++ b/x11-wm/lxsession/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= lxsession
-PORTVERSION= 0.4.6.1
-PORTREVISION= 3
+PORTVERSION= 0.5.3
CATEGORIES= x11-wm
-MASTER_SITES= SF/lxde/LXSession%20%28session%20manager%29/LXSession%20${PORTVERSION}/
+MASTER_SITES= SF/lxde/LXSession%20%28session%20manager%29/LXSession%200.5.x/
MAINTAINER= ports@FreeBSD.org
COMMENT= LXDE Session Manager
@@ -14,23 +13,45 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= valac:lang/vala
-LIB_DEPENDS= libhal.so:sysutils/hal \
- libgee-0.8.so:devel/libgee \
- libdbus-glib-1.so:devel/dbus-glib
-
-USES= gmake iconv localbase pkgconfig
-USE_GNOME= gtk20 intlhack libxslt
+LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libunique-1.0.so:x11-toolkits/unique \
+ libpolkit-agent-1.so:sysutils/polkit \
+ libck-connector.so:sysutils/consolekit
+
+USES= gmake localbase pkgconfig tar:xz
+USE_GNOME= glib20 gtk20 intltool cairo gdkpixbuf2 libxslt
GNU_CONFIGURE= yes
+USE_XORG= x11
USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+
+SUB_FILES= pkg-message
-OPTIONS_DEFINE= NLS
+CONFIGURE_ARGS= --enable-buildin-clipboard \
+ --enable-buildin-polkit
+
+OPTIONS_DEFINE= NLS UPOWER
OPTIONS_SUB= yes
NLS_USES= gettext
NLS_USES_OFF= gettext-tools
-
-# Wrong versioning upstream
-PORTSCOUT= skipv:0.4.9.2
+UPOWER_LIB_DEPENDS= libupower-glib.so:sysutils/upower
+UPOWER_DESC= Suspend/Hibernate support
+
+post-patch:
+ ${FIND} ${WRKSRC} -type f | ${XARGS} \
+ ${REINPLACE_CMD} -e 's|/etc/xdg|${PREFIX}/etc/xdg|g ;\
+ s|%%PREFIX%%|${PREFIX}| ;\
+ s|/usr/bin/pkexec|${PREFIX}/bin/pkexec|g ;\
+ s|:/usr/share:/usr/share/gdm||g ;\
+ s|:/var/lib/menu-xdg||g ;\
+ s|/usr/share|${PREFIX}/share|g ;\
+ s|/usr/lib|${PREFIX}/lib|g ;\
+ s|%%QT4_LIBDIR%%|${PREFIX}/lib/qt4| ;\
+ s|%%QT5_LIBDIR%%|${PREFIX}/lib/qt5| ;\
+ s|Clearlooks|Adwaita|'
post-patch-NLS-off:
@${REINPLACE_CMD} -e 's|po man|man|' \
diff --git a/x11-wm/lxsession/distinfo b/x11-wm/lxsession/distinfo
index 390656051dad..fd3232a5a720 100644
--- a/x11-wm/lxsession/distinfo
+++ b/x11-wm/lxsession/distinfo
@@ -1,2 +1,3 @@
-SHA256 (lxsession-0.4.6.1.tar.gz) = bd6a7ef3c0ba4b9eedf3c58624dbce8bbbba3b179abbc552bf10c2830eec3ee1
-SIZE (lxsession-0.4.6.1.tar.gz) = 407100
+TIMESTAMP = 1482592330
+SHA256 (lxsession-0.5.3.tar.xz) = 90bf42a45421f45f2c745d60f2c730176e1472642451c06c2ab07dcebdaf1fa8
+SIZE (lxsession-0.5.3.tar.xz) = 407600
diff --git a/x11-wm/lxsession/files/patch-lxsession-default-apps_main.c b/x11-wm/lxsession/files/patch-lxsession-default-apps_main.c
new file mode 100644
index 000000000000..6358073643ec
--- /dev/null
+++ b/x11-wm/lxsession/files/patch-lxsession-default-apps_main.c
@@ -0,0 +1,11 @@
+--- lxsession-default-apps/main.c.orig 2016-12-10 10:31:48 UTC
++++ lxsession-default-apps/main.c
+@@ -1842,7 +1842,7 @@ LDefaultAppsMainWindows* ldefault_apps_m
+ gchar* _tmp14_ = NULL;
+ GtkBuilder* _tmp15_ = NULL;
+ const gchar* _tmp16_ = NULL;
+- _tmp14_ = g_build_filename ("/usr", "share", "lxsession", "ui", "lxsession-default-apps.ui", NULL);
++ _tmp14_ = g_build_filename ("%%PREFIX%%", "share", "lxsession", "ui", "lxsession-default-apps.ui", NULL);
+ _g_free0 (builder_file_path);
+ builder_file_path = _tmp14_;
+ _tmp15_ = builder;
diff --git a/x11-wm/lxsession/files/patch-lxsession-default-apps_main.vala b/x11-wm/lxsession/files/patch-lxsession-default-apps_main.vala
new file mode 100644
index 000000000000..c6b48f0619e1
--- /dev/null
+++ b/x11-wm/lxsession/files/patch-lxsession-default-apps_main.vala
@@ -0,0 +1,11 @@
+--- lxsession-default-apps/main.vala.orig 2016-12-10 10:31:17 UTC
++++ lxsession-default-apps/main.vala
+@@ -125,7 +125,7 @@ namespace LDefaultApps
+ else
+ {
+ /* TODO Make it smart with prefix */
+- builder_file_path = Path.build_filename("/usr","share","lxsession","ui","lxsession-default-apps.ui");
++ builder_file_path = Path.build_filename("%%PREFIX%%","share","lxsession","ui","lxsession-default-apps.ui");
+ builder.add_from_file (builder_file_path);
+ }
+ }
diff --git a/x11-wm/lxsession/files/patch-lxsession_environement.c b/x11-wm/lxsession/files/patch-lxsession_environement.c
new file mode 100644
index 000000000000..38efcf67a185
--- /dev/null
+++ b/x11-wm/lxsession/files/patch-lxsession_environement.c
@@ -0,0 +1,11 @@
+--- lxsession/environement.c.orig 2016-12-10 01:54:04 UTC
++++ lxsession/environement.c
+@@ -963,7 +963,7 @@ void lxsession_lxsession_env_set_misc (L
+ gchar* _tmp31_ = NULL;
+ gchar* _tmp32_ = NULL;
+ _tmp30_ = qt_plugin;
+- _tmp31_ = g_strconcat (_tmp30_, ":/usr/lib64/kde4/plugins:/usr/lib/kde4/plugins", NULL);
++ _tmp31_ = g_strconcat (_tmp30_, ":%%QT4_LIBDIR%%/plugins:%%QT5_LIBDIR%%/plugins", NULL);
+ _tmp32_ = _tmp31_;
+ g_setenv ("QT_PLUGIN_PATH", _tmp32_, TRUE);
+ _g_free0 (_tmp32_);
diff --git a/x11-wm/lxsession/files/patch-lxsession_environement.vala b/x11-wm/lxsession/files/patch-lxsession_environement.vala
new file mode 100644
index 000000000000..6849b6f87077
--- /dev/null
+++ b/x11-wm/lxsession/files/patch-lxsession_environement.vala
@@ -0,0 +1,11 @@
+--- lxsession/environement.vala.orig 2016-12-05 20:07:14 UTC
++++ lxsession/environement.vala
+@@ -331,7 +331,7 @@ namespace Lxsession
+ {
+ if (qt_plugin != "")
+ {
+- Environment.set_variable("QT_PLUGIN_PATH" , qt_plugin + ":/usr/lib64/kde4/plugins:/usr/lib/kde4/plugins", true);
++ Environment.set_variable("QT_PLUGIN_PATH" , qt_plugin + ":%%QT4_LIBDIR%%/plugins:%%QT5_LIBDIR%%/plugins", true);
+ }
+ }
+
diff --git a/x11-wm/lxsession/files/pkg-message.in b/x11-wm/lxsession/files/pkg-message.in
new file mode 100644
index 000000000000..c66a2afcdc83
--- /dev/null
+++ b/x11-wm/lxsession/files/pkg-message.in
@@ -0,0 +1,11 @@
+To be able to shutdown or reboot your system, you'll have to add .rules
+files in %%LOCALBASE%%/etc/polkit-1/rules.d directory. Which looks
+like this (replace PUTYOURGROUPHERE by your group):
+
+polkit.addRule(function (action, subject) {
+ if ((action.id == "org.freedesktop.consolekit.system.restart" ||
+ action.id == "org.freedesktop.consolekit.system.stop")
+ && subject.isInGroup("PUTYOURGROUPHERE")) {
+ return polkit.Result.YES;
+ }
+});
diff --git a/x11-wm/lxsession/pkg-descr b/x11-wm/lxsession/pkg-descr
index 2f6a25f1fbfb..7288850104d0 100644
--- a/x11-wm/lxsession/pkg-descr
+++ b/x11-wm/lxsession/pkg-descr
@@ -1,4 +1,4 @@
-lxsession is a standard-compliant X11 session manager with
-shutdown/reboot/suspend supports via HAL and gdm.
+LXSession is a lightweight X11 session manager, designed for use with
+the Lightweight X11 Desktop Environment (LXDE).
-WWW: http://lxde.sourceforge.net/
+WWW: http://lxde.org/
diff --git a/x11-wm/lxsession/pkg-plist b/x11-wm/lxsession/pkg-plist
index 8cafa2683ab8..d5fb4e30223b 100644
--- a/x11-wm/lxsession/pkg-plist
+++ b/x11-wm/lxsession/pkg-plist
@@ -1,8 +1,31 @@
+bin/lxclipboard
bin/lxlock
+bin/lxpolkit
bin/lxsession
+bin/lxsession-db
+bin/lxsession-default
+bin/lxsession-default-apps
+bin/lxsession-default-terminal
+bin/lxsession-edit
bin/lxsession-logout
+bin/lxsession-xdg-autostart
+bin/lxsettings-daemon
+etc/xdg/autostart/lxpolkit.desktop
+libexec/lxsession/lxsession-xsettings
+man/man1/lxclipboard.1.gz
+man/man1/lxlock.1.gz
+man/man1/lxpolkit.1.gz
+man/man1/lxsession-db.1.gz
+man/man1/lxsession-default-apps.1.gz
+man/man1/lxsession-default-terminal.1.gz
+man/man1/lxsession-default.1.gz
+man/man1/lxsession-edit.1.gz
man/man1/lxsession-logout.1.gz
+man/man1/lxsession-xdg-autostart.1.gz
man/man1/lxsession.1.gz
+man/man1/lxsettings-daemon.1.gz
+share/applications/lxsession-default-apps.desktop
+share/applications/lxsession-edit.desktop
%%NLS%%share/locale/af/LC_MESSAGES/lxsession.mo
%%NLS%%share/locale/am/LC_MESSAGES/lxsession.mo
%%NLS%%share/locale/ar/LC_MESSAGES/lxsession.mo
@@ -17,8 +40,8 @@ man/man1/lxsession.1.gz
%%NLS%%share/locale/de/LC_MESSAGES/lxsession.mo
%%NLS%%share/locale/el/LC_MESSAGES/lxsession.mo
%%NLS%%share/locale/en_GB/LC_MESSAGES/lxsession.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/lxsession.mo
%%NLS%%share/locale/es/LC_MESSAGES/lxsession.mo
-%%NLS%%share/locale/es_VE/LC_MESSAGES/lxsession.mo
%%NLS%%share/locale/et/LC_MESSAGES/lxsession.mo
%%NLS%%share/locale/eu/LC_MESSAGES/lxsession.mo
%%NLS%%share/locale/fa/LC_MESSAGES/lxsession.mo
@@ -31,8 +54,10 @@ man/man1/lxsession.1.gz
%%NLS%%share/locale/hr/LC_MESSAGES/lxsession.mo
%%NLS%%share/locale/hu/LC_MESSAGES/lxsession.mo
%%NLS%%share/locale/id/LC_MESSAGES/lxsession.mo
+%%NLS%%share/locale/is/LC_MESSAGES/lxsession.mo
%%NLS%%share/locale/it/LC_MESSAGES/lxsession.mo
%%NLS%%share/locale/ja/LC_MESSAGES/lxsession.mo
+%%NLS%%share/locale/kk/LC_MESSAGES/lxsession.mo
%%NLS%%share/locale/ko/LC_MESSAGES/lxsession.mo
%%NLS%%share/locale/lg/LC_MESSAGES/lxsession.mo
%%NLS%%share/locale/lt/LC_MESSAGES/lxsession.mo
@@ -58,6 +83,7 @@ man/man1/lxsession.1.gz
%%NLS%%share/locale/th/LC_MESSAGES/lxsession.mo
%%NLS%%share/locale/tr/LC_MESSAGES/lxsession.mo
%%NLS%%share/locale/tt_RU/LC_MESSAGES/lxsession.mo
+%%NLS%%share/locale/ug/LC_MESSAGES/lxsession.mo
%%NLS%%share/locale/uk/LC_MESSAGES/lxsession.mo
%%NLS%%share/locale/ur/LC_MESSAGES/lxsession.mo
%%NLS%%share/locale/ur_PK/LC_MESSAGES/lxsession.mo
@@ -70,3 +96,6 @@ man/man1/lxsession.1.gz
%%DATADIR%%/images/gnome-session-switch.png
%%DATADIR%%/images/system-log-out.png
%%DATADIR%%/images/system-shutdown.png
+%%DATADIR%%/ui/lxpolkit.ui
+%%DATADIR%%/ui/lxsession-default-apps.ui
+%%DATADIR%%/ui/lxsession-edit.ui