aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/mcwm
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-03-17 13:17:13 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-03-17 13:17:13 +0000
commitdbced3f758ae8c6a48a8fe0fc50ae87e06a3bd84 (patch)
tree1f33ae548e1cb11b8df200747c32539a6abb7778 /x11-wm/mcwm
parent5e67b3f765f74c9ff9fbe43af706199b39abf1ac (diff)
downloadports-dbced3f758ae8c6a48a8fe0fc50ae87e06a3bd84.tar.gz
ports-dbced3f758ae8c6a48a8fe0fc50ae87e06a3bd84.zip
mcwm is a minimalistic floating window manager for the X Window System.
It is built directly on top of XCB, the C binding for the X11 protocol. It doesn't use the Xlib API at all. All functions are available from the keyboard, but the mouse can be used for moving,resizing and raise/lower. WWW: http://hack.org/mc/hacks/mcwm/ PR: ports/155610 Submitted by: Jakub Lach <jakub_lach at mailplus.pl>
Notes
Notes: svn path=/head/; revision=271111
Diffstat (limited to 'x11-wm/mcwm')
-rw-r--r--x11-wm/mcwm/Makefile44
-rw-r--r--x11-wm/mcwm/distinfo2
-rw-r--r--x11-wm/mcwm/files/patch-Makefile29
-rw-r--r--x11-wm/mcwm/pkg-descr8
4 files changed, 83 insertions, 0 deletions
diff --git a/x11-wm/mcwm/Makefile b/x11-wm/mcwm/Makefile
new file mode 100644
index 000000000000..c54805966b28
--- /dev/null
+++ b/x11-wm/mcwm/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: mcwm
+# Date created: 16 March 2011
+# Whom: Jakub Lach <jakub_lach@mailplus.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mcwm
+PORTVERSION= 20110308
+CATEGORIES= x11-wm
+MASTER_SITES= http://hack.org/mc/hacks/mcwm/
+
+MAINTAINER= jakub_lach@mailplus.pl
+COMMENT= A small window manager inspired by CTWM, evilwm, and tinywm
+
+BUILD_DEPENDS= xcb-util>=0.3.6:${PORTSDIR}/x11/xcb-util
+RUN_DEPENDS= xcb-util>=0.3.6:${PORTSDIR}/x11/xcb-util
+
+USE_XORG= x11
+USE_BZIP2= yes
+
+MAN1= mcwm.1
+PLIST_FILES= bin/mcwm
+PORTDOCS= LICENSE README
+
+pre-everything::
+ @${ECHO_MSG} "You can build mcwm with your own config.h using the MCWM_CONF knob:"
+ @${ECHO_MSG} "make MCWM_CONF=/path/to/dwm/config.h install clean"
+
+post-extract:
+.if defined(MCWM_CONF)
+ @${ECHO_MSG} "creating config.h from ${MCWM_CONF}"
+ @${CP} ${MCWM_CONF} ${WRKSRC}/config.h
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/LICENSE ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-wm/mcwm/distinfo b/x11-wm/mcwm/distinfo
new file mode 100644
index 000000000000..32aa0f3f89dc
--- /dev/null
+++ b/x11-wm/mcwm/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mcwm-20110308.tar.bz2) = 871d78eccfdbe00af17551436a886cc352874839c2adae963e83b25fcd770406
+SIZE (mcwm-20110308.tar.bz2) = 23392
diff --git a/x11-wm/mcwm/files/patch-Makefile b/x11-wm/mcwm/files/patch-Makefile
new file mode 100644
index 000000000000..c606274b3043
--- /dev/null
+++ b/x11-wm/mcwm/files/patch-Makefile
@@ -0,0 +1,29 @@
+--- Makefile.orig 2011-03-16 18:19:22.000000000 +0100
++++ Makefile 2011-03-16 18:23:04.000000000 +0100
+@@ -3,12 +3,12 @@ DIST=mcwm-$(VERSION)
+ SRC=mcwm.c list.c config.h events.h list.h
+ DISTFILES=LICENSE Makefile NEWS README TODO WISHLIST mcwm.man $(SRC)
+
+-CC=gcc
+-CFLAGS=-g -std=c99 -Wall -Wextra -O2 -I/usr/local/include #-DDEBUG #-DDMALLOC
+-LDFLAGS=-L/usr/local/lib -lxcb -lxcb-keysyms -lxcb-icccm -lxcb-atom # -ldmalloc
++CFLAGS+=-g -std=c99 -Wall -Wextra -I/usr/local/include
++LDFLAGS+=-L/usr/local/lib -lxcb -lxcb-keysyms -lxcb-icccm -lxcb-atom
+
+ RM=/bin/rm
+-PREFIX=/usr/local
++PREFIX?=/usr/local
++MANPREFIX = ${PREFIX}/man
+
+ TARGETS=mcwm
+ OBJS=mcwm.o list.o
+@@ -28,6 +28,9 @@ list.o: list.c list.h Makefile
+
+ install: $(TARGETS)
+ install -m 755 mcwm $(PREFIX)/bin
++ @echo installing manual page to ${DESTDIR}${MANPREFIX}/man1
++ @mkdir -p ${DESTDIR}${MANPREFIX}/man1
++ @sed "s/VERSION/${VERSION}/g" < mcwm.man > ${DESTDIR}${MANPREFIX}/man1/mcwm.1
+
+ deinstall:
+ $(RM) $(PREFIX)/bin/mcwm
diff --git a/x11-wm/mcwm/pkg-descr b/x11-wm/mcwm/pkg-descr
new file mode 100644
index 000000000000..02f0931804cb
--- /dev/null
+++ b/x11-wm/mcwm/pkg-descr
@@ -0,0 +1,8 @@
+mcwm is a minimalistic floating window manager for the X Window System.
+It is built directly on top of XCB, the C binding for the X11 protocol.
+It doesn't use the Xlib API at all.
+
+All functions are available from the keyboard, but the mouse can be
+used for moving,resizing and raise/lower.
+
+WWW: http://hack.org/mc/hacks/mcwm/