aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/metacity
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /x11-wm/metacity
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
downloadports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.tar.gz
ports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.zip
The FreeBSD GNOME team proudly presents GNOME 3.14 and Cinnamon 2.2.
Gnome 3.14.1 and Cinnamon 2.2.16 are supported on FreeBSD 9.3-RELEASE and up. This commit removes the old GNOME 2 desktop, bindings and some ports that can't be compiled. A few ports where updated to more recent versions to allow them to compile with this update. Apart from updating ports to newer versions GDM is more integrated with gnome-shell now, and handles several things for the GNOME desktop such as screen locking. If you want to use GNOME 3 via startx, you will have to add your own lock screen/screensaver. For example xscreensaver can be used for sessions started without GDM. Shell Extensions can be installed via https://extensions.gnome.org/ , we have ported a few that can't be installed via this way. The old gnome-utils and gnome-games ports where split up into single ports and where converted to meta-ports. gnome-terminal requires a UTF-8 locale to run, gdm handles this already, but if you use startx you need to do this yourself. Upgrade instructions: Delete the old and conflicting packages: # pkg delete clutter gnome-utils gnome-panel gnome-keyring vala-vapigen \ guile gcalctool gnome-media libgnomekbd # pkg delete gnome-screensaver gnome-applets bug-buddy evolution-exchange \ evolution-webcal gnome-system-tools seahorse-plugins gnome-control-center For package users the following lines will be enough: # pkg upgrade # pkg install gnome3 For ports users should do the following: # portmaster -a # portmaster x11/gnome3 We are currently aware of two issues. The first issue is a bug in the file monitoring code in the glib20 port. This bug causes glib programs to crash when files in a monitored directory are added or removed. Upstream is aware of the problem, but since the problem is quite complex there is no solution yet. This problem isn't restricted to BSD. The second issue is that on certain video cards totem will display a purple/pink overlay on the video. It not clear yet where the issues comes from. Major thanks goes to Gustau Perez for being a driving force behind getting GNOME 3 up to speed again. Also thanks to Antoine Brodin for running the exp-runs. This update was also made possible by: Joe Maloney Kris Moore Beeblebrox Ryan Lortie Antoine Jacoutot and everyone I missed
Notes
Notes: svn path=/head/; revision=372768
Diffstat (limited to 'x11-wm/metacity')
-rw-r--r--x11-wm/metacity/Makefile32
-rw-r--r--x11-wm/metacity/distinfo4
-rw-r--r--x11-wm/metacity/files/patch-bugzilla_588119139
-rw-r--r--x11-wm/metacity/files/patch-configure11
-rw-r--r--x11-wm/metacity/files/patch-src_core_delete.c10
-rw-r--r--x11-wm/metacity/files/patch-src_core_main.c14
-rw-r--r--x11-wm/metacity/pkg-plist99
7 files changed, 33 insertions, 276 deletions
diff --git a/x11-wm/metacity/Makefile b/x11-wm/metacity/Makefile
index 462af5e089d0..94d6747861b6 100644
--- a/x11-wm/metacity/Makefile
+++ b/x11-wm/metacity/Makefile
@@ -1,36 +1,34 @@
# Created by: Garrett Rooney <rooneg@electricjellyfish.net>
# $FreeBSD$
-# $MCom: ports/x11-wm/metacity/Makefile,v 1.158 2010/09/30 07:04:02 kwm Exp $
+# $MCom: ports/trunk/x11-wm/metacity/Makefile 20004 2014-10-20 14:11:09Z gusi $
PORTNAME= metacity
-PORTVERSION= 2.30.3
-PORTREVISION= 2
+PORTVERSION= 3.14.1
CATEGORIES= x11-wm
MASTER_SITES= GNOME
-DIST_SUBDIR= gnome2
+DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Window manager for the adult in you
-BUILD_DEPENDS= zenity:${PORTSDIR}/x11/zenity
+BUILD_DEPENDS= zenity>=3.0.0:${PORTSDIR}/x11/zenity \
+ itstool:${PORTSDIR}/textproc/itstool \
+ gsettings-desktop-schemas>=3.3.0:${PORTSDIR}/devel/gsettings-desktop-schemas
LIB_DEPENDS= libstartup-notification-1.so:${PORTSDIR}/x11/startup-notification \
- libcanberra-gtk.so:${PORTSDIR}/audio/libcanberra
-RUN_DEPENDS= zenity:${PORTSDIR}/x11/zenity
+ libgtop-2.0.so:${PORTSDIR}/devel/libgtop \
+ libcanberra-gtk3.so:${PORTSDIR}/audio/libcanberra-gtk3
+RUN_DEPENDS= zenity>=3.0.0:${PORTSDIR}/x11/zenity \
+ gsettings-desktop-schemas>=3.3.0:${PORTSDIR}/devel/gsettings-desktop-schemas
-USE_XORG= x11 xcomposite xdamage
-USES= gettext gmake libtool:keepla pathfix pkgconfig tar:bzip2
-INSTALL_TARGET= install-strip
+USE_XORG= x11 xcomposite xdamage xrender xcursor xinerama xext xrandr
+USES= gettext gmake libtool pathfix pkgconfig tar:xz
GNU_CONFIGURE= yes
-USE_GNOME= gnomeprefix intlhack gconf2 gtk20
+USE_GNOME= gnomeprefix gtk30 intlhack libxml2:build
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAKE_ENV= G_CHARSET_ALIAS="${LOCALBASE}/libdata/charset.alias"
-
-GCONF_SCHEMAS= metacity.schemas
+INSTALL_TARGET= install-strip
-post-patch:
- @${REINPLACE_CMD} -e 's|-Werror||g' \
- ${WRKSRC}/configure
+GLIB_SCHEMAS= org.gnome.metacity.gschema.xml
.include <bsd.port.mk>
diff --git a/x11-wm/metacity/distinfo b/x11-wm/metacity/distinfo
index 90104c11848d..2824673470bf 100644
--- a/x11-wm/metacity/distinfo
+++ b/x11-wm/metacity/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome2/metacity-2.30.3.tar.bz2) = 08f887018fa5e447cf184d03bae3fe2c05fdb7583bed6768e3b4d66392fc18dd
-SIZE (gnome2/metacity-2.30.3.tar.bz2) = 2358537
+SHA256 (gnome3/metacity-3.14.1.tar.xz) = 1a4ebf77478fd948f62aa3df26cf7fa9bd9a2c2a98c30d3bcdf7dd8e1cf3d6f4
+SIZE (gnome3/metacity-3.14.1.tar.xz) = 1610500
diff --git a/x11-wm/metacity/files/patch-bugzilla_588119 b/x11-wm/metacity/files/patch-bugzilla_588119
deleted file mode 100644
index 823c111ab58c..000000000000
--- a/x11-wm/metacity/files/patch-bugzilla_588119
+++ /dev/null
@@ -1,139 +0,0 @@
-From a3de65d5d1861f755ced7cad291fbbd4f1b8ef51 Mon Sep 17 00:00:00 2001
-From: Owen W. Taylor <otaylor@fishsoup.net>
-Date: Sat, 22 Aug 2009 15:00:57 -0400
-Subject: [PATCH] Should set RestartStyleHint to RestartIfRunning when replaced
-
-This reverts most of commit abbd057eb967e6ab462ffe305f41b2b04d417b25;
-
- - It's fine to call meta_session_shutdown() after the display
- is closed, since it's talking over the ICE connection
- - We should not call warn_about_lame_clients_and_finish_interact()
- unless we are interacting with the window manager in a session
- save.
-
-However, the part of abbd057 that fixed accessing freed memory was
-fixing a real problem; this patches does the same thing in a simpler
-way by fixing an obvious type in meta_display_close() where it was
-NULL'ing out the local variable 'display' rather than the global
-variable 'the_display' and adding keeping the check in meta_finalize()
-that was added in abbd057.
-
-The order of calling meta_session_shutdown() and
-calling meta_display_close() is reverted back to the old order to
-make it clear that it's OK if the display way already closed previously.
-
-http://bugzilla.gnome.org/show_bug.cgi?id=588119
----
- src/core/display-private.h | 2 +-
- src/core/display.c | 16 ++++------------
- src/core/main.c | 5 ++---
- src/core/session.c | 8 --------
- 4 files changed, 7 insertions(+), 24 deletions(-)
-
-diff --git a/src/core/display-private.h b/src/core/display-private.h
-index 19287f3..9c8ebc6 100644
---- src/core/display-private.h
-+++ src/core/display-private.h
-@@ -329,7 +329,7 @@ MetaScreen* meta_display_screen_for_xwindow (MetaDisplay *display,
- void meta_display_grab (MetaDisplay *display);
- void meta_display_ungrab (MetaDisplay *display);
-
--void meta_display_unmanage_screen (MetaDisplay **display,
-+void meta_display_unmanage_screen (MetaDisplay *display,
- MetaScreen *screen,
- guint32 timestamp);
-
-diff --git a/src/core/display.c b/src/core/display.c
-index 55c374a..8e35a35 100644
---- src/core/display.c
-+++ src/core/display.c
-@@ -926,7 +926,7 @@ meta_display_close (MetaDisplay *display,
- meta_compositor_destroy (display->compositor);
-
- g_free (display);
-- display = NULL;
-+ the_display = NULL;
-
- meta_quit (META_EXIT_SUCCESS);
- }
-@@ -4762,13 +4762,10 @@ process_selection_clear (MetaDisplay *display,
- meta_verbose ("Got selection clear for screen %d on display %s\n",
- screen->number, display->name);
-
-- meta_display_unmanage_screen (&display,
-+ meta_display_unmanage_screen (display,
- screen,
- event->xselectionclear.time);
-
-- if (!display)
-- the_display = NULL;
--
- /* display and screen may both be invalid memory... */
-
- return;
-@@ -4790,12 +4787,10 @@ process_selection_clear (MetaDisplay *display,
- }
-
- void
--meta_display_unmanage_screen (MetaDisplay **displayp,
-+meta_display_unmanage_screen (MetaDisplay *display,
- MetaScreen *screen,
- guint32 timestamp)
- {
-- MetaDisplay *display = *displayp;
--
- meta_verbose ("Unmanaging screen %d on display %s\n",
- screen->number, display->name);
-
-@@ -4805,10 +4800,7 @@ meta_display_unmanage_screen (MetaDisplay **displayp,
- display->screens = g_slist_remove (display->screens, screen);
-
- if (display->screens == NULL)
-- {
-- meta_display_close (display, timestamp);
-- *displayp = NULL;
-- }
-+ meta_display_close (display, timestamp);
- }
-
- void
-diff --git a/src/core/main.c b/src/core/main.c
-index a36a396..44d317e 100644
---- src/core/main.c
-+++ src/core/main.c
-@@ -361,12 +361,11 @@ static void
- meta_finalize (void)
- {
- MetaDisplay *display = meta_get_display();
--
-- meta_session_shutdown ();
--
- if (display)
- meta_display_close (display,
- CurrentTime); /* I doubt correct timestamps matter here */
-+
-+ meta_session_shutdown ();
- }
-
- static void
-diff --git a/src/core/session.c b/src/core/session.c
-index 7e3b389..0d69350 100644
---- src/core/session.c
-+++ src/core/session.c
-@@ -376,14 +376,6 @@ meta_session_shutdown (void)
- SmProp *props[1];
- char hint = SmRestartIfRunning;
-
-- if (!meta_get_display ())
-- {
-- meta_verbose ("Cannot close session because there is no display");
-- return;
-- }
--
-- warn_about_lame_clients_and_finish_interact (FALSE);
--
- if (session_connection == NULL)
- return;
-
---
-1.6.4
diff --git a/x11-wm/metacity/files/patch-configure b/x11-wm/metacity/files/patch-configure
deleted file mode 100644
index 223d0af9ecf9..000000000000
--- a/x11-wm/metacity/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig 2010-04-01 13:44:38.000000000 +0200
-+++ configure 2010-04-01 13:45:49.000000000 +0200
-@@ -24238,7 +24238,7 @@
- "
-
- METACITY_MINOR_VERSION=30
--if test $(( $(echo $METACITY_MINOR_VERSION) %2)) == "1"; then
-+if test $(( $(echo $METACITY_MINOR_VERSION) %2)) = "1"; then
- stable_version=$(( ($METACITY_MINOR_VERSION / 2) * 2))
- echo "This is the UNSTABLE branch of metacity"
- echo -n "Use 2.$stable_version.x for stable "
diff --git a/x11-wm/metacity/files/patch-src_core_delete.c b/x11-wm/metacity/files/patch-src_core_delete.c
deleted file mode 100644
index c72b0f60ae0e..000000000000
--- a/x11-wm/metacity/files/patch-src_core_delete.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/core/delete.c.orig 2010-01-30 18:56:27.000000000 -0500
-+++ src/core/delete.c 2010-01-30 18:56:53.000000000 -0500
-@@ -32,6 +32,7 @@
- #include "workspace.h"
-
- #include <sys/types.h>
-+#include <sys/wait.h>
- #include <signal.h>
- #include <unistd.h>
- #include <errno.h>
diff --git a/x11-wm/metacity/files/patch-src_core_main.c b/x11-wm/metacity/files/patch-src_core_main.c
deleted file mode 100644
index 2d5171e5deda..000000000000
--- a/x11-wm/metacity/files/patch-src_core_main.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/core/main.c.orig 2010-01-21 11:09:25.000000000 -0500
-+++ src/core/main.c 2010-01-30 18:53:17.000000000 -0500
-@@ -58,7 +58,11 @@
-
- #include <stdlib.h>
- #include <sys/types.h>
-+#ifdef __linux__
- #include <wait.h>
-+#else
-+#include <sys/wait.h>
-+#endif
- #include <stdio.h>
- #include <string.h>
- #include <signal.h>
diff --git a/x11-wm/metacity/pkg-plist b/x11-wm/metacity/pkg-plist
index cc2bc20dc44d..0426b2f27e3b 100644
--- a/x11-wm/metacity/pkg-plist
+++ b/x11-wm/metacity/pkg-plist
@@ -2,28 +2,30 @@ bin/metacity
bin/metacity-message
bin/metacity-theme-viewer
bin/metacity-window-demo
-include/metacity-1/metacity-private/boxes.h
-include/metacity-1/metacity-private/common.h
-include/metacity-1/metacity-private/gradient.h
-include/metacity-1/metacity-private/preview-widget.h
-include/metacity-1/metacity-private/theme-parser.h
-include/metacity-1/metacity-private/theme.h
-include/metacity-1/metacity-private/util.h
+include/metacity/metacity-private/boxes.h
+include/metacity/metacity-private/common.h
+include/metacity/metacity-private/gradient.h
+include/metacity/metacity-private/preview-widget.h
+include/metacity/metacity-private/theme-parser.h
+include/metacity/metacity-private/theme.h
+include/metacity/metacity-private/util.h
lib/libmetacity-private.a
-lib/libmetacity-private.la
lib/libmetacity-private.so
-lib/libmetacity-private.so.0
-lib/libmetacity-private.so.0.0.0
+lib/libmetacity-private.so.2
+lib/libmetacity-private.so.2.0.0
libdata/pkgconfig/libmetacity-private.pc
man/man1/metacity-message.1.gz
man/man1/metacity-theme-viewer.1.gz
man/man1/metacity-window-demo.1.gz
man/man1/metacity.1.gz
+share/GConf/gsettings/metacity-schemas.convert
share/applications/metacity.desktop
-share/gnome-control-center/keybindings/50-metacity-desktop-key.xml
-share/gnome-control-center/keybindings/50-metacity-key.xml
-share/gnome/help/creating-metacity-themes/C/creating-metacity-themes.xml
+share/gnome-control-center/keybindings/50-metacity-navigation.xml
+share/gnome-control-center/keybindings/50-metacity-system.xml
+share/gnome-control-center/keybindings/50-metacity-windows.xml
share/gnome/wm-properties/metacity-wm.desktop
+share/help/C/creating-metacity-themes/index.docbook
+share/help/de/creating-metacity-themes/index.docbook
share/locale/am/LC_MESSAGES/metacity.mo
share/locale/ar/LC_MESSAGES/metacity.mo
share/locale/as/LC_MESSAGES/metacity.mo
@@ -109,6 +111,7 @@ share/locale/te/LC_MESSAGES/metacity.mo
share/locale/th/LC_MESSAGES/metacity.mo
share/locale/tk/LC_MESSAGES/metacity.mo
share/locale/tr/LC_MESSAGES/metacity.mo
+share/locale/ug/LC_MESSAGES/metacity.mo
share/locale/uk/LC_MESSAGES/metacity.mo
share/locale/vi/LC_MESSAGES/metacity.mo
share/locale/wa/LC_MESSAGES/metacity.mo
@@ -220,73 +223,3 @@ share/themes/Simple/metacity-1/maximize.png
share/themes/Simple/metacity-1/maximized.png
share/themes/Simple/metacity-1/metacity-theme-1.xml
share/themes/Simple/metacity-1/minimize.png
-@dirrm share/themes/Simple/metacity-1
-@dirrmtry share/themes/Simple
-@dirrm share/themes/Metabox/metacity-1
-@dirrmtry share/themes/Metabox
-@dirrm share/themes/Esco/metacity-1
-@dirrmtry share/themes/Esco
-@dirrm share/themes/Crux/metacity-1
-@dirrmtry share/themes/Crux
-@dirrm share/themes/Bright/metacity-1
-@dirrmtry share/themes/Bright
-@dirrm share/themes/Atlanta/metacity-1
-@dirrmtry share/themes/Atlanta
-@dirrm share/themes/AgingGorilla/metacity-1
-@dirrmtry share/themes/AgingGorilla
-@dirrm %%DATADIR%%/icons
-@dirrm %%DATADIR%%
-@dirrm share/gnome/help/creating-metacity-themes/C
-@dirrm share/gnome/help/creating-metacity-themes
-@dirrm include/metacity-1/metacity-private
-@dirrm include/metacity-1
-@dirrmtry share/locale/zh_HK/LC_MESSAGES
-@dirrmtry share/locale/zh_HK
-@dirrmtry share/locale/yo/LC_MESSAGES
-@dirrmtry share/locale/yo
-@dirrmtry share/locale/xh/LC_MESSAGES
-@dirrmtry share/locale/xh
-@dirrmtry share/locale/te/LC_MESSAGES
-@dirrmtry share/locale/te
-@dirrmtry share/locale/sr@latin/LC_MESSAGES
-@dirrmtry share/locale/sr@latin
-@dirrmtry share/locale/si/LC_MESSAGES
-@dirrmtry share/locale/si
-@dirrmtry share/locale/rw/LC_MESSAGES
-@dirrmtry share/locale/rw
-@dirrmtry share/locale/oc/LC_MESSAGES
-@dirrmtry share/locale/oc
-@dirrmtry share/locale/nds/LC_MESSAGES
-@dirrmtry share/locale/nds
-@dirrmtry share/locale/mr/LC_MESSAGES
-@dirrmtry share/locale/mr
-@dirrmtry share/locale/mg/LC_MESSAGES
-@dirrmtry share/locale/mg
-@dirrmtry share/locale/mai/LC_MESSAGES
-@dirrmtry share/locale/mai
-@dirrmtry share/locale/la/LC_MESSAGES
-@dirrmtry share/locale/la
-@dirrmtry share/locale/ku/LC_MESSAGES
-@dirrmtry share/locale/ku
-@dirrmtry share/locale/ig/LC_MESSAGES
-@dirrmtry share/locale/ig
-@dirrmtry share/locale/hy/LC_MESSAGES
-@dirrmtry share/locale/hy
-@dirrmtry share/locale/ha/LC_MESSAGES
-@dirrmtry share/locale/ha
-@dirrmtry share/locale/en@shaw/LC_MESSAGES
-@dirrmtry share/locale/en@shaw
-@dirrmtry share/locale/dz/LC_MESSAGES
-@dirrmtry share/locale/dz
-@dirrmtry share/locale/crh/LC_MESSAGES
-@dirrmtry share/locale/crh
-@dirrmtry share/locale/ca@valencia/LC_MESSAGES
-@dirrmtry share/locale/ca@valencia
-@dirrmtry share/locale/bn_IN/LC_MESSAGES
-@dirrmtry share/locale/bn_IN
-@dirrmtry share/locale/be@latin/LC_MESSAGES
-@dirrmtry share/locale/be@latin
-@dirrmtry share/locale/ast/LC_MESSAGES
-@dirrmtry share/locale/ast
-@dirrmtry share/locale/as/LC_MESSAGES
-@dirrmtry share/locale/as