aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/muffin/Makefile
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2021-01-02 11:21:30 +0000
committerRene Ladan <rene@FreeBSD.org>2021-01-02 11:21:30 +0000
commit474895cdb67df33222fa2b2e67a4c6fc7dea0fa7 (patch)
tree88f0bd8b077f4fe5cb17646d5336161aa4610b11 /x11-wm/muffin/Makefile
parent9729352622704f6096153cf167ef06a4d7085051 (diff)
downloadports-474895cdb67df33222fa2b2e67a4c6fc7dea0fa7.tar.gz
ports-474895cdb67df33222fa2b2e67a4c6fc7dea0fa7.zip
Notes
Diffstat (limited to 'x11-wm/muffin/Makefile')
-rw-r--r--x11-wm/muffin/Makefile77
1 files changed, 51 insertions, 26 deletions
diff --git a/x11-wm/muffin/Makefile b/x11-wm/muffin/Makefile
index 083a43ec1e4d..afe628a36286 100644
--- a/x11-wm/muffin/Makefile
+++ b/x11-wm/muffin/Makefile
@@ -2,48 +2,73 @@
# $FreeBSD$
PORTNAME= muffin
-PORTVERSION= 2.4.4
-PORTREVISION= 2
+PORTVERSION= 4.8.0
CATEGORIES= x11-wm gnome
-DIST_SUBDIR= gnome3
+DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
COMMENT= Compositing window manager forked from Mutter for use with Cinnamon
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= zenity>=3.0.0:x11/zenity \
gnome-autogen.sh:devel/gnome-common \
- gsettings-desktop-schemas>=3.4.0:devel/gsettings-desktop-schemas
-LIB_DEPENDS= libstartup-notification-1.so:x11/startup-notification \
- libclutter-glx-1.0.so:graphics/clutter \
+ gsettings-desktop-schemas>=3.4.0:devel/gsettings-desktop-schemas \
+ gtkdocize:textproc/gtk-doc \
+ xkeyboard-config>0:x11/xkeyboard-config
+LIB_DEPENDS= libcanberra.so:audio/libcanberra \
libcanberra-gtk3.so:audio/libcanberra-gtk3 \
- libcinnamon-desktop.so:x11/cinnamon-desktop
-RUN_DEPENDS= zenity>=3.0.0:x11/zenity
+ libcinnamon-desktop.so:x11/cinnamon-desktop \
+ libdrm.so:graphics/libdrm \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libjson-glib-1.0.so:devel/json-glib \
+ libstartup-notification-1.so:x11/startup-notification \
+ libwacom.so:x11/libwacom \
+ libxkbcommon.so:x11/libxkbcommon \
+ libharfbuzz.so:print/harfbuzz
+RUN_DEPENDS= zenity>=3.0.0:x11/zenity \
+ xkeyboard-config>0:x11/xkeyboard-config
+
+USES= autoreconf:build gettext-tools gl gmake gnome libtool pathfix pkgconfig \
+ xorg
-USES= autoreconf:build gettext gmake gnome libtool pathfix pkgconfig \
- python:2.7 xorg
USE_GITHUB= yes
GH_ACCOUNT= linuxmint
-USE_GNOME= gconf2 gnomeprefix gtk30 \
- intlhack introspection:build
-USE_XORG= x11 xext xrandr xcomposite xcursor xinerama ice sm
+
+USE_GNOME= cairo dconf gdkpixbuf2 gnomeprefix glib20 gtk30 intltool \
+ introspection
+
+USE_XORG= ice sm x11 xcb xcomposite xcursor xdamage xext xfixes xi xinerama \
+ xkbfile xrandr xrender xtst
+
+USE_GL= egl gl
+
USE_LDCONFIG= yes
-USE_CSTD= gnu89
+
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include -Wno-error=unused-function
-CFLAGS+= -I${LOCALBASE}/include -Wno-error=unused-function
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= LIBS="-lexecinfo"
-CONFIGURE_ARGS= --enable-compile-warnings=maximum
-MAKE_ARGS= V=1
-GLIB_SCHEMAS= org.cinnamon.muffin.gschema.xml
+CONFIGURE_ARGS= --enable-maintainer-flags=no
+CFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
INSTALL_TARGET= install-strip
-pre-configure:
- @cd ${WRKSRC} && ${SETENV} NOCONFIGURE=yes ${SH} autogen.sh
+GLIB_SCHEMAS= org.cinnamon.muffin.gschema.xml
+
+OPTIONS_DEFINE= WAYLAND
+OPTIONS_DEFAULT= WAYLAND
+OPTIONS_SUB= yes
+
+WAYLAND_BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:devel/evdev-proto
+WAYLAND_LIB_DEPENDS= libinput.so:x11/libinput \
+ libudev.so:devel/libudev-devd \
+ libwayland-server.so:graphics/wayland
+WAYLAND_CONFIGURE_ENABLE= wayland-egl-server
post-patch:
- @${REINPLACE_CMD} -e 's|REQUIRED_AUTOMAKE_VERSION=1.10|REQUIRED_AUTOMAKE_VERSION=1.14|g' \
- ${WRKSRC}/autogen.sh
- @${REINPLACE_CMD} -e 's|--warn-error||g' ${WRKSRC}/src/Makefile.am
+ @${REINPLACE_CMD} 's/--warn-error//' ${WRKSRC}/src/Makefile.am
+
+pre-configure:
+ @cd ${WRKSRC} && ${SETENV} NOCONFIGURE=yes ${SH} autogen.sh
.include <bsd.port.mk>