aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/muffin
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /x11-wm/muffin
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
downloadports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.tar.gz
ports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.zip
Notes
Diffstat (limited to 'x11-wm/muffin')
-rw-r--r--x11-wm/muffin/Makefile49
-rw-r--r--x11-wm/muffin/distinfo2
-rw-r--r--x11-wm/muffin/files/patch-src_core_main.c14
-rw-r--r--x11-wm/muffin/pkg-descr9
-rw-r--r--x11-wm/muffin/pkg-plist136
5 files changed, 210 insertions, 0 deletions
diff --git a/x11-wm/muffin/Makefile b/x11-wm/muffin/Makefile
new file mode 100644
index 000000000000..ccc204f8c990
--- /dev/null
+++ b/x11-wm/muffin/Makefile
@@ -0,0 +1,49 @@
+# Created by: Gustau Perez i Querol <gustau.perez@gmail.com>
+# $FreeBSD$
+# $MCom: ports/trunk/x11-wm/muffin/Makefile 20031 2014-11-02 21:47:55Z kwm $
+
+PORTNAME= muffin
+PORTVERSION= 2.2.6
+PORTREVISION= 1
+CATEGORIES= x11-wm gnome
+MASTER_SITES= http://github.com/linuxmint/${PORTNAME}/archive/${PORTVERSION}.tar.gz?dummy=/
+DIST_SUBDIR= gnome3
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Compositing window manager forked from Mutter for use with Cinnamon
+
+BUILD_DEPENDS= zenity>=3.0.0:${PORTSDIR}/x11/zenity \
+ gnome-autogen.sh:${PORTSDIR}/devel/gnome-common \
+ gsettings-desktop-schemas>=3.4.0:${PORTSDIR}/devel/gsettings-desktop-schemas
+LIB_DEPENDS= libstartup-notification-1.so:${PORTSDIR}/x11/startup-notification \
+ libclutter-glx-1.0.so:${PORTSDIR}/graphics/clutter \
+ libcanberra-gtk3.so:${PORTSDIR}/audio/libcanberra-gtk3 \
+ libcinnamon-desktop.so:${PORTSDIR}/x11/cinnamon-desktop
+RUN_DEPENDS= zenity>=3.0.0:${PORTSDIR}/x11/zenity
+
+USES= autoreconf:build execinfo gettext libtool gmake \
+ pathfix pkgconfig python:2
+USE_GNOME= gconf2 gnomedocutils gnomeprefix gtk30 \
+ intlhack introspection:build
+USE_XORG= x11 xext xrandr xcomposite xcursor xinerama ice sm
+USE_LDCONFIG= yes
+USE_CSTD= gnu89
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include -Wno-error=unused-function
+CFLAGS+= -I${LOCALBASE}/include -Wno-error=unused-function
+LDFLAGS+= -L${LOCALBASE}/lib
+PATHFIX_MAKEFILEIN= Makefile.am
+CONFIGURE_ENV= LIBS="-lexecinfo"
+CONFIGURE_ARGS= --enable-compile-warnings=maximum
+MAKE_ARGS= V=1
+GLIB_SCHEMAS= org.cinnamon.muffin.gschema.xml
+INSTALL_TARGET= install-strip
+
+pre-configure:
+ @cd ${WRKSRC} && ${SETENV} NOCONFIGURE=yes ${SH} autogen.sh
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|REQUIRED_AUTOMAKE_VERSION=1.10|REQUIRED_AUTOMAKE_VERSION=1.14|g' \
+ ${WRKSRC}/autogen.sh
+
+.include <bsd.port.mk>
diff --git a/x11-wm/muffin/distinfo b/x11-wm/muffin/distinfo
new file mode 100644
index 000000000000..0331b5e92b60
--- /dev/null
+++ b/x11-wm/muffin/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gnome3/muffin-2.2.6.tar.gz) = 5617504f5f8ecaf53268787728e6b7bf5da1514d9bc538dd0c047d467cca9ccf
+SIZE (gnome3/muffin-2.2.6.tar.gz) = 2705497
diff --git a/x11-wm/muffin/files/patch-src_core_main.c b/x11-wm/muffin/files/patch-src_core_main.c
new file mode 100644
index 000000000000..a248e943ac3b
--- /dev/null
+++ b/x11-wm/muffin/files/patch-src_core_main.c
@@ -0,0 +1,14 @@
+--- src/core/main.c.orig 2010-02-12 12:17:38.000000000 -0500
++++ src/core/main.c 2010-02-19 01:22:45.000000000 -0500
+@@ -59,7 +59,11 @@
+
+ #include <stdlib.h>
+ #include <sys/types.h>
++#ifdef __linux__
+ #include <wait.h>
++#else
++#include <sys/wait.h>
++#endif
+ #include <stdio.h>
+ #include <string.h>
+ #include <signal.h>
diff --git a/x11-wm/muffin/pkg-descr b/x11-wm/muffin/pkg-descr
new file mode 100644
index 000000000000..17ce72bcfb58
--- /dev/null
+++ b/x11-wm/muffin/pkg-descr
@@ -0,0 +1,9 @@
+Muffin is a minimal X window manager aimed at nontechnical users and is
+designed to integrate well with the GNOME desktop. Muffin lacks some
+features that may be expected by traditional UNIX or other technical
+users; these users may want to investigate other available window man-
+agers for use with GNOME or standalone.
+
+Based on Mutter 3.2.1
+
+WWW: http://cinnamon.linuxmint.com/
diff --git a/x11-wm/muffin/pkg-plist b/x11-wm/muffin/pkg-plist
new file mode 100644
index 000000000000..7817f3093d44
--- /dev/null
+++ b/x11-wm/muffin/pkg-plist
@@ -0,0 +1,136 @@
+bin/muffin
+bin/muffin-message
+bin/muffin-theme-viewer
+bin/muffin-window-demo
+include/muffin/meta/atomnames.h
+include/muffin/meta/boxes.h
+include/muffin/meta/common.h
+include/muffin/meta/compositor-muffin.h
+include/muffin/meta/compositor.h
+include/muffin/meta/display.h
+include/muffin/meta/errors.h
+include/muffin/meta/gradient.h
+include/muffin/meta/group.h
+include/muffin/meta/keybindings.h
+include/muffin/meta/main.h
+include/muffin/meta/meta-background-actor.h
+include/muffin/meta/meta-plugin.h
+include/muffin/meta/meta-shadow-factory.h
+include/muffin/meta/meta-shaped-texture.h
+include/muffin/meta/meta-window-actor.h
+include/muffin/meta/prefs.h
+include/muffin/meta/preview-widget.h
+include/muffin/meta/screen.h
+include/muffin/meta/theme.h
+include/muffin/meta/types.h
+include/muffin/meta/util.h
+include/muffin/meta/window.h
+include/muffin/meta/workspace.h
+lib/libmuffin.a
+lib/libmuffin.so
+lib/libmuffin.so.0
+lib/libmuffin.so.0.0.0
+lib/muffin/Meta-Muffin.0.gir
+lib/muffin/Meta-Muffin.0.typelib
+lib/muffin/plugins/default.so
+libdata/pkgconfig/libmuffin.pc
+libdata/pkgconfig/muffin-plugins.pc
+man/man1/muffin-message.1.gz
+man/man1/muffin-theme-viewer.1.gz
+man/man1/muffin-window-demo.1.gz
+man/man1/muffin.1.gz
+share/applications/muffin.desktop
+share/GConf/gsettings/muffin-schemas.convert
+share/locale/am/LC_MESSAGES/muffin.mo
+share/locale/ar/LC_MESSAGES/muffin.mo
+share/locale/as/LC_MESSAGES/muffin.mo
+share/locale/ast/LC_MESSAGES/muffin.mo
+share/locale/az/LC_MESSAGES/muffin.mo
+share/locale/be/LC_MESSAGES/muffin.mo
+share/locale/be@latin/LC_MESSAGES/muffin.mo
+share/locale/bg/LC_MESSAGES/muffin.mo
+share/locale/bn/LC_MESSAGES/muffin.mo
+share/locale/bn_IN/LC_MESSAGES/muffin.mo
+share/locale/br/LC_MESSAGES/muffin.mo
+share/locale/bs/LC_MESSAGES/muffin.mo
+share/locale/ca/LC_MESSAGES/muffin.mo
+share/locale/ca@valencia/LC_MESSAGES/muffin.mo
+share/locale/cs/LC_MESSAGES/muffin.mo
+share/locale/cy/LC_MESSAGES/muffin.mo
+share/locale/da/LC_MESSAGES/muffin.mo
+share/locale/de/LC_MESSAGES/muffin.mo
+share/locale/dz/LC_MESSAGES/muffin.mo
+share/locale/el/LC_MESSAGES/muffin.mo
+share/locale/en_CA/LC_MESSAGES/muffin.mo
+share/locale/en_GB/LC_MESSAGES/muffin.mo
+share/locale/eo/LC_MESSAGES/muffin.mo
+share/locale/es/LC_MESSAGES/muffin.mo
+share/locale/et/LC_MESSAGES/muffin.mo
+share/locale/eu/LC_MESSAGES/muffin.mo
+share/locale/fa/LC_MESSAGES/muffin.mo
+share/locale/fi/LC_MESSAGES/muffin.mo
+share/locale/fr/LC_MESSAGES/muffin.mo
+share/locale/ga/LC_MESSAGES/muffin.mo
+share/locale/gl/LC_MESSAGES/muffin.mo
+share/locale/gu/LC_MESSAGES/muffin.mo
+share/locale/ha/LC_MESSAGES/muffin.mo
+share/locale/he/LC_MESSAGES/muffin.mo
+share/locale/hi/LC_MESSAGES/muffin.mo
+share/locale/hr/LC_MESSAGES/muffin.mo
+share/locale/hu/LC_MESSAGES/muffin.mo
+share/locale/hy/LC_MESSAGES/muffin.mo
+share/locale/id/LC_MESSAGES/muffin.mo
+share/locale/ig/LC_MESSAGES/muffin.mo
+share/locale/is/LC_MESSAGES/muffin.mo
+share/locale/it/LC_MESSAGES/muffin.mo
+share/locale/ja/LC_MESSAGES/muffin.mo
+share/locale/ka/LC_MESSAGES/muffin.mo
+share/locale/kn/LC_MESSAGES/muffin.mo
+share/locale/ko/LC_MESSAGES/muffin.mo
+share/locale/ku/LC_MESSAGES/muffin.mo
+share/locale/la/LC_MESSAGES/muffin.mo
+share/locale/lt/LC_MESSAGES/muffin.mo
+share/locale/lv/LC_MESSAGES/muffin.mo
+share/locale/mai/LC_MESSAGES/muffin.mo
+share/locale/mg/LC_MESSAGES/muffin.mo
+share/locale/mk/LC_MESSAGES/muffin.mo
+share/locale/ml/LC_MESSAGES/muffin.mo
+share/locale/mn/LC_MESSAGES/muffin.mo
+share/locale/mr/LC_MESSAGES/muffin.mo
+share/locale/ms/LC_MESSAGES/muffin.mo
+share/locale/nb/LC_MESSAGES/muffin.mo
+share/locale/nds/LC_MESSAGES/muffin.mo
+share/locale/ne/LC_MESSAGES/muffin.mo
+share/locale/nl/LC_MESSAGES/muffin.mo
+share/locale/nn/LC_MESSAGES/muffin.mo
+share/locale/oc/LC_MESSAGES/muffin.mo
+share/locale/or/LC_MESSAGES/muffin.mo
+share/locale/pa/LC_MESSAGES/muffin.mo
+share/locale/pl/LC_MESSAGES/muffin.mo
+share/locale/pt/LC_MESSAGES/muffin.mo
+share/locale/pt_BR/LC_MESSAGES/muffin.mo
+share/locale/ro/LC_MESSAGES/muffin.mo
+share/locale/ru/LC_MESSAGES/muffin.mo
+share/locale/rw/LC_MESSAGES/muffin.mo
+share/locale/si/LC_MESSAGES/muffin.mo
+share/locale/sk/LC_MESSAGES/muffin.mo
+share/locale/sl/LC_MESSAGES/muffin.mo
+share/locale/sq/LC_MESSAGES/muffin.mo
+share/locale/sr/LC_MESSAGES/muffin.mo
+share/locale/sr@latin/LC_MESSAGES/muffin.mo
+share/locale/sv/LC_MESSAGES/muffin.mo
+share/locale/ta/LC_MESSAGES/muffin.mo
+share/locale/te/LC_MESSAGES/muffin.mo
+share/locale/th/LC_MESSAGES/muffin.mo
+share/locale/tk/LC_MESSAGES/muffin.mo
+share/locale/tr/LC_MESSAGES/muffin.mo
+share/locale/ug/LC_MESSAGES/muffin.mo
+share/locale/uk/LC_MESSAGES/muffin.mo
+share/locale/vi/LC_MESSAGES/muffin.mo
+share/locale/wa/LC_MESSAGES/muffin.mo
+share/locale/xh/LC_MESSAGES/muffin.mo
+share/locale/yo/LC_MESSAGES/muffin.mo
+share/locale/zh_CN/LC_MESSAGES/muffin.mo
+share/locale/zh_HK/LC_MESSAGES/muffin.mo
+share/locale/zh_TW/LC_MESSAGES/muffin.mo
+%%DATADIR%%/icons/muffin-window-demo.png