aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/openbox
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2014-08-15 12:20:12 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2014-08-15 12:20:12 +0000
commit2b9a01c211afcc48784c491fd320ae3ca291b941 (patch)
tree506cf0adbf640ebc3a397f6c7c9e16188cab167b /x11-wm/openbox
parent3de444736833dc7f5191bd0e90e7fb46c76fb02b (diff)
downloadports-2b9a01c211afcc48784c491fd320ae3ca291b941.tar.gz
ports-2b9a01c211afcc48784c491fd320ae3ca291b941.zip
Add SVG option for svg icons support using librsvg2. Currently,
that support is automatically enabled if the configure script finds librsvg2 installed, so having an option gives a predictable result. This option is enabled by default. Suggested by: Kamil Szczesny
Notes
Notes: svn path=/head/; revision=364966
Diffstat (limited to 'x11-wm/openbox')
-rw-r--r--x11-wm/openbox/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/x11-wm/openbox/Makefile b/x11-wm/openbox/Makefile
index df16460ee000..621bacc6f43b 100644
--- a/x11-wm/openbox/Makefile
+++ b/x11-wm/openbox/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openbox
PORTVERSION= 3.5.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11-wm
MASTER_SITES= http://openbox.org/dist/openbox/
@@ -23,8 +23,8 @@ LDFLAGS+= -L${LOCALBASE}/lib -lXext
PLIST_SUB= VERSION=${PORTVERSION:C/.[0-9]+\$//}
-OPTIONS_DEFINE= NLS IMLIB PANGO NOTIFY
-OPTIONS_DEFAULT= IMLIB PANGO NOTIFY
+OPTIONS_DEFINE= NLS IMLIB PANGO SVG NOTIFY
+OPTIONS_DEFAULT= IMLIB PANGO NOTIFY SVG
OPTIONS_SUB= yes
NLS_USES= gettext
@@ -39,6 +39,9 @@ NOTIFY_CONFIGURE_OFF= --disable-startup-notification
IMLIB_CONFIGURE_ENABLE= imlib2
IMLIB_USE= EFL=imlib2
+SVG_USE= GNOME=librsvg2
+SVG_CONFIGURE_ENABLE= librsvg
+
post-configure:
@${CHMOD} +x ${WRKSRC}/install-sh