aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/openbox
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2015-11-24 22:21:16 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2015-11-24 22:21:16 +0000
commit73321d512f56b8505fe4d807333d188f9f625cb0 (patch)
tree02c2a1da5c678dc3a33c5a94971dc67b34b44810 /x11-wm/openbox
parente74408fbbffccd9ab225fc9d6c32578b3381d140 (diff)
downloadports-73321d512f56b8505fe4d807333d188f9f625cb0.tar.gz
ports-73321d512f56b8505fe4d807333d188f9f625cb0.zip
x11-wm/openbox: fix dependencies and default package
At build time openbox tries to detect presence of some X11 extentions libs and headers and silently disables support for them if they cannot be found. When building from port, these extensions are usually available already, so user gets a fully functional package, however, when installing from package user gets a package with a limited functionality. Fix this by adding all the required dependencies to USE_XORG. PR: 204706 MFH: 2015Q4
Notes
Notes: svn path=/head/; revision=402380
Diffstat (limited to 'x11-wm/openbox')
-rw-r--r--x11-wm/openbox/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/x11-wm/openbox/Makefile b/x11-wm/openbox/Makefile
index 454b4279e031..507f9389c4a6 100644
--- a/x11-wm/openbox/Makefile
+++ b/x11-wm/openbox/Makefile
@@ -3,6 +3,7 @@
PORTNAME= openbox
PORTVERSION= 3.6
+PORTREVISION= 1
CATEGORIES= x11-wm
MASTER_SITES= http://openbox.org/dist/openbox/
@@ -14,7 +15,7 @@ LICENSE= GPLv2
GNU_CONFIGURE= yes
USES= gmake libtool pathfix pkgconfig
USE_GNOME= glib20 libxml2
-USE_XORG= xext xft
+USE_XORG= xcursor xext xft xinerama xrandr xau
USE_LDCONFIG= yes
CFLAGS+= -I${LOCALBASE}/include