aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/openbox
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2017-04-22 08:39:21 +0000
committerMartin Wilke <miwi@FreeBSD.org>2017-04-22 08:39:21 +0000
commit75b3458fc5cf12ef1aa14265fc86835696cd9864 (patch)
treee5f625cdb00b266a744580a510d2e9f52276f471 /x11-wm/openbox
parent4ce4158e2dd0f2d356fa5a2f460f456d46ed7321 (diff)
downloadports-75b3458fc5cf12ef1aa14265fc86835696cd9864.tar.gz
ports-75b3458fc5cf12ef1aa14265fc86835696cd9864.zip
- Fix shebangs
- Add missing dependency Approved by: maintainer via irc
Notes
Notes: svn path=/head/; revision=439138
Diffstat (limited to 'x11-wm/openbox')
-rw-r--r--x11-wm/openbox/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/x11-wm/openbox/Makefile b/x11-wm/openbox/Makefile
index ec34457dd651..a9c49d64fdea 100644
--- a/x11-wm/openbox/Makefile
+++ b/x11-wm/openbox/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openbox
PORTVERSION= 3.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-wm
MASTER_SITES= http://openbox.org/dist/openbox/
@@ -12,11 +12,16 @@ COMMENT= Small, fast, standards compliant, extensible window manager
LICENSE= GPLv2
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+
GNU_CONFIGURE= yes
-USES= gmake libtool pathfix pkgconfig
-USE_GNOME= glib20 libxml2
-USE_XORG= xcursor xext xft xinerama xrandr xau
+USES= gmake libtool pathfix python:run pkgconfig shebangfix
+USE_GNOME= cairo glib20 libxml2
+USE_XORG= ice sm x11 xcursor xext xft xinerama xrandr \
+ xrender xau
USE_LDCONFIG= yes
+SHEBANG_FILES= data/autostart/openbox-xdg-autostart
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lXext