aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/ratmen
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2008-03-11 22:48:42 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2008-03-11 22:48:42 +0000
commit94501ffbfb369c7124975c334eb00d9ad3453255 (patch)
tree8e17daf1e1e878ba0bb3d4fbd0db961df5f79829 /x11-wm/ratmen
parent88863d272aad40c5e1cd8db2b414e1f48d067517 (diff)
downloadports-94501ffbfb369c7124975c334eb00d9ad3453255.tar.gz
ports-94501ffbfb369c7124975c334eb00d9ad3453255.zip
Ratmen is a simple program for displaying a menu in a window. On selection is
may either run a program or simply write something on standard out. It is inspired by, and is similar in function to, 9menu and ratmenu but is muchly improved. It includes: User settings in X resources, long and short option names (using getopts), scrollable menus (if they do not fit on screen), both mouse and keyboard support, exiting on unfocus, and a decent manpage. WWW: http://www.update.uu.se/~zrajm/programs/
Notes
Notes: svn path=/head/; revision=208847
Diffstat (limited to 'x11-wm/ratmen')
-rw-r--r--x11-wm/ratmen/Makefile24
-rw-r--r--x11-wm/ratmen/distinfo3
-rw-r--r--x11-wm/ratmen/files/patch-Makefile24
-rw-r--r--x11-wm/ratmen/files/patch-ratmen.c10
-rw-r--r--x11-wm/ratmen/pkg-descr8
5 files changed, 69 insertions, 0 deletions
diff --git a/x11-wm/ratmen/Makefile b/x11-wm/ratmen/Makefile
new file mode 100644
index 000000000000..1323e4be4075
--- /dev/null
+++ b/x11-wm/ratmen/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: ratmen
+# Date created: 2008-02-20
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= ratmen
+PORTVERSION= 2.2.3
+CATEGORIES= x11-wm
+MASTER_SITES= http://www.update.uu.se/~zrajm/programs/ratmen/
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Simple program for displaying a menu in a window
+
+USE_XLIB= yes
+MAN1= ratmen.1
+PLIST_FILES= bin/ratmen
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ratmen ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/ratmen.1 ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/x11-wm/ratmen/distinfo b/x11-wm/ratmen/distinfo
new file mode 100644
index 000000000000..dccc35ce2fab
--- /dev/null
+++ b/x11-wm/ratmen/distinfo
@@ -0,0 +1,3 @@
+MD5 (ratmen-2.2.3.tar.gz) = 4cc8de0f3138d9eacb06f08292df6294
+SHA256 (ratmen-2.2.3.tar.gz) = 2672f33da616c8d239c3f6d2281d64106b1e2e936dbf833294a827c82cc4ce3e
+SIZE (ratmen-2.2.3.tar.gz) = 25026
diff --git a/x11-wm/ratmen/files/patch-Makefile b/x11-wm/ratmen/files/patch-Makefile
new file mode 100644
index 000000000000..9bd308ca0281
--- /dev/null
+++ b/x11-wm/ratmen/files/patch-Makefile
@@ -0,0 +1,24 @@
+--- ./Makefile.orig 2007-10-25 10:51:20.000000000 -0300
++++ ./Makefile 2008-02-20 17:07:36.000000000 -0300
+@@ -32,16 +32,16 @@
+ )
+
+
+-PREFIX=/usr/local
+-MANDIR=$(PREFIX)/man
++PREFIX?=/usr/local
++MANDIR=$(MANPREFIX)/man
+
+ OPTIMIZE ?= -Os
+ DEBUG ?=
+ WARN ?= -Wall -ansi -pedantic
+
+-CC = gcc
+-LIBS = -L/usr/X11R6/lib -lX11
+-CFLAGS = $(OPTIMIZE) $(WARN) $(DEBUG)
++CC ?= gcc
++LIBS = -L$(X11BASE)/lib -lX11
++CFLAGS += $(OPTIMIZE) $(WARN) $(DEBUG) -I$(X11BASE)/include
+
+ all: doc $(PROG)
+
diff --git a/x11-wm/ratmen/files/patch-ratmen.c b/x11-wm/ratmen/files/patch-ratmen.c
new file mode 100644
index 000000000000..5fb528f98e56
--- /dev/null
+++ b/x11-wm/ratmen/files/patch-ratmen.c
@@ -0,0 +1,10 @@
+--- ./ratmen.c.orig 2007-10-25 09:13:39.000000000 -0300
++++ ./ratmen.c 2008-02-20 17:08:21.000000000 -0300
+@@ -128,7 +128,6 @@
+
+
+ /* function prototypes */
+-int strcasecmp(char*, char*); /* string comparison */
+ void ask_wm_for_delete(void);
+ void reap(int);
+ void redraw_snazzy(int, int, int);
diff --git a/x11-wm/ratmen/pkg-descr b/x11-wm/ratmen/pkg-descr
new file mode 100644
index 000000000000..bae1d59318d9
--- /dev/null
+++ b/x11-wm/ratmen/pkg-descr
@@ -0,0 +1,8 @@
+Ratmen is a simple program for displaying a menu in a window. On selection is
+may either run a program or simply write something on standard out. It is
+inspired by, and is similar in function to, 9menu and ratmenu but is muchly
+improved. It includes: User settings in X resources, long and short option
+names (using getopts), scrollable menus (if they do not fit on screen), both
+mouse and keyboard support, exiting on unfocus, and a decent manpage.
+
+WWW: http://www.update.uu.se/~zrajm/programs/