aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/selectwm
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2004-01-30 14:56:25 +0000
committerPete Fritchman <petef@FreeBSD.org>2004-01-30 14:56:25 +0000
commit86f957d6653f88ab76de3503951b9da1c436ecb5 (patch)
tree1d45b106afc239916d43ff04dda2a3be6a1d7bbe /x11-wm/selectwm
parent0f13c5acaff4556eaa5e978a6a77a0a593c68a47 (diff)
downloadports-86f957d6653f88ab76de3503951b9da1c436ecb5.tar.gz
ports-86f957d6653f88ab76de3503951b9da1c436ecb5.zip
Add selectwm 0.4, a GTK application to let you select a window manager
when starting X. Submitted by: Wesley Shields <wxs@csh.rit.edu>
Notes
Notes: svn path=/head/; revision=99520
Diffstat (limited to 'x11-wm/selectwm')
-rw-r--r--x11-wm/selectwm/Makefile30
-rw-r--r--x11-wm/selectwm/distinfo1
-rw-r--r--x11-wm/selectwm/pkg-descr13
-rw-r--r--x11-wm/selectwm/pkg-plist1
4 files changed, 45 insertions, 0 deletions
diff --git a/x11-wm/selectwm/Makefile b/x11-wm/selectwm/Makefile
new file mode 100644
index 000000000000..54f0dfd5b5ef
--- /dev/null
+++ b/x11-wm/selectwm/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: selectwm
+# Date created: 13 January 2004
+# Whom: Wesley Shields <wxs@csh.rit.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= selectwm
+PORTVERSION= 0.4
+CATEGORIES= x11-wm
+MASTER_SITES= http://ordiluc.net/selectwm/
+
+MAINTAINER= wxs@csh.rit.edu
+COMMENT= A GTK application to let you select a window manager when starting X
+
+MAN1= selectwm.1
+
+USE_BZIP2= yes
+USE_GETOPT_LONG= yes
+USE_GNOME= gtk20
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,-O2,${CFLAGS},g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's,^CFLAGS =,CFLAGS +=,' -e 's,-O2,,' \
+ ${WRKSRC}/src/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/x11-wm/selectwm/distinfo b/x11-wm/selectwm/distinfo
new file mode 100644
index 000000000000..0fdad3cd407b
--- /dev/null
+++ b/x11-wm/selectwm/distinfo
@@ -0,0 +1 @@
+MD5 (selectwm-0.4.tar.bz2) = 2756cfe74a1fe062301aa6a630d47852
diff --git a/x11-wm/selectwm/pkg-descr b/x11-wm/selectwm/pkg-descr
new file mode 100644
index 000000000000..4fdecd3f8809
--- /dev/null
+++ b/x11-wm/selectwm/pkg-descr
@@ -0,0 +1,13 @@
+This is a small application (using GTK+) which lets you select your window
+manager. It looks for a file named .selectwmrc in the user's directory
+which contains a list of window managers.
+
+When you start X it should show a list which lets you choose your window
+manager (by double clicking on it with the mouse or with the arrow keys
+and the return or space key).
+
+WWW: http://ordiluc.net/selectwm/
+
+-- WXS
+Wesley Shields
+wxs@csh.rit.edu
diff --git a/x11-wm/selectwm/pkg-plist b/x11-wm/selectwm/pkg-plist
new file mode 100644
index 000000000000..a0af44b4bddb
--- /dev/null
+++ b/x11-wm/selectwm/pkg-plist
@@ -0,0 +1 @@
+bin/selectwm