aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/treewm
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-11 20:54:14 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-11 20:54:14 +0000
commit2c5918d1b587d6358ee1b2299b1ab3f9f79b4147 (patch)
treec8a236e1d2af3a56ba33aefc3e66a3c85567c619 /x11-wm/treewm
parenta5307c47a4f1c2922afd203a1a7140a882e602be (diff)
downloadports-2c5918d1b587d6358ee1b2299b1ab3f9f79b4147.tar.gz
ports-2c5918d1b587d6358ee1b2299b1ab3f9f79b4147.zip
Add treewm, a window manager that tries to implement a new concept. In addition to
the client windows the user can create desktops which can themselves contain windows and desktops. By arranging the windows in such a tree the user is able to manage his tasks efficiently. See also: http://treewm.sourceforge.net/ and http://www.informatik.uni-frankfurt.de/~polzer/treewmdurchnull/ PR: ports/61189 Submitted by: divZero <freebsd-dr@durchnull.de>
Notes
Notes: svn path=/head/; revision=97951
Diffstat (limited to 'x11-wm/treewm')
-rw-r--r--x11-wm/treewm/Makefile47
-rw-r--r--x11-wm/treewm/distinfo1
-rw-r--r--x11-wm/treewm/pkg-descr9
-rw-r--r--x11-wm/treewm/pkg-message14
-rw-r--r--x11-wm/treewm/pkg-plist13
5 files changed, 84 insertions, 0 deletions
diff --git a/x11-wm/treewm/Makefile b/x11-wm/treewm/Makefile
new file mode 100644
index 000000000000..aa6419edde09
--- /dev/null
+++ b/x11-wm/treewm/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: treewm
+# Date created: 09 Sep 2003
+# Whom: Rudolf Polzer
+#
+# $FreeBSD$
+#
+
+PORTNAME= treewm
+PORTVERSION= 0.4.5
+CATEGORIES= x11-wm
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= freebsd-dr@durchnull.de
+COMMENT= Window Manager that arranges the windows in a tree
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+PORTDOCS= AUTHORS ChangeLog INSTALL PROBLEMS README README.tiling TODO default.cfg sample.cfg
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|' ${WRKSRC}/Makefile
+
+post-build:
+ @${SED} 's|%%D%%|${DOCSDIR}|g' ${PKGDIR}/pkg-message >${PKGMESSAGE}
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/treewm
+ ${MKDIR} ${PREFIX}/share/treewm/pixmaps
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/treewm ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/xprop/xprop ${PREFIX}/bin/xprop-treewm
+ ${INSTALL_PROGRAM} ${WRKSRC}/xkill/xkill ${PREFIX}/bin/xkill-treewm
+ ${INSTALL_DATA} ${WRKSRC}/src/pixmaps/*.xpm ${PREFIX}/share/treewm/pixmaps
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for FILE in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+.endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/x11-wm/treewm/distinfo b/x11-wm/treewm/distinfo
new file mode 100644
index 000000000000..bcad54e80a9a
--- /dev/null
+++ b/x11-wm/treewm/distinfo
@@ -0,0 +1 @@
+MD5 (treewm-0.4.5.tar.bz2) = 912ef3930ca6914bf5118f7bbce3fef6
diff --git a/x11-wm/treewm/pkg-descr b/x11-wm/treewm/pkg-descr
new file mode 100644
index 000000000000..29170be3b746
--- /dev/null
+++ b/x11-wm/treewm/pkg-descr
@@ -0,0 +1,9 @@
+treewm is a window manager that tries to implement a new concept. In addition to
+the client windows the user can create desktops which can themselves contain
+windows and desktops. By arranging the windows in such a tree the user is able
+to manage his tasks efficiently.
+
+See also the author's website about treewm:
+ WWW: http://treewm.sourceforge.net/
+and mine:
+ WWW: http://www.informatik.uni-frankfurt.de/~polzer/treewmdurchnull/
diff --git a/x11-wm/treewm/pkg-message b/x11-wm/treewm/pkg-message
new file mode 100644
index 000000000000..c3153ca83fd0
--- /dev/null
+++ b/x11-wm/treewm/pkg-message
@@ -0,0 +1,14 @@
+--------------------------------------------------------------------------
+
+The treewm package has been successfully installed.
+
+NB: Sample configuration files have been installed to
+%%D%% as "default.cfg" and "sample.cfg".
+Users can look at them as well as the README in the same directory to
+write their .treewmrc in their homedir. Also, please take a look at
+
+ WWW: http://www.informatik.uni-frankfurt.de/~polzer/treewmdurchnull/downloads/treewm-examples-en.tar.bz2
+
+for further hints and examples about configuring treewm.
+
+--------------------------------------------------------------------------
diff --git a/x11-wm/treewm/pkg-plist b/x11-wm/treewm/pkg-plist
new file mode 100644
index 000000000000..c7ea3646e2f6
--- /dev/null
+++ b/x11-wm/treewm/pkg-plist
@@ -0,0 +1,13 @@
+bin/treewm
+bin/xprop-treewm
+bin/xkill-treewm
+share/treewm/pixmaps/close.xpm
+share/treewm/pixmaps/icon.xpm
+share/treewm/pixmaps/max1.xpm
+share/treewm/pixmaps/max2.xpm
+share/treewm/pixmaps/move.xpm
+share/treewm/pixmaps/none1.xpm
+share/treewm/pixmaps/none2.xpm
+share/treewm/pixmaps/resize.xpm
+@dirrm share/treewm/pixmaps
+@dirrm share/treewm