aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/treewm
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2012-12-21 09:26:59 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2012-12-21 09:26:59 +0000
commitd1ca6d14c7b70fdb9deb21a469c0b81adb3d090b (patch)
treed69559817e579a368f0b8a50aefc6936772a318c /x11-wm/treewm
parentcd440334997ab3c82555ad51aa0bf70aa2174482 (diff)
downloadports-d1ca6d14c7b70fdb9deb21a469c0b81adb3d090b.tar.gz
ports-d1ca6d14c7b70fdb9deb21a469c0b81adb3d090b.zip
- Fix case usage in the COMMENT line
- Drop pretty much obvious pkg-message (including 404'ed link) - Cleanup Makefile, sort knobs, get rid of .for loops - Improve port description while here
Notes
Notes: svn path=/head/; revision=309345
Diffstat (limited to 'x11-wm/treewm')
-rw-r--r--x11-wm/treewm/Makefile27
-rw-r--r--x11-wm/treewm/files/pkg-message.in14
-rw-r--r--x11-wm/treewm/pkg-descr23
3 files changed, 27 insertions, 37 deletions
diff --git a/x11-wm/treewm/Makefile b/x11-wm/treewm/Makefile
index 258fa9e468f6..03421e4c1780 100644
--- a/x11-wm/treewm/Makefile
+++ b/x11-wm/treewm/Makefile
@@ -1,4 +1,4 @@
-# Created by: Rudolf Polzer
+# Created by: Rudolf Polzer <freebsd-dr@durchnull.de>
# $FreeBSD$
PORTNAME= treewm
@@ -8,50 +8,41 @@ CATEGORIES= x11-wm
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
-COMMENT= Window Manager that arranges the windows in a tree
+COMMENT= Window manager that arranges windows in a tree
LICENSE= GPLv2
BUILD_DEPENDS= xmkmf:${PORTSDIR}/devel/imake
-OPTIONS_DEFINE= DOCS EXAMPLES
-
USE_BZIP2= yes
-USE_XORG= x11 ice sm xext xmu xpm xt xxf86vm
USE_GMAKE= yes
+USE_XORG= x11 ice sm xext xmu xpm xt xxf86vm
MAKE_JOBS_SAFE= yes
-SUB_FILES= pkg-message
-
PORTDOCS= AUTHORS ChangeLog INSTALL PROBLEMS README README.tiling TODO
PORTEXAMPLES= default.cfg sample.cfg
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
post-patch:
- @${REINPLACE_CMD} -e \
- '/^PREFIX/s| =| ?=| ; \
- /^CXXFLAGS/s| =| ?=| ; \
+ @${REINPLACE_CMD} -e '/^PREFIX/s| =| ?=| ; /^CXXFLAGS/s| =| ?=| ; \
s|/usr/X11R6|${LOCALBASE}|g' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/treewm ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/xprop/xprop ${PREFIX}/bin/xprop-treewm
${INSTALL_PROGRAM} ${WRKSRC}/xkill/xkill ${PREFIX}/bin/xkill-treewm
- ${MKDIR} ${DATADIR}/pixmaps
+ @${MKDIR} ${DATADIR}/pixmaps
${INSTALL_DATA} ${WRKSRC}/src/pixmaps/*.xpm ${DATADIR}/pixmaps
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
-.for F in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${F} ${DOCSDIR}
-.endfor
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
-.for F in ${PORTEXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/${F} ${EXAMPLESDIR}
-.endfor
+ ${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/|} ${EXAMPLESDIR}
.endif
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/x11-wm/treewm/files/pkg-message.in b/x11-wm/treewm/files/pkg-message.in
deleted file mode 100644
index 148c6d29cfa4..000000000000
--- a/x11-wm/treewm/files/pkg-message.in
+++ /dev/null
@@ -1,14 +0,0 @@
---------------------------------------------------------------------------
-
-The treewm package has been successfully installed.
-
-NB: Sample configuration files have been installed to
-%%EXAMPLESDIR%% as "default.cfg" and "sample.cfg".
-Users can look at them as well as the README in the same directory to
-write their .treewmrc in their homedir. Also, please take a look at
-
- WWW: http://www.informatik.uni-frankfurt.de/~polzer/treewmdurchnull/downloads/treewm-examples-en.tar.bz2
-
-for further hints and examples about configuring treewm.
-
---------------------------------------------------------------------------
diff --git a/x11-wm/treewm/pkg-descr b/x11-wm/treewm/pkg-descr
index 2380e41862b6..96bb37c3bf2e 100644
--- a/x11-wm/treewm/pkg-descr
+++ b/x11-wm/treewm/pkg-descr
@@ -1,8 +1,21 @@
-treewm is a window manager that tries to implement a new concept. In addition to
-the client windows the user can create desktops which can themselves contain
-windows and desktops. By arranging the windows in such a tree the user is able
-to manage his tasks efficiently.
+treewm is a window manager that tries to implement a new concept. In addition
+to the client windows the user can create desktops which can themselves contain
+windows and desktops. By arranging the windows in such a tree the user is able
+to manage his tasks efficiently treewm is feature-rich, flexible and provides
+a powerful concept. However, treewm's look is is rather puristic, and its feel
+is not always intuitive, but with a bit of practise it should be very effective
+to use.
-More info: http://www.informatik.uni-frankfurt.de/~polzer/treewmdurchnull/
+Short feature list (some of them are quite unique among window managers):
+
+ - Allows to create desktops and to arbitrarily move windows between desktops
+ - Many options (such as sticky, autoresize, always on top, or the focus or
+ raise policy) can be set for any desktop or window
+ - Can be fully customized using the configuration file
+ - Has a very powerful (somewhat vi-like) command mode, and can be controlled
+ from shell scripts via a FIFO
+ - Icons can be placed on desktops that can execute arbitrary commands
+ - Only uses very common libraries, in particular it doesn't require GTK, Qt,
+ or anything like that
WWW: http://treewm.sourceforge.net/