aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/wmii-devel
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-03-08 20:25:55 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-03-08 20:25:55 +0000
commit505e8f2de22723254e13061429a79bae45d59751 (patch)
treebe7dd4334bba6b96bf2f0df10d676ed0a02afe64 /x11-wm/wmii-devel
parent47e58f8af59079c6ddb9e2d07b2bc10014c453b1 (diff)
downloadports-505e8f2de22723254e13061429a79bae45d59751.tar.gz
ports-505e8f2de22723254e13061429a79bae45d59751.zip
- Add port x11-wm/wmii-devel - Hg tip of wmii development
- Arrange mutual conflicts with wmii Repocopy by: marcus
Notes
Notes: svn path=/head/; revision=186925
Diffstat (limited to 'x11-wm/wmii-devel')
-rw-r--r--x11-wm/wmii-devel/Makefile39
-rw-r--r--x11-wm/wmii-devel/distinfo6
-rw-r--r--x11-wm/wmii-devel/files/patch-fbsd441
-rw-r--r--x11-wm/wmii-devel/files/patch-util.c70
-rw-r--r--x11-wm/wmii-devel/pkg-plist16
5 files changed, 100 insertions, 72 deletions
diff --git a/x11-wm/wmii-devel/Makefile b/x11-wm/wmii-devel/Makefile
index e4b4fbfcb015..ed546b4d7c01 100644
--- a/x11-wm/wmii-devel/Makefile
+++ b/x11-wm/wmii-devel/Makefile
@@ -1,36 +1,37 @@
-# New ports collection makefile for: Window Manager Improved 2
-# Date created: 02 Jun 2005
-# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+# New ports collection makefile for: wmii-devel
+# Date created: 2 June 2005
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= wmii
-DISTVERSION= 3.1
+PORTVERSION= 3.5.${CHANGESET}
CATEGORIES= x11-wm
-MASTER_SITES= http://www.suckless.org/download/ CSME
+MASTER_SITES= CENKES
-MAINTAINER= danfe@FreeBSD.org
-COMMENT= A dynamic, minimalist window manager for X11
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= A dynamic minimalist window manager
-USE_X_PREFIX= yes
+LIB_DEPENDS= ixp.0:${PORTSDIR}/devel/libixp
+RUN_DEPENDS= dmenu:${PORTSDIR}/x11/dmenu \
+ ${LOCALBASE}/9/bin/rc:${PORTSDIR}/devel/9base
+CHANGESET= 2010
+CONFLICTS= wmii-3.[0-46-9]* wmii-3.5.1*
+USE_BZIP2= yes
MAKE_ARGS= PREFIX="${PREFIX}" X11LIB="${X11BASE}/lib" \
X11INC="${X11BASE}/include" CC="${CC}" \
MANPREFIX="${MANPREFIX}/man"
-MAN1= wmii.1 wmiimenu.1 wmiir.1 wmiiwm.1
+MAN1= wmii.1 wmiiloop.1 wmiir.1 wmiiwm.1
post-patch:
- @${REINPLACE_CMD} -E 's|-O3|${CFLAGS}|; \
- s|(-[LI])\$${PREFIX}|\1${LOCALBASE}|' \
- ${WRKSRC}/config.mk
- @${REINPLACE_CMD} -e 's|cp -f $${M|${INSTALL_MAN} $${M|' \
- ${WRKSRC}/Makefile
-
-pre-install:
-.for b in wm/wmiiwm wmiimenu wmiipsel wmiir wmiisetsid wmiiwarp
- @${STRIP_CMD} ${WRKSRC}/cmd/${b}
-.endfor
+ @${REINPLACE_CMD} -e '/-[LI]/s|PREFIX|LOCALBASE|g;/^[CL].*FLAGS/s|=|+=|' ${WRKSRC}/config.mk
+ @${REINPLACE_CMD} -e '/cp -f wmiiwm/s|cp -f|${INSTALL_PROGRAM}|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|$$PLAN9|${LOCALBASE}/9|' ${WRKSRC}/wmii9rc
+ @${REINPLACE_CMD} -e 's|$$PLAN9|${LOCALBASE}/9|;1s|/.*|${LOCALBASE}/9/bin/rc -v|' ${WRKSRC}/rc/rc.wmii
+ @${REINPLACE_CMD} -e '/strlcat/d' ${WRKSRC}/wmii.h
+ @${FIND} ${WRKSRC}/ -name \*.bak -delete
.include <bsd.port.mk>
diff --git a/x11-wm/wmii-devel/distinfo b/x11-wm/wmii-devel/distinfo
index 2e7bcf03c57a..bd2789a71a03 100644
--- a/x11-wm/wmii-devel/distinfo
+++ b/x11-wm/wmii-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (wmii-3.1.tar.gz) = 108147a4283bd76d2a76e47bb0c96bac
-SHA256 (wmii-3.1.tar.gz) = 93428a4defcff9e14f28b907f227d5657066a983a9ef5f4a6d4e5fab56e7716b
-SIZE (wmii-3.1.tar.gz) = 60935
+MD5 (wmii-3.5.2010.tar.bz2) = 2218f15c3a96aa0496ebef5abc27350d
+SHA256 (wmii-3.5.2010.tar.bz2) = d2d278e7fec3315fad025d3c42d64d710f750b35e77784038d2f987d4efd0938
+SIZE (wmii-3.5.2010.tar.bz2) = 57284
diff --git a/x11-wm/wmii-devel/files/patch-fbsd4 b/x11-wm/wmii-devel/files/patch-fbsd4
deleted file mode 100644
index 061880d192c7..000000000000
--- a/x11-wm/wmii-devel/files/patch-fbsd4
+++ /dev/null
@@ -1,41 +0,0 @@
---- cmd/wm/client.c.orig Sat Jun 17 18:44:30 2006
-+++ cmd/wm/client.c Wed Oct 4 06:17:02 2006
-@@ -129,15 +129,20 @@
- void
- focus_client(Client *c, Bool restack)
- {
-+ Client *old, *old_in_area;
-+ Frame *f;
-+ View *v;
-+ int i;
-+ static char buf[256];
-+
- if (!sel_screen)
- return;
-
-- Client *old = sel_client();
-- Frame *f = c->frame.data[c->sel];
-- Client *old_in_area = sel_client_of_area(f->area);
-- View *v = f->area->view;
-- int i = idx_of_area(f->area);
-- static char buf[256];
-+ old = sel_client();
-+ f = c->frame.data[c->sel];
-+ old_in_area = sel_client_of_area(f->area);
-+ v = f->area->view;
-+ i = idx_of_area(f->area);
-
- v->sel = i;
- f->area->sel = idx_of_frame(f);
---- libixp/client.c.orig Sat Jun 17 18:44:30 2006
-+++ libixp/client.c Wed Oct 4 06:17:14 2006
-@@ -6,8 +6,8 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
--#include <sys/socket.h>
- #include <sys/types.h>
-+#include <sys/socket.h>
- #include <unistd.h>
-
- #include "ixp.h"
diff --git a/x11-wm/wmii-devel/files/patch-util.c b/x11-wm/wmii-devel/files/patch-util.c
new file mode 100644
index 000000000000..d4bcc28f4f26
--- /dev/null
+++ b/x11-wm/wmii-devel/files/patch-util.c
@@ -0,0 +1,70 @@
+--- ./util.c.orig Sun Mar 4 19:55:23 2007
++++ ./util.c Sun Mar 4 19:55:30 2007
+@@ -79,67 +79,3 @@
+ return s;
+ return "<nil>";
+ }
+-
+-/*
+- * Copyright (c) 1998 Todd C. Miller <Todd.Miller@courtesan.com>
+- * All rights reserved.
+- *
+- * Redistribution and use in source and binary forms, with or without
+- * modification, are permitted provided that the following conditions
+- * are met:
+- * 1. Redistributions of source code must retain the above copyright
+- * notice, this list of conditions and the following disclaimer.
+- * 2. Redistributions in binary form must reproduce the above copyright
+- * notice, this list of conditions and the following disclaimer in the
+- * documentation and/or other materials provided with the distribution.
+- * 3. The name of the author may not be used to endorse or promote products
+- * derived from this software without specific prior written permission.
+- *
+- * THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES,
+- * INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY
+- * AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL
+- * THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
+- * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+- * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+- * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+- * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+- * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+- * ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+- */
+-
+-/*
+- * Appends src to string dst of size siz (unlike strncat, siz is the
+- * full size of dst, not space left). At most siz-1 characters
+- * will be copied. Always NUL terminates (unless siz <= strlen(dst)).
+- * Returns strlen(src) + MIN(siz, strlen(initial dst)).
+- * If retval >= siz, truncation occurred.
+- */
+-uint
+-strlcat(char *dst, const char *src, unsigned int siz) {
+- const char *s;
+- char *d;
+- unsigned int n, dlen;
+-
+- n = siz;
+- s = src;
+- d = dst;
+-
+- /* Find the end of dst and adjust bytes left but don't go past end */
+- while (n-- != 0 && *d != '\0')
+- d++;
+- dlen = d - dst;
+- n = siz - dlen;
+-
+- if (n == 0)
+- return(dlen + strlen(s));
+- while (*s != '\0') {
+- if (n != 1) {
+- *d++ = *s;
+- n--;
+- }
+- s++;
+- }
+- *d = '\0';
+-
+- return(dlen + (s - src)); /* count does not include NUL */
+-}
diff --git a/x11-wm/wmii-devel/pkg-plist b/x11-wm/wmii-devel/pkg-plist
index 263e0fb26f3b..915b958938c3 100644
--- a/x11-wm/wmii-devel/pkg-plist
+++ b/x11-wm/wmii-devel/pkg-plist
@@ -1,12 +1,10 @@
bin/wmii
-bin/wmiimenu
-bin/wmiipsel
+bin/wmii9menu
+bin/wmii9rc
+bin/wmiiloop
bin/wmiir
-bin/wmiisetsid
-bin/wmiiwarp
bin/wmiiwm
-etc/wmii-3/quit
-etc/wmii-3/status
-etc/wmii-3/welcome
-etc/wmii-3/wmiirc
-@dirrm etc/wmii-3
+etc/wmii-3.5/rc.wmii
+etc/wmii-3.5/welcome
+etc/wmii-3.5/wmiirc
+@dirrm etc/wmii-3.5