aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/wmii
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2005-06-02 11:27:59 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2005-06-02 11:27:59 +0000
commit4d2a4726d9b5ac74dbb0b811a8ca5f1b7d9d3226 (patch)
tree54d5bf2a8f1648f9cfd247ae08a6d1bc07be7329 /x11-wm/wmii
parentf19f5e494590d524490da2550d5709578dd72006 (diff)
downloadports-4d2a4726d9b5ac74dbb0b811a8ca5f1b7d9d3226.tar.gz
ports-4d2a4726d9b5ac74dbb0b811a8ca5f1b7d9d3226.zip
Add wmii, a lightweight window manager.
Notes
Notes: svn path=/head/; revision=136670
Diffstat (limited to 'x11-wm/wmii')
-rw-r--r--x11-wm/wmii/Makefile50
-rw-r--r--x11-wm/wmii/distinfo2
-rw-r--r--x11-wm/wmii/pkg-descr14
-rw-r--r--x11-wm/wmii/pkg-plist19
4 files changed, 85 insertions, 0 deletions
diff --git a/x11-wm/wmii/Makefile b/x11-wm/wmii/Makefile
new file mode 100644
index 000000000000..4e18d57978e5
--- /dev/null
+++ b/x11-wm/wmii/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: Window Manager Improved 2
+# Date created: 02 Jun 2005
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wmii
+DISTVERSION= 1
+CATEGORIES= x11-wm
+MASTER_SITES= http://wmi.modprobe.de/download/
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= The next generation of WMI window manager
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+
+MAKE_ARGS= PREFIX="${PREFIX}" X11DIR="${X11BASE}" CC="${CC}" \
+ MANPREFIX="${PREFIX}/man"
+
+OPTIONS= CAIRO "Enable Cairo rendering backend" on \
+ STRL "Use strlcpy()/strlcat() functions" off
+
+MAN1= wmibar.1 wmifs.1 wmii.1 wmiinput.1 wmikeys.1 wmiplumb.1 \
+ wmir.1 wmiwarp.1
+MAN5= wmii.rc.5
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_CAIRO)
+LIB_DEPENDS= cairo.1:${PORTSDIR}/graphics/cairo
+MAKE_ARGS+= DRAW=cairo
+.endif
+
+.if defined(WITH_STRL)
+MAKE_ARGS+= STRLCPY="strlcpy" STRLCAT="strlcat"
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/include|${LOCALBASE}/include|' \
+ -e 's|/usr/lib|${LOCALBASE}/lib|' \
+ -e 's|-O0 -g -Wall -pedantic|${CFLAGS}|; s|-g||' \
+ ${WRKSRC}/config.mk
+.if defined(WITH_CAIRO)
+ @${REINPLACE_CMD} -e 's,^#CAIRO,CAIRO,' ${WRKSRC}/config.mk
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-wm/wmii/distinfo b/x11-wm/wmii/distinfo
new file mode 100644
index 000000000000..3375907456a4
--- /dev/null
+++ b/x11-wm/wmii/distinfo
@@ -0,0 +1,2 @@
+MD5 (wmii-1.tar.bz2) = 160f0f59138df262a9ea9764dfa5655e
+SIZE (wmii-1.tar.bz2) = 71003
diff --git a/x11-wm/wmii/pkg-descr b/x11-wm/wmii/pkg-descr
new file mode 100644
index 000000000000..40d54c1e0a52
--- /dev/null
+++ b/x11-wm/wmii/pkg-descr
@@ -0,0 +1,14 @@
+Window Manager Improved 2 is the next generation of the WMI project. Due
+to a complete rewrite it is highly modularized and uses a new configuration
+and inter-process communication interface which is based on the 9p protocol
+from the Plan 9 operating system. It achieves following goals:
+
+ * Reduction of compile time
+ * Reduction of memory usage
+ * Reduction of lines of code
+ * Performance improvements
+ * Improved rendering capabilities (optional Cairo)
+ * Improved configuration and IPC interface (Libixp)
+ * Modularized components
+
+WWW: http://wmi.modprobe.de/
diff --git a/x11-wm/wmii/pkg-plist b/x11-wm/wmii/pkg-plist
new file mode 100644
index 000000000000..ab4f21bbe762
--- /dev/null
+++ b/x11-wm/wmii/pkg-plist
@@ -0,0 +1,19 @@
+bin/wmibar
+bin/wmifs
+bin/wmii
+bin/wmiinput
+bin/wmikeys
+bin/wmiplumb
+bin/wmir
+bin/wmiwarp
+etc/wmii/actions
+etc/wmii/bar
+etc/wmii/input
+etc/wmii/keys
+etc/wmii/rc
+etc/wmii/rc.conf
+etc/wmii/status.sh
+etc/wmii/wmii
+@dirrm etc/wmii
+%%DATADIR%%/welcome.txt
+@dirrm %%DATADIR%%