aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/xfce4-desktop
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-05-25 16:51:40 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-05-25 16:51:40 +0000
commit1df39a5fb17c0bb2418a5560b3a28cf1a7f8d2a1 (patch)
tree957016e38f3df9d60491551bb27ea18c106f8e71 /x11-wm/xfce4-desktop
parent07e52958d406df264b2e023e577925c528eb89d3 (diff)
downloadports-1df39a5fb17c0bb2418a5560b3a28cf1a7f8d2a1.tar.gz
ports-1df39a5fb17c0bb2418a5560b3a28cf1a7f8d2a1.zip
- Welcome XFCE 4.10 to the portstree!
Special Thanks to: rene, Olivier Duchateau <duchateau.olivier@gmail.com> Submitted by: Olivier Duchateau <duchateau.olivier@gmail.com> Tested by: phw
Notes
Notes: svn path=/head/; revision=297441
Diffstat (limited to 'x11-wm/xfce4-desktop')
-rw-r--r--x11-wm/xfce4-desktop/Makefile19
-rw-r--r--x11-wm/xfce4-desktop/distinfo4
-rw-r--r--x11-wm/xfce4-desktop/files/patch-src::xfce-desktop-menu.c12
-rw-r--r--x11-wm/xfce4-desktop/files/patch-src::xfdesktop-file-utils.c12
-rw-r--r--x11-wm/xfce4-desktop/pkg-descr10
-rw-r--r--x11-wm/xfce4-desktop/pkg-plist80
6 files changed, 17 insertions, 120 deletions
diff --git a/x11-wm/xfce4-desktop/Makefile b/x11-wm/xfce4-desktop/Makefile
index f5b4fd7a5db3..83fea8624484 100644
--- a/x11-wm/xfce4-desktop/Makefile
+++ b/x11-wm/xfce4-desktop/Makefile
@@ -6,17 +6,14 @@
#
PORTNAME= xfce4-desktop
-PORTVERSION= 4.8.3
+PORTVERSION= 4.10.0
CATEGORIES= x11-wm xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
-MASTER_SITE_SUBDIR= src/xfce/xfdesktop/${PORTVERSION:R}
DISTNAME= xfdesktop-${PORTVERSION}
DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
-COMMENT= Xfce 4 desktop background manager and root menu
-
-DOCSDIR= ${PREFIX}/share/doc/xfdesktop
+COMMENT= Xfce's desktop manager
LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
wnck-1.22:${PORTSDIR}/x11-toolkits/libwnck \
@@ -28,10 +25,10 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= glib20 gnomehack gtk20 intltool intlhack pkgconfig \
desktopfileutils
-USE_XFCE= configenv garcon libmenu libutil xfconf
+USE_XFCE= configenv garcon libmenu libutil libexo xfconf
-CONFIGURE_ARGS+= --enable-gio-unix \
- --enable-notifications
+CONFIGURE_ARGS+=--enable-gio-unix \
+ --enable-notifications
OPTIONS= THUNAR "Enable thunar support" on \
NLS "Enable Native Language Support" on
@@ -41,10 +38,10 @@ MAN1= xfdesktop.1
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_THUNAR)
-CONFIGURE_ARGS+=--enable-thunarx --enable-exo
-USE_XFCE+= libexo thunar
+CONFIGURE_ARGS+=--enable-thunarx --with-file-manager-fallback=Thunar
+USE_XFCE+= thunar
.else
-CONFIGURE_ARGS+=--disable-thunarx --disable-exo
+CONFIGURE_ARGS+=--disable-thunarx --without-file-manager-fallback
.endif
.if !defined(WITHOUT_NLS)
diff --git a/x11-wm/xfce4-desktop/distinfo b/x11-wm/xfce4-desktop/distinfo
index 093b97693fce..dd6d262e2abc 100644
--- a/x11-wm/xfce4-desktop/distinfo
+++ b/x11-wm/xfce4-desktop/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfce4/xfdesktop-4.8.3.tar.bz2) = e58460f52ae96c389402f6db62c46db61cd51cdb550a42bd97c0ab2a5b62f424
-SIZE (xfce4/xfdesktop-4.8.3.tar.bz2) = 2693819
+SHA256 (xfce4/xfdesktop-4.10.0.tar.bz2) = 897ae6ee435dcc89809ad70c15c5d15347d1cf4fc8033238b17dcc47836c2d7b
+SIZE (xfce4/xfdesktop-4.10.0.tar.bz2) = 1098862
diff --git a/x11-wm/xfce4-desktop/files/patch-src::xfce-desktop-menu.c b/x11-wm/xfce4-desktop/files/patch-src::xfce-desktop-menu.c
deleted file mode 100644
index 7de09a7a8674..000000000000
--- a/x11-wm/xfce4-desktop/files/patch-src::xfce-desktop-menu.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/xfce-desktop-menu.c.orig 2010-12-04 06:20:14.000000000 -0600
-+++ src/xfce-desktop-menu.c 2011-03-05 19:58:16.416523605 -0600
-@@ -99,7 +99,8 @@ xfce_desktop_menu_reload(XfceDesktopMenu
- * recursively. same deal for _something_changed(). */
- DBG("Schedule menu reload");
- if(!desktop_menu->idle_id)
-- desktop_menu->idle_id = g_idle_add(_generate_menu_idled, desktop_menu);
-+ /* just regen when idle. */
-+ _generate_menu(desktop_menu);
- }
-
- /*
diff --git a/x11-wm/xfce4-desktop/files/patch-src::xfdesktop-file-utils.c b/x11-wm/xfce4-desktop/files/patch-src::xfdesktop-file-utils.c
deleted file mode 100644
index 4c19b11441a5..000000000000
--- a/x11-wm/xfce4-desktop/files/patch-src::xfdesktop-file-utils.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./src/xfdesktop-file-utils.c.orig 2011-04-22 13:21:52.000000000 -0500
-+++ ./src/xfdesktop-file-utils.c 2011-04-27 12:32:33.676427006 -0500
-@@ -49,7 +49,9 @@
-
- #include <libxfce4ui/libxfce4ui.h>
-
-+#ifdef HAVE_LIBEXO
- #include <exo/exo.h>
-+#endif
-
- #include <dbus/dbus-glib-lowlevel.h>
-
diff --git a/x11-wm/xfce4-desktop/pkg-descr b/x11-wm/xfce4-desktop/pkg-descr
index 582c654b911a..f22117d413d5 100644
--- a/x11-wm/xfce4-desktop/pkg-descr
+++ b/x11-wm/xfce4-desktop/pkg-descr
@@ -1,8 +1,4 @@
-The desktop manager sets the background image, provides a right-click
-menu to launch applications and can optionally show files (including
-application launchers) or iconified windows. It includes gradient
-support for background color, saturation support for background image,
-real multiscreen and xinerama support, and it provides a desktop menu
-editor.
+The desktop manager sets the background image, and provides a root
+window menu, desktop icons or minimized icons and windows list.
-WWW: http://www.xfce.org/projects/xfdesktop/
+WWW: http://docs.xfce.org/xfce/xfdesktop/start
diff --git a/x11-wm/xfce4-desktop/pkg-plist b/x11-wm/xfce4-desktop/pkg-plist
index 55d3b9fe4905..56bb61a35f48 100644
--- a/x11-wm/xfce4-desktop/pkg-plist
+++ b/x11-wm/xfce4-desktop/pkg-plist
@@ -1,52 +1,7 @@
bin/xfdesktop
bin/xfdesktop-settings
share/applications/xfce-backdrop-settings.desktop
-%%DOCSDIR%%/html/C/images/root_menu.png
-%%DOCSDIR%%/html/C/images/root_menu2.png
-%%DOCSDIR%%/html/C/images/select_bg_color.png
-%%DOCSDIR%%/html/C/images/xfdesktop-background-tab.png
-%%DOCSDIR%%/html/C/images/xfdesktop-icons-tab.png
-%%DOCSDIR%%/html/C/images/xfdesktop-menus-tab.png
-%%DOCSDIR%%/html/C/index.html
-%%DOCSDIR%%/html/bn/images
-%%DOCSDIR%%/html/bn/index.html
-%%DOCSDIR%%/html/ca/images
-%%DOCSDIR%%/html/ca/index.html
-%%DOCSDIR%%/html/da/images
-%%DOCSDIR%%/html/da/index.html
-%%DOCSDIR%%/html/el/images
-%%DOCSDIR%%/html/el/index.html
-%%DOCSDIR%%/html/fr/images/root_menu.png
-%%DOCSDIR%%/html/fr/images/root_menu2.png
-%%DOCSDIR%%/html/fr/images/select_bg_color.png
-%%DOCSDIR%%/html/fr/images/xfdesktop-background-tab.png
-%%DOCSDIR%%/html/fr/images/xfdesktop-icons-tab.png
-%%DOCSDIR%%/html/fr/images/xfdesktop-menus-tab.png
-%%DOCSDIR%%/html/fr/index.html
-%%DOCSDIR%%/html/gl/images
-%%DOCSDIR%%/html/gl/index.html
-%%DOCSDIR%%/html/id/images
-%%DOCSDIR%%/html/id/index.html
-%%DOCSDIR%%/html/it/images
-%%DOCSDIR%%/html/it/index.html
-%%DOCSDIR%%/html/ja/images/root_menu.png
-%%DOCSDIR%%/html/ja/images/root_menu2.png
-%%DOCSDIR%%/html/ja/images/select_bg_color.png
-%%DOCSDIR%%/html/ja/images/xfdesktop-background-tab.png
-%%DOCSDIR%%/html/ja/images/xfdesktop-icons-tab.png
-%%DOCSDIR%%/html/ja/images/xfdesktop-menus-tab.png
-%%DOCSDIR%%/html/ja/index.html
-%%DOCSDIR%%/html/ru/images
-%%DOCSDIR%%/html/ru/index.html
-%%DOCSDIR%%/html/sv/images
-%%DOCSDIR%%/html/sv/index.html
-%%DOCSDIR%%/html/tr/images
-%%DOCSDIR%%/html/tr/index.html
-%%DOCSDIR%%/html/ug/images
-%%DOCSDIR%%/html/ug/index.html
-%%DOCSDIR%%/html/xfdesktop.css
-%%DOCSDIR%%/html/zh_CN/images
-%%DOCSDIR%%/html/zh_CN/index.html
+share/backgrounds/xfce/xfce-blue.jpg
share/icons/hicolor/32x32/apps/xfce4-backdrop.png
share/icons/hicolor/32x32/apps/xfce4-menueditor.png
share/icons/hicolor/48x48/apps/xfce4-backdrop.png
@@ -97,6 +52,7 @@ share/icons/hicolor/scalable/apps/xfce4-menueditor.svg
%%NLS%%share/locale/ms/LC_MESSAGES/xfdesktop.mo
%%NLS%%share/locale/nb/LC_MESSAGES/xfdesktop.mo
%%NLS%%share/locale/nl/LC_MESSAGES/xfdesktop.mo
+%%NLS%%share/locale/nn/LC_MESSAGES/xfdesktop.mo
%%NLS%%share/locale/pa/LC_MESSAGES/xfdesktop.mo
%%NLS%%share/locale/pl/LC_MESSAGES/xfdesktop.mo
%%NLS%%share/locale/pt/LC_MESSAGES/xfdesktop.mo
@@ -123,18 +79,8 @@ share/pixmaps/xfce4_xicon2.png
share/pixmaps/xfce4_xicon3.png
share/pixmaps/xfce4_xicon4.png
share/pixmaps/xfdesktop/xfdesktop-fallback-icon.png
-share/xfce4/backdrops/xfce-in-a-grid.png
-share/xfce4/backdrops/xfce-in-the-moon.png
-share/xfce4/backdrops/xfce-smoke.png
-share/xfce4/backdrops/xfce-stellar-tile.png
-share/xfce4/backdrops/xfce-stripes.png
-share/xfce4/backdrops/xfce-turbulence.png
-share/xfce4/backdrops/xfce4gradientcurve.png
-share/xfce4/backdrops/xfce4logo.png
@exec %%LOCALBASE%%/bin/update-desktop-database >/dev/null || /usr/bin/true
@unexec %%LOCALBASE%%/bin/update-desktop-database >/dev/null || /usr/bin/true
-@dirrm share/xfce4/backdrops
-@dirrmtry share/xfce4
@dirrm share/pixmaps/xfdesktop
%%NLS%%@dirrmtry share/locale/ur_PK/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/ur_PK
@@ -158,23 +104,5 @@ share/xfce4/backdrops/xfce4logo.png
%%NLS%%@dirrmtry share/locale/bn_IN
%%NLS%%@dirrmtry share/locale/ast/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/ast
-@dirrm %%DOCSDIR%%/html/zh_CN
-@dirrm %%DOCSDIR%%/html/ug
-@dirrm %%DOCSDIR%%/html/tr
-@dirrm %%DOCSDIR%%/html/sv
-@dirrm %%DOCSDIR%%/html/ru
-@dirrm %%DOCSDIR%%/html/ja/images
-@dirrm %%DOCSDIR%%/html/ja
-@dirrm %%DOCSDIR%%/html/it
-@dirrm %%DOCSDIR%%/html/id
-@dirrm %%DOCSDIR%%/html/gl
-@dirrm %%DOCSDIR%%/html/fr/images
-@dirrm %%DOCSDIR%%/html/fr
-@dirrm %%DOCSDIR%%/html/el
-@dirrm %%DOCSDIR%%/html/da
-@dirrm %%DOCSDIR%%/html/ca
-@dirrm %%DOCSDIR%%/html/bn
-@dirrm %%DOCSDIR%%/html/C/images
-@dirrm %%DOCSDIR%%/html/C
-@dirrm %%DOCSDIR%%/html
-@dirrm %%DOCSDIR%%
+@dirrm share/backgrounds/xfce
+@dirrmtry share/backgrounds