aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/xfce4-desktop
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-05-30 16:49:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-05-30 16:49:12 +0000
commit4b68fc723bc6478544954fa1a7554ca5c269f611 (patch)
tree752bd2703b89f85a96b337b223e14ab4bb621705 /x11-wm/xfce4-desktop
parent66521294b08078847ba4c56a6423c20cf34d68f8 (diff)
downloadports-4b68fc723bc6478544954fa1a7554ca5c269f611.tar.gz
ports-4b68fc723bc6478544954fa1a7554ca5c269f611.zip
- Convert complete XFCE to new options framework
While here some extra work: - Remove 6.X gruft - Correct NOPORTDOCS - Pet portlint - Whitespaces fixes Reviewed by: beat, bapt (thx!)
Notes
Notes: svn path=/head/; revision=297800
Diffstat (limited to 'x11-wm/xfce4-desktop')
-rw-r--r--x11-wm/xfce4-desktop/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/x11-wm/xfce4-desktop/Makefile b/x11-wm/xfce4-desktop/Makefile
index 83fea8624484..480769ff284d 100644
--- a/x11-wm/xfce4-desktop/Makefile
+++ b/x11-wm/xfce4-desktop/Makefile
@@ -30,21 +30,22 @@ USE_XFCE= configenv garcon libmenu libutil libexo xfconf
CONFIGURE_ARGS+=--enable-gio-unix \
--enable-notifications
-OPTIONS= THUNAR "Enable thunar support" on \
- NLS "Enable Native Language Support" on
+OPTIONS_DEFINE= THUNAR NLS
+OPTIONS_DEFAULT= THUNAR NLS
+THUNAR_DESC= Enable thunar support
MAN1= xfdesktop.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_THUNAR)
+.if ${PORT_OPTIONS:MTHUNAR}
CONFIGURE_ARGS+=--enable-thunarx --with-file-manager-fallback=Thunar
USE_XFCE+= thunar
.else
CONFIGURE_ARGS+=--disable-thunarx --without-file-manager-fallback
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""
@@ -56,4 +57,4 @@ PLIST_SUB+= NLS="@comment "
post-install:
@-update-desktop-database
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>