aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/xfce4-panel
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2021-01-02 16:36:33 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2021-01-02 16:36:33 +0000
commitb2f2269daff8c7e224099d352e652241fbdfcb7b (patch)
tree27b902ea7af0a7d6abc54b964847536e36093b87 /x11-wm/xfce4-panel
parent0a2af555796c3880231fff24f17bf146795a8887 (diff)
downloadports-b2f2269daff8c7e224099d352e652241fbdfcb7b.tar.gz
ports-b2f2269daff8c7e224099d352e652241fbdfcb7b.zip
Welcome XFCE 4.16 to the FreeBSD ports tree!
Upstream announce: https://xfce.org/about/news/?post=1608595200 This XFCE release dropped support for GTK2 plugins and also dropped GTK2 from all components. WARNING: please check UPDATING before upgrading your packages. In case of problems also read the libexo pkg-message. Due to this some panel plugins and libraries will be removed since they cannot compile anymore: - print/xfce4-print - x11/xfce4-quicklauncher-plugin - x11/xfce4-wmdock-plugin - x11-toolkits/libxfce4gui These further components also fail to build or work and are being marked BROKEN, deprecated and marked for removal: - science/xfce4-equake-plugin - x11/xfce4-embed-plugin - deskutils/orage - deskutils/xfce4-volumed [1] deskutils/xfce4-notes-plugin will be also marked BROKEN, but there is active development in it's upstream repository and a fixed release is expected soon. deskutils/xfce4-generic-slider will also be marked broken, since it fails to compile. [2] Thanks also to riggs, Olivier Duchateau <duchateau.olivier@gmail.com> and the people in Approved and Reviewed lines below for help and contributions. Reviewed by: woodsb02 Approved by: sergey.dyatko@gmail.com (maintainer) [1], ehaupt [2] Differential Revision: https://reviews.freebsd.org/D27846
Notes
Notes: svn path=/head/; revision=559953
Diffstat (limited to 'x11-wm/xfce4-panel')
-rw-r--r--x11-wm/xfce4-panel/Makefile12
-rw-r--r--x11-wm/xfce4-panel/distinfo6
-rw-r--r--x11-wm/xfce4-panel/files/patch-plugins_pager_pager.c13
-rw-r--r--x11-wm/xfce4-panel/pkg-plist55
4 files changed, 33 insertions, 53 deletions
diff --git a/x11-wm/xfce4-panel/Makefile b/x11-wm/xfce4-panel/Makefile
index dd4f036e4a48..1824a36e2596 100644
--- a/x11-wm/xfce4-panel/Makefile
+++ b/x11-wm/xfce4-panel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= xfce4-panel
-PORTVERSION= 4.14.4
+PORTVERSION= 4.16.0
CATEGORIES= x11-wm xfce
MASTER_SITES= XFCE
DIST_SUBDIR= xfce4
@@ -16,7 +16,8 @@ LICENSE_FILE_GPLv2= ${WRKSRC}/COPYING
LICENSE_FILE_LGPL21= ${WRKSRC}/COPYING.LIB
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
- libfreetype.so:print/freetype2
+ libfreetype.so:print/freetype2 \
+ libdbusmenu-gtk3.so:devel/libdbusmenu
USES= compiler:c11 desktop-file-utils gettext-tools gmake gnome \
libtool pathfix perl5 pkgconfig tar:bzip2 xfce xorg
@@ -32,8 +33,8 @@ CONFIGURE_ARGS= --enable-gio-unix --without-html-dir
PORTSCOUT= limitw:1,even
-OPTIONS_DEFINE= GIR GTK2 NLS VAPI
-OPTIONS_DEFAULT= GIR GTK2 VAPI
+OPTIONS_DEFINE= GIR NLS VAPI
+OPTIONS_DEFAULT= GIR VAPI
OPTIONS_SUB= yes
GIR_DESC= Use Gobject Introspection
@@ -42,9 +43,6 @@ GIR_USE= gnome=introspection:build
GIR_CONFIGURE_ON= --enable-introspection=yes
GIR_CONFIGURE_OFF= --enable-introspection=no
-GTK2_USE= gnome=gtk20
-GTK2_CONFIGURE_ENABLE= gtk2
-
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext-runtime
diff --git a/x11-wm/xfce4-panel/distinfo b/x11-wm/xfce4-panel/distinfo
index 14a52461519b..b1887efdb61c 100644
--- a/x11-wm/xfce4-panel/distinfo
+++ b/x11-wm/xfce4-panel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1588078825
-SHA256 (xfce4/xfce4-panel-4.14.4.tar.bz2) = 8e5ea79412ba84cfada897ff309cbe2cd4aca16b9bd4f93df060229528576fd5
-SIZE (xfce4/xfce4-panel-4.14.4.tar.bz2) = 1307938
+TIMESTAMP = 1608682746
+SHA256 (xfce4/xfce4-panel-4.16.0.tar.bz2) = 5e979aeeb37d306d72858b1bc67448222ea7a68de01409055b846cd31f3cc53d
+SIZE (xfce4/xfce4-panel-4.16.0.tar.bz2) = 1382354
diff --git a/x11-wm/xfce4-panel/files/patch-plugins_pager_pager.c b/x11-wm/xfce4-panel/files/patch-plugins_pager_pager.c
index 64a605c24887..60998ddca727 100644
--- a/x11-wm/xfce4-panel/files/patch-plugins_pager_pager.c
+++ b/x11-wm/xfce4-panel/files/patch-plugins_pager_pager.c
@@ -3,15 +3,9 @@ From: Andre Miranda <andreldm@xfce.org>
Date: Sun, 25 Aug 2019 19:16:03 -0300
Subject: [PATCH] pager: Override WnckPager scroll-event handler (Bug #15886)
----
- plugins/pager/pager.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/plugins/pager/pager.c b/plugins/pager/pager.c
-index 5637bea6..3a64496e 100644
---- plugins/pager/pager.c
+--- plugins/pager/pager.c.orig 2020-12-10 23:14:07 UTC
+++ plugins/pager/pager.c
-@@ -445,6 +445,8 @@ G_GNUC_END_IGNORE_DEPRECATIONS
+@@ -482,6 +482,8 @@ G_GNUC_END_IGNORE_DEPRECATIONS
G_CALLBACK (pager_plugin_drag_begin_event), plugin);
g_signal_connect_after (G_OBJECT (plugin->pager), "drag-end",
G_CALLBACK (pager_plugin_drag_end_event), plugin);
@@ -20,6 +14,3 @@ index 5637bea6..3a64496e 100644
}
else
{
---
-2.23.0
-
diff --git a/x11-wm/xfce4-panel/pkg-plist b/x11-wm/xfce4-panel/pkg-plist
index 34a06bcacf45..cae1ea4a06ae 100644
--- a/x11-wm/xfce4-panel/pkg-plist
+++ b/x11-wm/xfce4-panel/pkg-plist
@@ -3,18 +3,6 @@ bin/xfce4-popup-applicationsmenu
bin/xfce4-popup-directorymenu
bin/xfce4-popup-windowmenu
etc/xdg/xfce4/panel/default.xml
-%%GTK2%%include/xfce4/libxfce4panel-1.0/libxfce4panel/libxfce4panel-config.h
-%%GTK2%%include/xfce4/libxfce4panel-1.0/libxfce4panel/libxfce4panel-enum-types.h
-%%GTK2%%include/xfce4/libxfce4panel-1.0/libxfce4panel/libxfce4panel-enums.h
-%%GTK2%%include/xfce4/libxfce4panel-1.0/libxfce4panel/libxfce4panel.h
-%%GTK2%%include/xfce4/libxfce4panel-1.0/libxfce4panel/xfce-arrow-button.h
-%%GTK2%%include/xfce4/libxfce4panel-1.0/libxfce4panel/xfce-hvbox.h
-%%GTK2%%include/xfce4/libxfce4panel-1.0/libxfce4panel/xfce-panel-convenience.h
-%%GTK2%%include/xfce4/libxfce4panel-1.0/libxfce4panel/xfce-panel-image.h
-%%GTK2%%include/xfce4/libxfce4panel-1.0/libxfce4panel/xfce-panel-macros-46.h
-%%GTK2%%include/xfce4/libxfce4panel-1.0/libxfce4panel/xfce-panel-macros.h
-%%GTK2%%include/xfce4/libxfce4panel-1.0/libxfce4panel/xfce-panel-plugin-provider.h
-%%GTK2%%include/xfce4/libxfce4panel-1.0/libxfce4panel/xfce-panel-plugin.h
include/xfce4/libxfce4panel-2.0/libxfce4panel/libxfce4panel-config.h
include/xfce4/libxfce4panel-2.0/libxfce4panel/libxfce4panel-enum-types.h
include/xfce4/libxfce4panel-2.0/libxfce4panel/libxfce4panel-enums.h
@@ -22,14 +10,10 @@ include/xfce4/libxfce4panel-2.0/libxfce4panel/libxfce4panel.h
include/xfce4/libxfce4panel-2.0/libxfce4panel/xfce-arrow-button.h
include/xfce4/libxfce4panel-2.0/libxfce4panel/xfce-panel-convenience.h
include/xfce4/libxfce4panel-2.0/libxfce4panel/xfce-panel-image.h
-include/xfce4/libxfce4panel-2.0/libxfce4panel/xfce-panel-macros-46.h
include/xfce4/libxfce4panel-2.0/libxfce4panel/xfce-panel-macros.h
include/xfce4/libxfce4panel-2.0/libxfce4panel/xfce-panel-plugin-provider.h
include/xfce4/libxfce4panel-2.0/libxfce4panel/xfce-panel-plugin.h
-%%GIR%%lib/girepository-1.0/libxfce4panel-2.0.typelib
-%%GTK2%%lib/libxfce4panel-1.0.so
-%%GTK2%%lib/libxfce4panel-1.0.so.4
-%%GTK2%%lib/libxfce4panel-1.0.so.4.0.0
+%%GIR%%lib/girepository-1.0/Libxfce4panel-2.0.typelib
lib/libxfce4panel-2.0.so
lib/libxfce4panel-2.0.so.4
lib/libxfce4panel-2.0.so.4.0.0
@@ -45,24 +29,31 @@ lib/xfce4/panel/plugins/libshowdesktop.so
lib/xfce4/panel/plugins/libsystray.so
lib/xfce4/panel/plugins/libtasklist.so
lib/xfce4/panel/plugins/libwindowmenu.so
-%%GTK2%%lib/xfce4/panel/wrapper-1.0
lib/xfce4/panel/wrapper-2.0
-%%GTK2%%libdata/pkgconfig/libxfce4panel-1.0.pc
libdata/pkgconfig/libxfce4panel-2.0.pc
share/applications/panel-desktop-handler.desktop
share/applications/panel-preferences.desktop
-%%GIR%%share/gir-1.0/libxfce4panel-2.0.gir
-share/icons/hicolor/16x16/apps/xfce4-panel-menu.png
-share/icons/hicolor/16x16/apps/xfce4-panel.png
-share/icons/hicolor/22x22/apps/xfce4-panel-menu.png
-share/icons/hicolor/22x22/apps/xfce4-panel.png
-share/icons/hicolor/24x24/apps/xfce4-panel-menu.png
-share/icons/hicolor/24x24/apps/xfce4-panel.png
-share/icons/hicolor/32x32/apps/xfce4-panel-menu.png
-share/icons/hicolor/32x32/apps/xfce4-panel.png
-share/icons/hicolor/48x48/apps/xfce4-panel-menu.png
-share/icons/hicolor/48x48/apps/xfce4-panel.png
-share/icons/hicolor/scalable/apps/xfce4-panel.svg
+%%GIR%%share/gir-1.0/Libxfce4panel-2.0.gir
+share/icons/hicolor/128x128/apps/org.xfce.panel.png
+share/icons/hicolor/16x16/apps/org.xfce.panel.applicationsmenu.png
+share/icons/hicolor/16x16/apps/org.xfce.panel.png
+share/icons/hicolor/24x24/apps/org.xfce.panel.applicationsmenu.png
+share/icons/hicolor/24x24/apps/org.xfce.panel.png
+share/icons/hicolor/32x32/apps/org.xfce.panel.actions.png
+share/icons/hicolor/32x32/apps/org.xfce.panel.applicationsmenu.png
+share/icons/hicolor/32x32/apps/org.xfce.panel.clock.png
+share/icons/hicolor/32x32/apps/org.xfce.panel.directorymenu.png
+share/icons/hicolor/32x32/apps/org.xfce.panel.launcher.png
+share/icons/hicolor/32x32/apps/org.xfce.panel.pager.png
+share/icons/hicolor/32x32/apps/org.xfce.panel.png
+share/icons/hicolor/32x32/apps/org.xfce.panel.separator.png
+share/icons/hicolor/32x32/apps/org.xfce.panel.showdesktop.png
+share/icons/hicolor/32x32/apps/org.xfce.panel.statustray.png
+share/icons/hicolor/32x32/apps/org.xfce.panel.tasklist.png
+share/icons/hicolor/32x32/apps/org.xfce.panel.windowmenu.png
+share/icons/hicolor/48x48/apps/org.xfce.panel.applicationsmenu.png
+share/icons/hicolor/48x48/apps/org.xfce.panel.png
+share/icons/hicolor/scalable/apps/org.xfce.panel.svg
%%NLS%%share/locale/am/LC_MESSAGES/xfce4-panel.mo
%%NLS%%share/locale/ar/LC_MESSAGES/xfce4-panel.mo
%%NLS%%share/locale/ast/LC_MESSAGES/xfce4-panel.mo
@@ -80,7 +71,6 @@ share/icons/hicolor/scalable/apps/xfce4-panel.svg
%%NLS%%share/locale/es/LC_MESSAGES/xfce4-panel.mo
%%NLS%%share/locale/et/LC_MESSAGES/xfce4-panel.mo
%%NLS%%share/locale/eu/LC_MESSAGES/xfce4-panel.mo
-%%NLS%%share/locale/fa_IR/LC_MESSAGES/xfce4-panel.mo
%%NLS%%share/locale/fi/LC_MESSAGES/xfce4-panel.mo
%%NLS%%share/locale/fr/LC_MESSAGES/xfce4-panel.mo
%%NLS%%share/locale/gl/LC_MESSAGES/xfce4-panel.mo
@@ -88,6 +78,7 @@ share/icons/hicolor/scalable/apps/xfce4-panel.svg
%%NLS%%share/locale/hr/LC_MESSAGES/xfce4-panel.mo
%%NLS%%share/locale/hu/LC_MESSAGES/xfce4-panel.mo
%%NLS%%share/locale/hy_AM/LC_MESSAGES/xfce4-panel.mo
+%%NLS%%share/locale/hye/LC_MESSAGES/xfce4-panel.mo
%%NLS%%share/locale/id/LC_MESSAGES/xfce4-panel.mo
%%NLS%%share/locale/ie/LC_MESSAGES/xfce4-panel.mo
%%NLS%%share/locale/is/LC_MESSAGES/xfce4-panel.mo