aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-04-07 03:44:08 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-04-07 04:19:59 +0000
commit157731dfea5228f4da2ab9188dad3351ee3eeec8 (patch)
tree3b29d43b5822f3e6d74bd94762a93af8e3174602 /x11-wm
parentebb0dd9648ac31174980ee73d160315d81f94478 (diff)
downloadports-157731dfea5228f4da2ab9188dad3351ee3eeec8.tar.gz
ports-157731dfea5228f4da2ab9188dad3351ee3eeec8.zip
x11-wm/mutter: Attempt to fix build order bug (D29353)
Uncovered while building with devel/samurai but can probably also happen with ninja eventually. In file included from ../src/core/mutter.c:26: In file included from ../src/compositor/meta-plugin-manager.h:25: In file included from ../src/core/util-private.h:30: In file included from ../src/meta/util.h:29: In file included from ../src/meta/common.h:34: In file included from ../clutter/clutter/clutter.h:32: In file included from ../clutter/clutter/clutter-types.h:32: In file included from ../cogl/cogl/cogl.h:142: ../cogl/cogl-path/cogl-path.h:55:10: fatal error: 'cogl-path/cogl-path-enum-types.h' file not found #include <cogl-path/cogl-path-enum-types.h> ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ 1 error generated. samu: subcommands failed http://package18.nyi.freebsd.org/data/122amd64-default-foo/2021-04-04_07h37m38s/logs/errors/mutter-3.36.6.log PR: 254678 Obtained from: Aports
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/mutter/files/patch-clutter_clutter_meson.build25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11-wm/mutter/files/patch-clutter_clutter_meson.build b/x11-wm/mutter/files/patch-clutter_clutter_meson.build
new file mode 100644
index 000000000000..0e6f0d08e2e1
--- /dev/null
+++ b/x11-wm/mutter/files/patch-clutter_clutter_meson.build
@@ -0,0 +1,25 @@
+This ensures that libmutter_cogl_path_dep is built before other targets,
+fixing the build with many buildjobs
+
+Obtained from: Aports
+
+--- clutter/clutter/meson.build.orig 2020-09-07 19:18:23 UTC
++++ clutter/clutter/meson.build
+@@ -424,7 +424,7 @@ libmutter_clutter = shared_library(libmutter_clutter_n
+ soversion: 0,
+ c_args: clutter_c_args,
+ include_directories: clutter_includes,
+- dependencies: [clutter_deps],
++ dependencies: [clutter_deps,libmutter_cogl_path_dep],
+ gnu_symbol_visibility: 'hidden',
+ link_with: [
+ libmutter_cogl,
+@@ -436,7 +436,7 @@ libmutter_clutter = shared_library(libmutter_clutter_n
+ install: true,
+ )
+ libmutter_clutter_dep = declare_dependency(
+- sources: [clutter_enum_types[1]],
++ sources: [clutter_enum_types[1],libmutter_cogl_path_enum_types[1]],
+ link_with: libmutter_clutter,
+ dependencies: clutter_deps,
+ )