aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-03-16 08:48:42 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-03-16 08:48:42 +0000
commit44b6e7dad1342b4be7b431ef4d88a0ae154009fa (patch)
tree8164e8be8598e1c3c4c370e2825a91acc225f173 /x11-wm
parentfdcf028dcb873af4b3de61633e98a3aa4c60f989 (diff)
downloadports-44b6e7dad1342b4be7b431ef4d88a0ae154009fa.tar.gz
ports-44b6e7dad1342b4be7b431ef4d88a0ae154009fa.zip
x11-wm/river: don't overwrite system-wide config
Notes
Notes: svn path=/head/; revision=568544
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/river/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/x11-wm/river/Makefile b/x11-wm/river/Makefile
index 5ad5df87db9f..2140e5496192 100644
--- a/x11-wm/river/Makefile
+++ b/x11-wm/river/Makefile
@@ -2,6 +2,7 @@
PORTNAME= river
PORTVERSION= s20210314
+PORTREVISION= 1
CATEGORIES= x11-wm
MAINTAINER= jbeich@FreeBSD.org
@@ -35,7 +36,7 @@ NO_INSTALL= yes # strip(1) breaks runtime
PLIST_FILES= bin/${PORTNAME} \
bin/${PORTNAME}ctl \
bin/${PORTNAME}tile \
- ${ETCDIR}/init \
+ "@sample ${ETCDIR}/init.sample" \
share/bash-completion/completions/${PORTNAME}ctl \
share/zsh/site-functions/_${PORTNAME}ctl \
${NULL}
@@ -66,4 +67,8 @@ do-build:
do-test:
@(cd ${WRKSRC} && ${TEST_ENV} zig build test ${CONFIGURE_ARGS})
+post-install:
+# Let @sample handle default files under etc/
+ @${MV} ${STAGEDIR}${ETCDIR}/init ${STAGEDIR}${ETCDIR}/init.sample
+
.include <bsd.port.mk>