aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-09-18 17:09:44 +0000
committerSteve Wills <swills@FreeBSD.org>2018-09-18 17:09:44 +0000
commit45b1e023c9717ecfdabe0497cdb72a3a6539de21 (patch)
treed983d801d0425c4c6a75d3a57ab90d689d3eeb1d /x11-wm
parentf0084422c044c6cc9d1132368a318c5e0418d5e5 (diff)
downloadports-45b1e023c9717ecfdabe0497cdb72a3a6539de21.tar.gz
ports-45b1e023c9717ecfdabe0497cdb72a3a6539de21.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/compiz-plugins-main/Makefile22
1 files changed, 16 insertions, 6 deletions
diff --git a/x11-wm/compiz-plugins-main/Makefile b/x11-wm/compiz-plugins-main/Makefile
index 1b0ca2d0be33..53345a6ca998 100644
--- a/x11-wm/compiz-plugins-main/Makefile
+++ b/x11-wm/compiz-plugins-main/Makefile
@@ -3,26 +3,30 @@
PORTNAME= compiz-plugins-main
PORTVERSION= 0.8.8
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= x11-wm
MASTER_SITES= http://releases.compiz.org/${PORTVERSION}/
MAINTAINER= freebsd-ports@dan.me.uk
COMMENT= Plugins for Compiz Composite Window Manager
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= libcairo.so:graphics/cairo \
- libpangocairo-1.0.so:x11-toolkits/pango
+ libpangocairo-1.0.so:x11-toolkits/pango \
+ libstartup-notification-1.so:x11/startup-notification
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/compiz.pc:x11-wm/compiz \
${LOCALBASE}/libdata/pkgconfig/bcop.pc:devel/compiz-bcop
RUN_DEPENDS:= ${BUILD_DEPENDS}
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USE_GL= yes
-USES= gettext gmake libtool:keepla pathfix pkgconfig tar:bzip2
+USES= gmake jpeg libtool:keepla pathfix pkgconfig tar:bzip2
USE_CSTD= gnu89
-USE_GNOME= gconf2 intltool
-USE_XORG= xorgproto
+USE_GL= yes
+USE_GNOME= gconf2 intltool libxslt
+USE_XORG= ice sm x11 xcomposite xdamage xext xfixes xinerama xorgproto xrandr xrender
USE_LDCONFIG= yes
GCONF_SCHEMAS= compiz-animation.schemas \
@@ -55,4 +59,10 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --enable-schemas
+OPTIONS_DEFINE= NLS
+OPTIONS_DEFAULT= NLS
+
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext-runtime gettext-tools
+
.include <bsd.port.mk>