aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-11-14 03:55:57 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-11-14 03:55:57 +0000
commit79957c75ea6b7ec1bee889d7cd44c156352cd77d (patch)
tree40921f83d6530a860dfbdfee1416219f2a970533 /x11-wm
parent88ba5913c9a6f83049661717dcdb8c3d181fefee (diff)
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/plwm/Makefile7
-rw-r--r--x11-wm/plwm/files/patch-plwm_outline.py12
2 files changed, 11 insertions, 8 deletions
diff --git a/x11-wm/plwm/Makefile b/x11-wm/plwm/Makefile
index 0a9573a220a7..6680d62be2f4 100644
--- a/x11-wm/plwm/Makefile
+++ b/x11-wm/plwm/Makefile
@@ -10,7 +10,8 @@ DISTNAME= ${PORTNAME:tu}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Window manager construction kit
-LICENSE= GPLv2
+LICENSE= GPLv2 # or later
+LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xlib>0:${PORTSDIR}/x11-toolkits/py-xlib
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xlib>0:${PORTSDIR}/x11-toolkits/py-xlib
@@ -31,10 +32,12 @@ post-patch:
@${REINPLACE_CMD} -e \
's|$$Id|coding: utf-8 |g' ${WRKSRC}/plwm/mw_apm.py
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/doc && ${INSTALL_DATA} *.pdf \
${STAGEDIR}${DOCSDIR})
+
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
(cd ${WRKSRC}/examples && ${INSTALL_DATA} *.examplewm *.py \
${STAGEDIR}${EXAMPLESDIR})
diff --git a/x11-wm/plwm/files/patch-plwm_outline.py b/x11-wm/plwm/files/patch-plwm_outline.py
index cb6f011c291d..3e6cacceed0f 100644
--- a/x11-wm/plwm/files/patch-plwm_outline.py
+++ b/x11-wm/plwm/files/patch-plwm_outline.py
@@ -1,6 +1,6 @@
---- plwm/outline.py.orig 2001-11-26 14:48:21.000000000 +0100
-+++ plwm/outline.py 2009-06-06 17:47:13.000000000 +0200
-@@ -63,7 +63,7 @@
+--- plwm/outline.py.orig 2001-11-26 13:48:21 UTC
++++ plwm/outline.py
+@@ -63,7 +63,7 @@ class XorOutlineClient:
if name:
self.outline_gc.set_clip_rectangles(0, 0, [coords], X.YXSorted)
@@ -9,7 +9,7 @@
self.screen.root.draw_text(self.outline_gc, sx, sy, name)
self.outline_name = (sx, sy, name)
else:
-@@ -138,8 +138,8 @@
+@@ -138,8 +138,8 @@ class WindowOutlineClient:
height = s[3] - s[1] + 1)
if name:
@@ -20,7 +20,7 @@
width = sw, height = sh)
if not self.outline_mapped:
-@@ -155,7 +155,7 @@
+@@ -155,7 +155,7 @@ class WindowOutlineClient:
# disappear otherwise...
if name:
self.outline_name_window.image_text(self.outline_name_gc,
@@ -29,7 +29,7 @@
def outline_hide(self):
if self.outline_mapped:
-@@ -246,8 +246,8 @@
+@@ -246,8 +246,8 @@ def calculate_parts(client, x, y, w, h,
sw = min(r.overall_width, w)
sh = min(r.overall_ascent + r.overall_descent, h)