aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-02-27 08:39:11 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-02-27 08:39:11 +0000
commitbe198a8850ef40a128de77d39a1e5818c60573c0 (patch)
tree9e9ee40d7dcdded376e145651ceec670c6b0e130 /x11-wm
parent353ef2d51dcb2e3459927fad647b3e1800b16de5 (diff)
downloadports-be198a8850ef40a128de77d39a1e5818c60573c0.tar.gz
ports-be198a8850ef40a128de77d39a1e5818c60573c0.zip
Make ImageMagick support optional and respect IMAGEMAGICK_DEFAULT.
Notes
Notes: svn path=/head/; revision=566678
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/libwraster/Makefile18
-rw-r--r--x11-wm/windowmaker/Makefile17
2 files changed, 31 insertions, 4 deletions
diff --git a/x11-wm/libwraster/Makefile b/x11-wm/libwraster/Makefile
index f00b0d60738a..cacce0194cea 100644
--- a/x11-wm/libwraster/Makefile
+++ b/x11-wm/libwraster/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libwraster
PORTVERSION= 0.95.9
+PORTREVISION= 1
CATEGORIES= x11-wm windowmaker
MASTER_SITES= http://windowmaker.org/pub/source/release/
DISTNAME= WindowMaker-${PORTVERSION}
@@ -15,8 +16,7 @@ LIB_DEPENDS= libgif.so:graphics/giflib \
libpng.so:graphics/png \
libjbig.so:graphics/jbigkit \
libtiff.so:graphics/tiff \
- libwebp.so:graphics/webp \
- libMagickWand-7.so:graphics/ImageMagick7
+ libwebp.so:graphics/webp
USES= jpeg libtool localbase pathfix pkgconfig xorg
USE_LDCONFIG= yes
@@ -36,6 +36,20 @@ CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
--with-x
INSTALL_TARGET= install-strip
+OPTIONS_DEFINE= IMAGEMAGICK
+OPTIONS_DEFAULT= IMAGEMAGICK
+
+IMAGEMAGICK_LIB_DEPENDS= libMagickWand-${IMAGEMAGICK_DEFAULT}.so:graphics/ImageMagick${IMAGEMAGICK_DEFAULT}
+IMAGEMAGICK_CONFIGURE_OFF= --disable-magick
+
+.include <bsd.port.options.mk>
+
+post-patch-IMAGEMAGICK-on:
+.if ${IMAGEMAGICK_DEFAULT} == 6
+ @${REINPLACE_CMD} -e '/MagickWand\.h/s,MagickWand/,wand/,' \
+ ${WRKSRC}/configure ${WRKSRC}/wrlib/load_magick.c
+.endif
+
pre-build:
cd ${WRKSRC} && ${MAKE_CMD} config-paths.h
diff --git a/x11-wm/windowmaker/Makefile b/x11-wm/windowmaker/Makefile
index 1a402a704cdb..67ba30d05992 100644
--- a/x11-wm/windowmaker/Makefile
+++ b/x11-wm/windowmaker/Makefile
@@ -3,6 +3,7 @@
PORTNAME= windowmaker
PORTVERSION= 0.95.9
+PORTREVISION= 1
CATEGORIES= x11-wm windowmaker
MASTER_SITES= http://windowmaker.org/pub/source/release/
DISTNAME= WindowMaker-${PORTVERSION}
@@ -17,7 +18,6 @@ LIB_DEPENDS= libgif.so:graphics/giflib \
libjbig.so:graphics/jbigkit \
libtiff.so:graphics/tiff \
libwebp.so:graphics/webp \
- libMagickWand-7.so:graphics/ImageMagick7 \
libwraster.so:x11-wm/libwraster \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
@@ -51,12 +51,25 @@ PORTDOCS= AUTHORS BUGFORM BUGS ChangeLog FAQ INSTALL \
INSTALL-WMAKER NEWS README README.definable-cursor \
README.i18n TODO The-perfect-Window-Maker-patch.txt
-OPTIONS_DEFINE= DOCS NLS
+OPTIONS_DEFINE= IMAGEMAGICK DOCS NLS
+OPTIONS_DEFAULT= IMAGEMAGICK
OPTIONS_SUB= yes
+
+IMAGEMAGICK_LIB_DEPENDS= libMagickWand-${IMAGEMAGICK_DEFAULT}.so:graphics/ImageMagick${IMAGEMAGICK_DEFAULT}
+IMAGEMAGICK_CONFIGURE_OFF= --disable-magick
+
NLS_USES= gettext
NLS_CONFIGURE_ENV= LINGUAS="*"
NLS_CONFIGURE_ENABLE= locale
+.include <bsd.port.options.mk>
+
+post-patch-IMAGEMAGICK-on:
+.if ${IMAGEMAGICK_DEFAULT} == 6
+ @${REINPLACE_CMD} -e '/MagickWand\.h/s,MagickWand/,wand/,' \
+ ${WRKSRC}/configure ${WRKSRC}/wrlib/load_magick.c
+.endif
+
post-install:
@${MKDIR} \
${STAGEDIR}${PREFIX}/GNUstep/Applications/WPrefs.app/xpm \