aboutsummaryrefslogtreecommitdiff
path: root/x11/alacritty
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-12-01 07:54:50 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-12-01 07:54:50 +0000
commit377c4ead414d701e897c1334468279234446e447 (patch)
treeed5c8b83532560ac93acbb000076562a68c25dfd /x11/alacritty
parent13b1f294d6521b30688bc800d5497e84a6ca02ba (diff)
downloadports-377c4ead414d701e897c1334468279234446e447.tar.gz
ports-377c4ead414d701e897c1334468279234446e447.zip
x11/alacritty: Unbreak tests
- Add x11-fonts/dejavu as a test dependency. This allows the "font" crate tests to find a font that matches "monospace". - The test build cannot find libxcb. It is unclear why the link failure is not triggered during the normal build. Add USES=localbase for now. error: linking with `cc` failed: exit code: 1 [...] = note: /usr/bin/ld: error: unable to find library -lxcb /usr/bin/ld: error: unable to find library -lxcb /usr/bin/ld: error: unable to find library -lxcb /usr/bin/ld: error: unable to find library -lxcb /usr/bin/ld: error: unable to find library -lxcb-render /usr/bin/ld: error: unable to find library -lxcb-shape /usr/bin/ld: error: unable to find library -lxcb-xfixes error: aborting due to previous error error: could not compile `copypasta`.
Notes
Notes: svn path=/head/; revision=518754
Diffstat (limited to 'x11/alacritty')
-rw-r--r--x11/alacritty/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/x11/alacritty/Makefile b/x11/alacritty/Makefile
index b87870869e05..153536fcf998 100644
--- a/x11/alacritty/Makefile
+++ b/x11/alacritty/Makefile
@@ -13,8 +13,9 @@ LICENSE_FILE= ${WRKSRC}/LICENSE-APACHE
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
+TEST_DEPENDS= dejavu>0:x11-fonts/dejavu
-USES= cargo python:3.6+,build ssl:build xorg
+USES= cargo localbase:ldflags python:3.6+,build ssl:build xorg
USE_GITHUB= yes
GH_ACCOUNT= jwilm
GH_TUPLE= chrisduerr:glutin:7e479dca8be6244b96e2a080714fc4babf7fe30d:glutin \