aboutsummaryrefslogtreecommitdiff
path: root/x11/aterm
diff options
context:
space:
mode:
authorMichael Landin <mich@FreeBSD.org>2005-09-08 13:31:25 +0000
committerMichael Landin <mich@FreeBSD.org>2005-09-08 13:31:25 +0000
commit6e8dbb5f273eab01b851fe62730e45493a1746a4 (patch)
tree7a7c3f4a2782c3ec612a0d16591155201eb7138f /x11/aterm
parent5994a36bf89f6dcc89931c1c576741c4ae016e0c (diff)
downloadports-6e8dbb5f273eab01b851fe62730e45493a1746a4.tar.gz
ports-6e8dbb5f273eab01b851fe62730e45493a1746a4.zip
o fix annoying "window size" bug
o bump PORTREVISION PR: ports/85770 Submitted by: Daniel Roethlisberger <daniel@roe.ch>
Notes
Notes: svn path=/head/; revision=142221
Diffstat (limited to 'x11/aterm')
-rw-r--r--x11/aterm/Makefile2
-rw-r--r--x11/aterm/files/patch-aa25
-rw-r--r--x11/aterm/pkg-message10
3 files changed, 22 insertions, 15 deletions
diff --git a/x11/aterm/Makefile b/x11/aterm/Makefile
index fbfadbb377a6..860abe42fe6e 100644
--- a/x11/aterm/Makefile
+++ b/x11/aterm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= aterm
PORTVERSION= 1.0.0
+PORTREVISION= 1
CATEGORIES+= x11 # `+=' is for slave ports
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -71,6 +72,5 @@ MAN1= aterm.1
post-install:
@${CHMOD} 4711 ${PREFIX}/bin/aterm
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/x11/aterm/files/patch-aa b/x11/aterm/files/patch-aa
index 4b0ec0244456..b9ec6296fead 100644
--- a/x11/aterm/files/patch-aa
+++ b/x11/aterm/files/patch-aa
@@ -1,6 +1,6 @@
---- src/command.c.orig Mon Oct 22 23:02:47 2001
-+++ src/command.c Mon Oct 22 22:43:26 2001
-@@ -69,12 +69,18 @@
+--- src/command.c.orig Tue Jun 21 22:08:16 2005
++++ src/command.c Tue Sep 6 00:35:28 2005
+@@ -73,12 +73,18 @@
#ifndef NO_XLOCALE
# if (XtSpecificationRelease < 6)
# define NO_XLOCALE
@@ -22,7 +22,7 @@
#ifdef TTY_GID_SUPPORT
# include <grp.h>
#endif
-@@ -534,7 +540,7 @@
+@@ -600,7 +606,7 @@
ttydev = tty_name;
# define PTYCHAR1 "pqrstuvwxyz"
@@ -31,3 +31,20 @@
for (c1 = PTYCHAR1; *c1; c1++) {
ptydev[len - 2] = ttydev[len - 2] = *c1;
for (c2 = PTYCHAR2; *c2; c2++) {
+@@ -1043,8 +1049,6 @@
+ signal(SIGTERM, Exit_signal);
+ signal(SIGCHLD, Child_signal);
+
+- tt_winsize(ptyfd); /* set window size */
+-
+ /* need to trap SIGURG for SVR4 (Unixware) rlogin */
+ /* signal (SIGURG, SIG_DFL); */
+
+@@ -1084,6 +1088,7 @@
+ }
+ #endif /* SRIOCSREDIR */
+ }
++ tt_winsize(0); /* set window size */
+
+ /* reset signals and spin off the command interpreter */
+ signal(SIGINT, SIG_DFL);
diff --git a/x11/aterm/pkg-message b/x11/aterm/pkg-message
deleted file mode 100644
index f571ee708d02..000000000000
--- a/x11/aterm/pkg-message
+++ /dev/null
@@ -1,10 +0,0 @@
-
- ATTENTION:
-
-Due to a BSD related bug in aterm in some cases the $COLUMNS and $LINES
-envirement variables are not being updated to the corresponding window geometry
-values. This will cause problems with applications such as 'man' or 'ee'. You
-need to adjust the window geometry manually at least once in order for the two
-envirement variable mentioned above to get adjusted correctly.
-
-The AfterStep/aterm developers know about this problem and are working on it.