aboutsummaryrefslogtreecommitdiff
path: root/x11/aterm
diff options
context:
space:
mode:
authorMichael Landin <mich@FreeBSD.org>2004-06-23 15:34:52 +0000
committerMichael Landin <mich@FreeBSD.org>2004-06-23 15:34:52 +0000
commitaa9216ba2a95af7e07945215d50361715692905c (patch)
treee860709271803a9b866ddc677011e53ea411b82a /x11/aterm
parent6f4276a795a1d333d49d97fe57784183f23748b1 (diff)
downloadports-aa9216ba2a95af7e07945215d50361715692905c.tar.gz
ports-aa9216ba2a95af7e07945215d50361715692905c.zip
- Add two knobs:
- WITHOUT_JPEG - WITHOUT_PNG - Tell configure where to look for libs Submitted by: Grigori Goronzy <greg@chown.ath.cx>
Notes
Notes: svn path=/head/; revision=112061
Diffstat (limited to 'x11/aterm')
-rw-r--r--x11/aterm/Makefile19
1 files changed, 16 insertions, 3 deletions
diff --git a/x11/aterm/Makefile b/x11/aterm/Makefile
index 4508506d41a6..f1dbc27c05a2 100644
--- a/x11/aterm/Makefile
+++ b/x11/aterm/Makefile
@@ -14,9 +14,6 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= mich@FreeBSD.org
COMMENT= A color vt102 terminal emulator with transparency support
-LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.5:${PORTSDIR}/graphics/png
-
USE_X_PREFIX= yes
USE_XPM= yes
GNU_CONFIGURE= yes
@@ -25,6 +22,22 @@ CONFIGURE_ARGS+= \
--enable-transparency --enable-background-image \
--enable-fading --enable-utmp --enable-wtmp
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+
+.if !defined(WITHOUT_PNG)
+CONFIGURE_ARGS+= --with-png
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
+.else
+CONFIGURE_ARGS+= --with-png=no
+.endif
+
+.if !defined(WITHOUT_JPEG)
+CONFIGURE_ARGS+= --with-jpeg
+LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg
+.else
+CONFIGURE_ARGS+= --with-jpeg=no
+.endif
+
.if !defined(WITH_BSDEL)
CONFIGURE_ARGS+= --disable-backspace-key --disable-delete-key
.endif