aboutsummaryrefslogtreecommitdiff
path: root/x11/aterm
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2010-08-12 20:15:59 +0000
committerDoug Barton <dougb@FreeBSD.org>2010-08-12 20:15:59 +0000
commitdbddc2b7925c985d44183aec41d6f62f60c7adab (patch)
treef471d01960c131459f8ba3b3820d56fedf7e2e22 /x11/aterm
parent37838d6055ecbbe65cd9e8084f1f623c66dc7399 (diff)
downloadports-dbddc2b7925c985d44183aec41d6f62f60c7adab.tar.gz
ports-dbddc2b7925c985d44183aec41d6f62f60c7adab.zip
Revamp this port:
1. There are no slave ports, so remove the mechanism for that 2. Update CONFIGURE_ARGS 3. Add OPTIONS support 4. Remove knobs for some things that were not actually used by configure 5. Add knobs for other things 6. Default transparency support, mouse support, and bsd-style del/bksp support to on, as previously; but default background image support to off. With modern window managers it's problematic, and needlessly bloats the binary. 7. Switch to PLIST_FILES for the one file installed, the chmod doesn't seem to have any effect one way or the other. 8. Add a bunch of patches from the debian repo which slightly improve support for modern WMs. Bump PORTREVISION Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=259145
Diffstat (limited to 'x11/aterm')
-rw-r--r--x11/aterm/Makefile74
-rw-r--r--x11/aterm/files/patch-cutToBeginningOfLine56
-rw-r--r--x11/aterm/files/patch-dpy32
-rw-r--r--x11/aterm/files/patch-eterm_transparency96
-rw-r--r--x11/aterm/files/patch-fix_deadkeys36
-rw-r--r--x11/aterm/files/patch-lose_pastebuffer_on_resize12
-rw-r--r--x11/aterm/files/patch-manpage_bl12
-rw-r--r--x11/aterm/files/patch-manpage_paths23
-rw-r--r--x11/aterm/files/patch-superflous_linking25
-rw-r--r--x11/aterm/files/patch-warn_faulty_boolean31
-rw-r--r--x11/aterm/files/patch-xlocale_test24
-rw-r--r--x11/aterm/files/patch-xresources_in_manpage19
-rw-r--r--x11/aterm/pkg-plist2
13 files changed, 405 insertions, 37 deletions
diff --git a/x11/aterm/Makefile b/x11/aterm/Makefile
index 6a82806fef32..d0f43e29b514 100644
--- a/x11/aterm/Makefile
+++ b/x11/aterm/Makefile
@@ -7,66 +7,75 @@
PORTNAME= aterm
PORTVERSION= 1.0.1
-PORTREVISION= 5
-CATEGORIES+= x11 # `+=' is for slave ports
+PORTREVISION= 6
+CATEGORIES= x11
MASTER_SITES= SF
-MAINTAINER= mich@FreeBSD.org
+MAINTAINER= dougb@FreeBSD.org
COMMENT= A color vt102 terminal emulator with transparency support
USE_XORG= xpm
GNU_CONFIGURE= yes
-# `+=' is for slave ports
-CONFIGURE_ARGS+= --enable-transparency \
- --enable-fading --enable-wtmp \
- --without-afterstep-config
+CONFIGURE_ARGS= --enable-wtmp \
+ --enable-xgetdefault \
+ --disable-memset \
+ --disable-swapscreen \
+ --disable-thai \
+ --without-afterstep-config
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
-.include <bsd.port.pre.mk>
+OPTIONS= TRANS "Transparency support" on \
+ BSDEL "BSD-style backspace and delete" on \
+ MOUSE "Mousewheel support" on \
+ BGIMG "XPM, JPEG, PNG backgrounds" off \
+ KANJI "Kanji (EUC-JP or SJIS) support" off \
+ BIG5S "Chinese character support (BIG5)" off \
+ GREEK "Greek keyboard support" off
+
+MAN1= aterm.1
+
+PLIST_FILES= bin/aterm
+.include <bsd.port.pre.mk>
.if ${OSVERSION} > 900007
CONFIGURE_ARGS+= --disable-utmp
.else
CONFIGURE_ARGS+= --enable-utmp
.endif
-.if !defined(WITHOUT_BACKGROUND_IMAGE)
-LIB_DEPENDS+= AfterImage.0:${PORTSDIR}/graphics/libafterimage
-CONFIGURE_ARGS+= --enable-background-image
-.endif
-
-.if !defined(WITHOUT_PNG)
-CONFIGURE_ARGS+= --with-png
-LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png
-.else
-CONFIGURE_ARGS+= --with-png=no
-.endif
-
-.if !defined(WITHOUT_JPEG)
-CONFIGURE_ARGS+= --with-jpeg
-LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
+.if !defined(WITHOUT_TRANS)
+CONFIGURE_ARGS+= --enable-transparency
.else
-CONFIGURE_ARGS+= --with-jpeg=no
+CONFIGURE_ARGS+= --disable-transparency
.endif
-.if !defined(WITH_BSDEL)
+.if !defined(WITHOUT_BSDEL)
CONFIGURE_ARGS+= --disable-backspace-key --disable-delete-key
+.else
+CONFIGURE_ARGS+= --enable-backspace-key --enable-delete-key
.endif
-.if defined(WITH_MENUBAR)
-CONFIGURE_ARGS+= --enable-menubar
+.if !defined(WITHOUT_MOUSE)
+CONFIGURE_ARGS+= --enable-mousewheel
+.else
+CONFIGURE_ARGS+= --disable-mousewheel
.endif
-.if defined(WITH_NEXTSCROLL)
-CONFIGURE_ARGS+= --enable-next-scroll
+.if defined(WITH_BGIMG)
+LIB_DEPENDS+= AfterImage.0:${PORTSDIR}/graphics/libafterimage \
+ png.6:${PORTSDIR}/graphics/png \
+ jpeg.11:${PORTSDIR}/graphics/jpeg
+CONFIGURE_ARGS+= --with-afterimage-config --with-png --with-jpeg
+.else
+CONFIGURE_ARGS+= --without-afterimage-config --with-png=no --with-jpeg=no
.endif
.if defined(WITH_KANJI)
CONFIGURE_ARGS+= --enable-kanji
.endif
-.if defined(WITH_BIG5)
+.if defined(WITH_BIG5S)
CONFIGURE_ARGS+= --enable-big5
.endif
@@ -74,9 +83,4 @@ CONFIGURE_ARGS+= --enable-big5
CONFIGURE_ARGS+= --enable-greek
.endif
-MAN1= aterm.1
-
-post-install:
- @${CHMOD} 4711 ${PREFIX}/bin/aterm
-
.include <bsd.port.post.mk>
diff --git a/x11/aterm/files/patch-cutToBeginningOfLine b/x11/aterm/files/patch-cutToBeginningOfLine
new file mode 100644
index 000000000000..2be191df4c38
--- /dev/null
+++ b/x11/aterm/files/patch-cutToBeginningOfLine
@@ -0,0 +1,56 @@
+diff -urNad aterm-1.0.1~/src/rxvt.h src/rxvt.h
+--- src/rxvt.h 2007-08-03 23:55:28.000000000 +0200
++++ src/rxvt.h 2007-08-03 23:56:36.000000000 +0200
+@@ -784,6 +784,7 @@
+ #define Opt_scrollKeypress (1LU<<12)
+ #define Opt_transparent (1LU<<13)
+ #define Opt_transparent_sb (1LU<<14)
++#define Opt_cutToBeginningOfLine (1LU<<15)
+ #define Opt_borderLess (1LU<<16)
+
+ /* place holder used for parsing command-line options */
+diff -urNad aterm-1.0.1~/src/screen.c src/screen.c
+--- aterm-1.0.1~/src/screen.c 2007-08-03 23:55:28.000000000 +0200
++++ src/screen.c 2007-08-04 00:02:35.000000000 +0200
+@@ -3155,7 +3155,7 @@
+ text_t *stp;
+ rend_t *srp;
+
+- if (selection.clicks != 2)
++ if (selection.clicks < 2)
+ return; /* Go away: we only handle double clicks */
+
+ if (dirn == UP) {
+@@ -3454,7 +3454,11 @@
+ } else if (selection.clicks == 3) {
+ if (ROWCOL_IS_AFTER(selection.mark, selection.beg))
+ selection.mark.col++;
+- selection.beg.col = 0;
++ if (Options & Opt_cutToBeginningOfLine) {
++ selection_delimit_word(UP, &(selection.beg), &(selection.beg));
++ } else {
++ selection.beg.col = 0;
++ }
+ selection.end.col = TermWin.bcol;
+ }
+ if (button3 && buttonpress) { /* mark may need to be changed */
+diff -urNad aterm-1.0.1~/src/xdefaults.c src/xdefaults.c
+--- aterm-1.0.1~/src/xdefaults.c 2007-08-03 23:55:28.000000000 +0200
++++ src/xdefaults.c 2007-08-04 00:03:23.000000000 +0200
+@@ -70,6 +70,7 @@
+ #endif
+ static const char *rs_visualBell = NULL;
+ static const char *rs_reverseVideo = NULL;
++static const char *rs_cutToBeginningOfLine = NULL;
+
+ #ifdef META8_OPTION
+ static const char *rs_meta8 = NULL;
+@@ -327,6 +328,8 @@
+ BOOL(rs_utmpInhibit, "utmpInhibit", "ut", Opt_utmpInhibit,
+ "utmp inhibit"),
+ BOOL(rs_visualBell, "visualBell", "vb", Opt_visualBell, "visual bell"),
++ BOOL(rs_cutToBeginningOfLine, "cutToBeginningOfLine", "cb", Opt_cutToBeginningOfLine,
++ "cut to beginning of line"),
+
+ #ifndef NO_MAPALERT
+ # ifdef MAPALERT_OPTION
diff --git a/x11/aterm/files/patch-dpy b/x11/aterm/files/patch-dpy
new file mode 100644
index 000000000000..eb4221a9539a
--- /dev/null
+++ b/x11/aterm/files/patch-dpy
@@ -0,0 +1,32 @@
+diff -urNad aterm-1.0.1~/src/libafterstep.h src/libafterstep.h
+--- aterm-1.0.1~/src/libafterstep.h 2004-11-10 18:21:43.000000000 +0100
++++ src/libafterstep.h 2009-07-20 23:10:02.000000000 +0200
+@@ -45,7 +45,6 @@
+ #ifdef INTERN
+ int DeadPipe( int nonsense ){return 1;}
+ ScreenInfo Scr ;
+-Display *dpy ;
+ char *MyName;
+ #endif /* INTERN */
+ #endif /* USE_LIBASIMAGE */
+diff -urNad aterm-1.0.1~/src/main.c src/main.c
+--- aterm-1.0.1~/src/main.c 2007-08-01 16:08:29.000000000 +0200
++++ src/main.c 2009-07-20 23:08:46.000000000 +0200
+@@ -2087,7 +2087,7 @@
+ #endif
+
+ ConnectX ( &Scr, 0 );
+- Xdisplay = dpy ;
++ Xdisplay = get_current_X_display() ;
+ Xscreen = Scr.screen ;
+ asv = Scr.asv ;
+
+@@ -2125,7 +2125,7 @@
+ XdisplayHeight = DisplayHeight (Xdisplay, Xscreen);
+
+ #ifdef HAVE_AFTERIMAGE
+- dpy = Xdisplay ;
++ set_current_X_display(Xdisplay) ;
+ asv = create_asvisual (Xdisplay, Xscreen, Xdepth, NULL);
+ Xcmap = asv->colormap;
+ Xdepth = asv->visual_info.depth;
diff --git a/x11/aterm/files/patch-eterm_transparency b/x11/aterm/files/patch-eterm_transparency
new file mode 100644
index 000000000000..0c4e6b0f0558
--- /dev/null
+++ b/x11/aterm/files/patch-eterm_transparency
@@ -0,0 +1,96 @@
+diff -urNad aterm-1.0.1~/src/main.c src/main.c
+--- aterm-1.0.1~/src/main.c 2007-08-04 00:05:30.000000000 +0200
++++ src/main.c 2007-08-04 00:09:53.000000000 +0200
+@@ -1334,6 +1334,12 @@
+ break;
+ #endif
+
++ case XTerm_EtermSeq:
++ op = atoi(str);
++ if (!(str = strchr(str, ';')))
++ break;
++ eterm_seq(op, str + 1);
++ break;
+ case XTerm_Menu:
+ /*
+ * menubar_dispatch() violates the constness of the string,
+@@ -1360,6 +1366,43 @@
+ break;
+ }
+ }
++
++/*
++ * Eterm escape sequences: ESC ] 6;Ps;Pt BEL
++ * 2 = set shade/tint mask
++ * (There are more codes--check Eterm's reference doc.)
++ */
++/* PROTO */
++ void
++eterm_seq(int op, const char *str)
++{
++ assert(str != NULL);
++ switch (op) {
++#if defined(BACKGROUND_IMAGE) || defined(TRANSPARENT)
++ case 2:
++ /* { shade | tint } [ class ; ] value */
++ if (strncmp(str, "tint", 4) == 0) {
++ char *class;
++ char *value;
++
++ if (!(class = strchr((char *) str, ';')))
++ break;
++ *class++ = '\0';
++ if (!(value = strchr(class, ';'))) {
++ /* Default class is bg. */
++ value = class;
++ class = "bg";
++ } else
++ *value++ = '\0';
++
++ if (strcmp(class, "bg") == 0) {
++ set_window_color(Color_tint, value);
++ }
++ }
++ break;
++#endif
++ }
++}
+ /*}}} */
+
+
+diff -urNad aterm-1.0.1~/src/rxvt.h src/rxvt.h
+--- aterm-1.0.1~/src/rxvt.h 2007-08-04 00:05:30.000000000 +0200
++++ src/rxvt.h 2007-08-04 00:10:31.000000000 +0200
+@@ -807,6 +807,7 @@
+ /*
+ * rxvt extensions of XTerm escape sequences: ESC ] Ps;Pt BEL
+ */
++#define XTerm_EtermSeq 6 /* Eterm proprietary escape sequences */
+ #define XTerm_Menu 10 /* set menu item */
+ #define XTerm_Pixmap 20 /* new bg pixmap */
+ #define XTerm_restoreFG 39 /* change default fg color */
+diff -urNad aterm-1.0.1~/src/screen.c src/screen.c
+--- aterm-1.0.1~/src/screen.c 2007-08-04 00:05:30.000000000 +0200
++++ src/screen.c 2007-08-04 00:15:22.000000000 +0200
+@@ -2665,7 +2665,20 @@
+ !(Options & Opt_transparent))
+ {
+ XSetWindowBackground(Xdisplay, TermWin.vt, PixColors[Color_bg]);
+- }
++ } else if (idx == Color_tint) {
++ XColor tint;
++
++ tint.pixel = PixColors[Color_tint];
++ XQueryColor(Xdisplay, Xcmap, &tint);
++ if (TermWin.background.Shading.tintColor.red == tint.red &&
++ TermWin.background.Shading.tintColor.green == tint.green &&
++ TermWin.background.Shading.tintColor.blue == tint.blue) {
++ return;
++ }
++ TermWin.background.Shading.tintColor = tint;
++ RenderPixmap(0);
++ }
++
+
+ /* handle Color_BD, scrollbar background, etc. */
+
diff --git a/x11/aterm/files/patch-fix_deadkeys b/x11/aterm/files/patch-fix_deadkeys
new file mode 100644
index 000000000000..6778af562144
--- /dev/null
+++ b/x11/aterm/files/patch-fix_deadkeys
@@ -0,0 +1,36 @@
+diff -urNad aterm-1.0.1~/src/command.c src/command.c
+--- aterm-1.0.1~/src/command.c 2006-06-26 20:01:20.000000000 +0200
++++ src/command.c 2007-09-26 15:03:19.000000000 +0200
+@@ -1486,19 +1486,21 @@
+ numlock_state = (ev->xkey.state & ModNumLockMask); /* numlock toggle */
+ PrivMode((!numlock_state), PrivMode_aplKP);
+ }
+-#ifdef USE_XIM
++#if defined(USE_XIM) || !defined(NO_XLOCALE)
+ len = 0;
+- if (Input_Context != NULL) {
+- Status status_return;
++ if (!XFilterEvent(ev, *(&ev->xkey.window))) {
++ if (Input_Context != NULL) {
++ Status status_return;
+
+- kbuf[0] = '\0';
+- len = XmbLookupString(Input_Context, &ev->xkey, kbuf,
+- sizeof(kbuf), &keysym,
+- &status_return);
+- } else {
+- len = XLookupString(&ev->xkey, kbuf,
+- sizeof(kbuf), &keysym,
+- &compose);
++ kbuf[0] = '\0';
++ len = XmbLookupString(Input_Context, &ev->xkey, kbuf,
++ sizeof(kbuf), &keysym,
++ &status_return);
++ } else {
++ len = XLookupString(&ev->xkey, kbuf,
++ sizeof(kbuf), &keysym,
++ &compose);
++ }
+ }
+ #else /* USE_XIM */
+ len = XLookupString(&ev->xkey, (char *) kbuf, sizeof(kbuf), &keysym, &compose);
diff --git a/x11/aterm/files/patch-lose_pastebuffer_on_resize b/x11/aterm/files/patch-lose_pastebuffer_on_resize
new file mode 100644
index 000000000000..21e5c923aeed
--- /dev/null
+++ b/x11/aterm/files/patch-lose_pastebuffer_on_resize
@@ -0,0 +1,12 @@
+diff -urNad aterm-1.0.1~/src/screen.c src/screen.c
+--- aterm-1.0.1~/src/screen.c 2006-03-30 00:32:07.000000000 +0200
++++ src/screen.c 2007-12-17 23:08:19.000000000 +0100
+@@ -2883,7 +2883,7 @@
+ selection.type = 1;
+ /* "fix" for the high-ascii pasting? : */
+ /* may need to try all three : aterm_XA_UTF8_STRING, _XA_COMPAUND_TEXT and XA_STRING in that order */
+- XConvertSelection(Xdisplay, XA_PRIMARY, XA_STRING, aterm_XA_VT_SELECTION, TermWin.vt,tm);
++ XConvertSelection(Xdisplay, XA_PRIMARY, _XA_COMPAUND_TEXT, aterm_XA_VT_SELECTION, TermWin.vt,tm);
+ /* XConvertSelection(Xdisplay, XA_PRIMARY, _XA_COMPAUND_TEXT, prop, TermWin.vt,tm); */
+ }
+ }
diff --git a/x11/aterm/files/patch-manpage_bl b/x11/aterm/files/patch-manpage_bl
new file mode 100644
index 000000000000..a5169e80e63e
--- /dev/null
+++ b/x11/aterm/files/patch-manpage_bl
@@ -0,0 +1,12 @@
+diff -urNad aterm-1.0.0~/doc/aterm.1 aterm-1.0.0/doc/aterm.1
+--- aterm-1.0.0~/doc/aterm.1 2006-10-06 15:16:23.000000000 +0200
++++ doc/aterm.1 2006-10-06 15:14:38.000000000 +0200
+@@ -171,7 +171,7 @@
+ .IP "\fB-bd\fP \fIcolour\fP"
+ The colour of the border between the xterm scrollbar and the text;
+ resource \fBborderColor\fP\&.
+-.IP "\fB-bl\fP \fInumber\fP"
++.IP "\fB-bl\fP|\fB+bl\fP"
+ This option specifies that aterm should askwindow manager to not have
+ a border around term's window;
+ resource \fBborderLess\fP\&.
diff --git a/x11/aterm/files/patch-manpage_paths b/x11/aterm/files/patch-manpage_paths
new file mode 100644
index 000000000000..e7148cc8c876
--- /dev/null
+++ b/x11/aterm/files/patch-manpage_paths
@@ -0,0 +1,23 @@
+diff -urNad aterm-1.0.1~/doc/aterm.1 doc/aterm.1
+--- aterm-1.0.1~/doc/aterm.1 2007-12-17 22:48:28.000000000 +0100
++++ doc/aterm.1 2007-12-17 22:51:01.000000000 +0100
+@@ -1,6 +1,6 @@
+ .TH "ATERM" "1" "05 July 05" "X Version 11" "X Tools"
+ .SH "NAME"
+-aterm (Afterstep XVT) \- a VT102 emulator for the X window system
++aterm \- a VT102 emulator for the X window system
+ .PP
+ .SH "SYNOPSIS"
+ .PP
+@@ -656,9 +656,9 @@
+ to find XPM files\&.
+ .SH "FILES"
+ .PP
+-.IP "\fB/etc/utmp\fP"
++.IP "\fB/var/run/utmp\fP"
+ System file for login records\&.
+-.IP "\fB/usr/lib/X11/rgb\&.txt\fP"
++.IP "\fB/etc/X11/rgb.txt\fP"
+ Color names\&.
+ .PP
+ .SH "SEE ALSO"
diff --git a/x11/aterm/files/patch-superflous_linking b/x11/aterm/files/patch-superflous_linking
new file mode 100644
index 000000000000..3937523ce98e
--- /dev/null
+++ b/x11/aterm/files/patch-superflous_linking
@@ -0,0 +1,25 @@
+diff -urNad aterm-1.0.1~/configure configure
+--- aterm-1.0.1~/configure 2007-09-22 10:33:40.000000000 +0200
++++ configure 2007-09-22 10:34:13.000000000 +0200
+@@ -6796,9 +6796,9 @@
+ fi
+ { echo "$as_me:$LINENO: result: $ac_cv_lib_ICE_IceConnectionNumber" >&5
+ echo "${ECHO_T}$ac_cv_lib_ICE_IceConnectionNumber" >&6; }
+-if test $ac_cv_lib_ICE_IceConnectionNumber = yes; then
+- X_PRE_LIBS="$X_PRE_LIBS -lSM -lICE"
+-fi
++#if test $ac_cv_lib_ICE_IceConnectionNumber = yes; then
++# X_PRE_LIBS="$X_PRE_LIBS -lSM -lICE"
++#fi
+
+ LDFLAGS=$ac_save_LDFLAGS
+
+@@ -6877,7 +6877,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lXext $x_libs $LIBS"
++#LIBS="-lXext $x_libs $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
diff --git a/x11/aterm/files/patch-warn_faulty_boolean b/x11/aterm/files/patch-warn_faulty_boolean
new file mode 100644
index 000000000000..5c7d66a7d9e1
--- /dev/null
+++ b/x11/aterm/files/patch-warn_faulty_boolean
@@ -0,0 +1,31 @@
+diff -urNad --exclude=CVS --exclude=.svn ./src/xdefaults.c /tmp/dpep-work.T9H3hg/aterm-1.0.0/src/xdefaults.c
+--- src/xdefaults.c 2005-07-31 18:31:49.000000000 +0200
++++ src/xdefaults.c 2005-07-31 18:46:26.000000000 +0200
+@@ -862,8 +862,12 @@
+ s = !s;
+ if (s)
+ Options |= (optList[entry].flag);
+- else
++ else {
++ if (my_strcasecmp(str, "FALSE"))
++ print_error("Cannot parse value \"%s\" from resource \"%s\" as boolean",
++ str, kw);
+ Options &= ~(optList[entry].flag);
++ }
+ }
+ }
+ break;
+@@ -945,8 +949,12 @@
+ s = !s;
+ if (s)
+ Options |= (optList[entry].flag);
+- else
++ else {
++ if (my_strcasecmp(p, "FALSE"))
++ print_error("Cannot parse value \"%s\" from resource \"%s\" as boolean",
++ p, kw);
+ Options &= ~(optList[entry].flag);
++ }
+ }
+ }
+ }
diff --git a/x11/aterm/files/patch-xlocale_test b/x11/aterm/files/patch-xlocale_test
new file mode 100644
index 000000000000..4f3d3f16db80
--- /dev/null
+++ b/x11/aterm/files/patch-xlocale_test
@@ -0,0 +1,24 @@
+diff -urNad aterm-1.0.1~/autoconf/configure.in aterm-1.0.1/autoconf/configure.in
+--- aterm-1.0.1~/autoconf/configure.in 2007-08-04 00:23:29.000000000 +0200
++++ autoconf/configure.in 2007-08-04 00:28:14.000000000 +0200
+@@ -608,7 +608,7 @@
+
+ dnl# this is a really hack test for some basic Xlocale stuff
+ SAVETHELIBS=$LIBS
+-LIBS="$LIBS $X_LIBS $X_PRE_LIBS $X_EXTRA_LIBS -lX11 -lXmu"
++LIBS="$LIBS $X_LIBS $X_PRE_LIBS $X_EXTRA_LIBS -lX11"
+ CFLAGS="$CFLAGS $X_CFLAGS"
+ AC_CACHE_CHECK(for working Xlocale, rxvt_cv_func_xlocale,
+ [AC_TRY_RUN(
+diff -urNad aterm-1.0.1~/configure aterm-1.0.1/configure
+--- aterm-1.0.1~/configure 2007-08-04 00:23:29.000000000 +0200
++++ configure 2007-08-04 00:28:29.000000000 +0200
+@@ -10434,7 +10434,7 @@
+ fi
+
+ SAVETHELIBS=$LIBS
+-LIBS="$LIBS $X_LIBS $X_PRE_LIBS $X_EXTRA_LIBS -lX11 -lXmu"
++LIBS="$LIBS $X_LIBS $X_PRE_LIBS $X_EXTRA_LIBS -lX11"
+ CFLAGS="$CFLAGS $X_CFLAGS"
+ { echo "$as_me:$LINENO: checking for working Xlocale" >&5
+ echo $ECHO_N "checking for working Xlocale... $ECHO_C" >&6; }
diff --git a/x11/aterm/files/patch-xresources_in_manpage b/x11/aterm/files/patch-xresources_in_manpage
new file mode 100644
index 000000000000..4dfff8aebf29
--- /dev/null
+++ b/x11/aterm/files/patch-xresources_in_manpage
@@ -0,0 +1,19 @@
+diff -urNad aterm-0.4.2/doc/aterm.1 /tmp/dpep.SAKh5b/aterm-0.4.2/doc/aterm.1
+--- aterm-0.4.2/doc/aterm.1 2005-03-29 15:58:53.000000000 +0200
++++ doc/aterm.1 2005-03-29 16:06:31.000000000 +0200
+@@ -255,9 +255,12 @@
+ .IP
+ .SH "RESOURCES (available also as long-options)"
+ .PP
+-\fBaterm\fP accepts application defaults set in XAPPLOADDIR/aterm (compile-time
+-defined: usually \fB/etc/X11/Xresources/aterm\fP) and resources set in
+-\fB~/\&.Xdefaults\fP or \fB~/\&.Xresources\fP\&. Note that when reading X resources,
++.\" \fBaterm\fP accepts application defaults set in XAPPLOADDIR/aterm (compile-time
++.\" defined: usually \fB/etc/X11/Xresources/aterm\fP) and resources set in
++.\" \fB~/\&.Xdefaults\fP or \fB~/\&.Xresources\fP\&.
++\fBaterm\fP accepts application defaults from the X server resource database.
++\fBxrdb\fP is used to update this database.
++Note that when reading X resources,
+ \fBaterm\fP recognizes two class names: \fBXTerm\fP and \fBAterm\fP\&. The class name
+ \fBXTerm\fP allows resources common to both \fBaterm\fP and \fIxterm\fP to be easily
+ configured, while the class name \fBAterm\fP allows resources unique to \fBaterm\fP,
diff --git a/x11/aterm/pkg-plist b/x11/aterm/pkg-plist
deleted file mode 100644
index 90bdc5edbd92..000000000000
--- a/x11/aterm/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/aterm
-@exec chmod 4711 %D/bin/aterm