aboutsummaryrefslogtreecommitdiff
path: root/x11/bbrun
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-06-18 05:42:56 +0000
committerPatrick Li <pat@FreeBSD.org>2002-06-18 05:42:56 +0000
commit174bb66c318a0cabd03a3cc2c26dd33a28a334c3 (patch)
tree8d79274222d154276fc756e3cc025d3d6f41f76e /x11/bbrun
parentdda764802ffefac3325d77057e0583e8eb3412ef (diff)
downloadports-174bb66c318a0cabd03a3cc2c26dd33a28a334c3.tar.gz
ports-174bb66c318a0cabd03a3cc2c26dd33a28a334c3.zip
Update to 1.3
Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=61475
Diffstat (limited to 'x11/bbrun')
-rw-r--r--x11/bbrun/Makefile2
-rw-r--r--x11/bbrun/distinfo2
-rw-r--r--x11/bbrun/files/patch-Makefile36
3 files changed, 18 insertions, 22 deletions
diff --git a/x11/bbrun/Makefile b/x11/bbrun/Makefile
index 3eaad089aecf..0f29c5a1bdec 100644
--- a/x11/bbrun/Makefile
+++ b/x11/bbrun/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bbrun
-PORTVERSION= 1.2
+PORTVERSION= 1.3
CATEGORIES= x11-wm
MASTER_SITES= http://www.dwave.net/~jking/bbrun/
diff --git a/x11/bbrun/distinfo b/x11/bbrun/distinfo
index 155ce0212064..5fd82e1e13d0 100644
--- a/x11/bbrun/distinfo
+++ b/x11/bbrun/distinfo
@@ -1 +1 @@
-MD5 (bbrun-1.2.tar.gz) = fbcf9279112acab213a7bf899affc36c
+MD5 (bbrun-1.3.tar.gz) = ef1a5271b05c4652d78ae034454d6f3b
diff --git a/x11/bbrun/files/patch-Makefile b/x11/bbrun/files/patch-Makefile
index 6202e4ccc942..9c48d6f7ce99 100644
--- a/x11/bbrun/files/patch-Makefile
+++ b/x11/bbrun/files/patch-Makefile
@@ -1,29 +1,25 @@
---- Makefile.orig Mon Oct 2 11:05:09 2000
-+++ Makefile Sat Dec 1 20:33:06 2001
-@@ -1,19 +1,21 @@
--LIBDIR = -L/usr/X11R6/lib -L/usr/lib
--LIBS = -lXpm -lXext -lX11 -lm -lgtk -lgdk -rdynamic -lgmodule -lglib -ldl
--CFLAGS = -I/usr/X11R6/include -I/usr/lib/glib/include
-+LIBDIR = -L${X11BASE}/lib -L${LOCALBASE}/lib
-+LIBS = `${GTK_CONFIG} --libs` -rdynamic -lXpm
+--- Makefile.orig Wed Feb 6 15:05:51 2002
++++ Makefile Tue Jun 18 01:37:36 2002
+@@ -1,16 +1,17 @@
+-CC = gcc
+-LIBS = -lXpm `gtk-config --libs`
+-CFLAGS = `gtk-config --cflags`
++LIBS = -lXpm `${GTK_CONFIG} --libs` -L${LOCALBASE}/lib -lgnugetopt
+CFLAGS += `${GTK_CONFIG} --cflags` -Wall
- OBJS = bbrun.o \
- ../wmgeneral/wmgeneral.o \
- ../wmgeneral/misc.o \
- ../wmgeneral/list.o
+ OBJS = bbrun.o \
+ ../wmgeneral/wmgeneral.o \
+ ../wmgeneral/misc.o \
+ ../wmgeneral/list.o
.c.o:
-- cc -c -O2 -Wall $< -o $*.o $(CFLAGS)
+- $(CC) -c -O2 -Wall $< -o $*.o $(CFLAGS)
+ $(CC) -c $< -o $*.o $(CFLAGS)
bbrun: $(OBJS)
-- cc -Wall -g -o bbrun $^ $(LIBDIR) $(LIBS)
-+ $(CC) -o bbrun $^ $(LIBDIR) $(LIBS)
+- $(CC) -Wall -g -o bbrun $^ $(LIBS)
++ $(CC) -o bbrun $^ $(LIBS)
- clean::
- for i in $(OBJS) ; do \
- rm $$i; \
- done
- rm bbrun
+ clean:
+ rm -f bbrun $(OBJS)
+
+all: bbrun