aboutsummaryrefslogtreecommitdiff
path: root/x11/bbrun
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:37:44 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:37:44 +0000
commit8e775bbe3ac76cb899c9b749314bd42fdf20302d (patch)
treec2f290a2bd462060addfdd5ce0894c6a53db8dd4 /x11/bbrun
parent3971644de4f32b35be9d9172ace8abbd6593c350 (diff)
downloadports-8e775bbe3ac76cb899c9b749314bd42fdf20302d.tar.gz
ports-8e775bbe3ac76cb899c9b749314bd42fdf20302d.zip
get rid of libgnugetopt dependency for -CURRENT,
use USE_GETOPT_LONG instead. respect CC, CFLAGS.
Notes
Notes: svn path=/head/; revision=84837
Diffstat (limited to 'x11/bbrun')
-rw-r--r--x11/bbrun/Makefile6
-rw-r--r--x11/bbrun/files/patch-Makefile6
2 files changed, 7 insertions, 5 deletions
diff --git a/x11/bbrun/Makefile b/x11/bbrun/Makefile
index 670e17c32422..380323c7be76 100644
--- a/x11/bbrun/Makefile
+++ b/x11/bbrun/Makefile
@@ -7,19 +7,21 @@
PORTNAME= bbrun
PORTVERSION= 1.4
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= http://www.dwave.net/~jking/bbrun/
MAINTAINER= adamw@FreeBSD.org
COMMENT= A Run box for Blackbox
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-
+USE_GETOPT_LONG=yes
USE_X_PREFIX= yes
USE_GNOME= gtk12
USE_GMAKE= yes
USE_XPM= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/bbrun
+MAKE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/bbrun ${PREFIX}/bin
diff --git a/x11/bbrun/files/patch-Makefile b/x11/bbrun/files/patch-Makefile
index bffa640c44f0..2b0fd3d7c82e 100644
--- a/x11/bbrun/files/patch-Makefile
+++ b/x11/bbrun/files/patch-Makefile
@@ -4,8 +4,8 @@
-CC = gcc
-LIBS = -lXpm `gtk-config --libs`
-CFLAGS = `gtk-config --cflags`
-+LIBS = -lXpm `${GTK_CONFIG} --libs` -L${LOCALBASE}/lib -lgnugetopt
-+CFLAGS = `${GTK_CONFIG} --cflags` -Wall
++LIBS = -lXpm `${GTK_CONFIG} --libs`
++CFLAGS += `${GTK_CONFIG} --cflags` -Wall
OBJS = bbrun.o \
../wmgeneral/wmgeneral.o \
../wmgeneral/misc.o \
@@ -17,7 +17,7 @@
bbrun: $(OBJS)
- $(CC) -Wall -g -o bbrun $^ $(LIBS)
-+ $(CC) -o bbrun $^ $(LIBS)
++ $(CC) -o bbrun $^ $(LDFLAGS) $(LIBS)
install:
cp bbrun /usr/local/bin/