aboutsummaryrefslogtreecommitdiff
path: root/x11/bgrot
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-09 14:56:09 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-09 14:56:09 +0000
commitdc7b070b5935990d6b2fbbeabd09f8f90750f4fb (patch)
treee2ea28688dbfe5d001024097da555f906f6343e5 /x11/bgrot
parent13d579bb520cf6de731d282f64d551d8dc9cd442 (diff)
downloadports-dc7b070b5935990d6b2fbbeabd09f8f90750f4fb.tar.gz
ports-dc7b070b5935990d6b2fbbeabd09f8f90750f4fb.zip
Update to 1.31
Handle the configuration file directly in plist PR: ports/185605 Submitted by: Matthew D.Fuller <fullermd@over-yonder.net> (maintainer)
Notes
Notes: svn path=/head/; revision=339247
Diffstat (limited to 'x11/bgrot')
-rw-r--r--x11/bgrot/Makefile9
-rw-r--r--x11/bgrot/distinfo4
-rw-r--r--x11/bgrot/files/patch-Makefile56
-rw-r--r--x11/bgrot/files/patch-setconfdir.pl13
-rw-r--r--x11/bgrot/pkg-message3
-rw-r--r--x11/bgrot/pkg-plist4
6 files changed, 11 insertions, 78 deletions
diff --git a/x11/bgrot/Makefile b/x11/bgrot/Makefile
index a4f694cdf58f..3e7fe4ae5a12 100644
--- a/x11/bgrot/Makefile
+++ b/x11/bgrot/Makefile
@@ -2,18 +2,21 @@
# $FreeBSD$
PORTNAME= bgrot
-PORTVERSION= 1.30
-PORTREVISION= 7
+PORTVERSION= 1.31
CATEGORIES= x11
MASTER_SITES= http://www.over-yonder.net/~fullermd/projects/bgrot/ \
http://distfiles.over-yonder.net/bgrot/
MAINTAINER= fullermd@over-yonder.net
-COMMENT= A program to handle your X background to prevent boredom
+COMMENT= Program to handle your X background to prevent boredom
+
+LICENSE= BSD2CLAUSE
RUN_DEPENDS= xv:${PORTSDIR}/graphics/xv
USES= shebangfix perl5
SHEBANG_FILES= *.pl
+MAKE_ARGS= IPREFIX=${STAGEDIR}${PREFIX}
+
.include <bsd.port.mk>
diff --git a/x11/bgrot/distinfo b/x11/bgrot/distinfo
index 50086e6e33c2..6c649467f687 100644
--- a/x11/bgrot/distinfo
+++ b/x11/bgrot/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bgrot-1.30.tar.gz) = e9cac2280bb57119df15eb78b412066f7e6b4c8eaf9c5bc9aa3df4f4a36ca791
-SIZE (bgrot-1.30.tar.gz) = 6567
+SHA256 (bgrot-1.31.tar.gz) = e4f625b6e8f064532ed2c921e80219db7b33c9fe7b54e7ab40fe9fc0bb175ccc
+SIZE (bgrot-1.31.tar.gz) = 6867
diff --git a/x11/bgrot/files/patch-Makefile b/x11/bgrot/files/patch-Makefile
deleted file mode 100644
index 3f30601653eb..000000000000
--- a/x11/bgrot/files/patch-Makefile
+++ /dev/null
@@ -1,56 +0,0 @@
---- Makefile.orig 2000-06-21 18:50:30.000000000 +0800
-+++ Makefile 2014-01-09 21:37:58.000000000 +0800
-@@ -4,12 +4,13 @@
- # Written by Matthew Fuller <fullermd@over-yonder.net>
-
- # OK, first: config stuff
-+PREFIX ?= /usr/local
-
- # BINDIR: Where the programs are
--BINDIR = /usr/local/bin
-+BINDIR = ${PREFIX}/bin
-
- # CONFDIR: Where the system-wide config goes
--CONFDIR = /usr/local/etc
-+CONFDIR = ${PREFIX}/etc
-
- # DIRMODE: Permission bits for directories
- # FILEMODE: Permission bits for files
-@@ -22,7 +23,7 @@ BINOWN = bin
- BINGRP = bin
-
- # MANDIR: Where is your manpage base?
--MANDIR = /usr/local/man
-+MANDIR = ${PREFIX}/man
-
- # OK, that's about it for user stuff
- # Touch the rest of this file at your own risk
-@@ -48,15 +49,15 @@ help: info
- install:
- @echo Installing...
- .if !exists(${BINDIR})
-- -mkdir -m ${DIRMODE} ${BINDIR}
-+ -mkdir -m ${DIRMODE} $(DESTDIR)${BINDIR}
- .endif
- @echo Installing files...
-- -install -o ${BINOWN} -g ${BINGRP} -m ${FILEMODE} -c ${INSTALLFILES} ${BINDIR}
-- -install -o ${BINOWN} -g ${BINGRP} -m ${FILEMODE} -c bgrot.conf ${CONFDIR}
-+ -install -o ${BINOWN} -g ${BINGRP} -m ${FILEMODE} -c ${INSTALLFILES} $(DESTDIR)${BINDIR}
-+ -install -o ${BINOWN} -g ${BINGRP} -m ${FILEMODE} -c bgrot.conf.skel $(DESTDIR)${CONFDIR}
- @echo Compressing manpage...
- @gzip -c bgrot.1 > bgrot.1.gz
- @echo Installing manpage...
-- -install -o ${BINOWN} -g ${BINGRP} -m ${FILEMODE} -c bgrot.1.gz ${MANDIR}/man1
-+ -install -o ${BINOWN} -g ${BINGRP} -m ${FILEMODE} -c bgrot.1.gz $(DESTDIR)${MANDIR}/man1
- @echo Installation completed
- @echo Read the file README for usage information
-
-@@ -88,7 +89,7 @@ uninstall:
- rm -f ${BINDIR}/$${entry}; \
- done
- @echo Uninstalling configuration...
-- @rm -f ${CONFDIR}/bgrot.conf
-+ @rm -f ${CONFDIR}/bgrot.conf.skel
- @echo Uninstalling manpage...
- @rm -f ${MANDIR}/man1/bgrot.1.gz
- @echo Done.
diff --git a/x11/bgrot/files/patch-setconfdir.pl b/x11/bgrot/files/patch-setconfdir.pl
deleted file mode 100644
index d2c3e5f91a30..000000000000
--- a/x11/bgrot/files/patch-setconfdir.pl
+++ /dev/null
@@ -1,13 +0,0 @@
---- setconfdir.pl.orig Fri Nov 25 17:15:32 2005
-+++ setconfdir.pl Fri Nov 25 17:15:44 2005
-@@ -16,8 +16,8 @@
-
- foreach(<SKEL>) {
- chomp;
-- if(/^\$CONFDIR\=/) {
-- $_ = "\$CONFDIR=\"$CONFDIR\"";
-+ if(/^\CONFDIR\=/) {
-+ $_ = "\CONFDIR=\"$CONFDIR\"";
- }
- print OUT "$_\n";
- }
diff --git a/x11/bgrot/pkg-message b/x11/bgrot/pkg-message
deleted file mode 100644
index 7994647a3b61..000000000000
--- a/x11/bgrot/pkg-message
+++ /dev/null
@@ -1,3 +0,0 @@
-***
-*** Please copy ${PREFIX}/etc/bgrot.conf.skel to ${PREFIX}/etc/bgrot.conf
-***
diff --git a/x11/bgrot/pkg-plist b/x11/bgrot/pkg-plist
index e15694522fc0..cc155c9ce57d 100644
--- a/x11/bgrot/pkg-plist
+++ b/x11/bgrot/pkg-plist
@@ -3,5 +3,7 @@ bin/bgrandom.pl
bin/bgrotman.pl
bin/createlist.sh
bin/masterlistgen.sh
-etc/bgrot.conf.skel
+@unexec if cmp -s %D/etc/bgrot.conf.sample %D/etc/bgrot.conf; then rm -f %D/etc/bgrot.conf; fi
+etc/bgrot.conf.sample
+@exec if [ ! -f %D/etc/bgrot.conf ] ; then cp -p %D/%F %B/bgrot.conf; fi
man/man1/bgrot.1.gz