aboutsummaryrefslogtreecommitdiff
path: root/x11/deskmenu
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2016-03-16 09:22:30 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2016-03-16 09:22:30 +0000
commit1c9913eb823e0e05a5f7393a8524b7d58b70f7a5 (patch)
treeeb19247fe41434769af00386bd632e8a196d5762 /x11/deskmenu
parent34b2379e9d4ef63061bc2f583a8ca2ae078af277 (diff)
downloadports-1c9913eb823e0e05a5f7393a8524b7d58b70f7a5.tar.gz
ports-1c9913eb823e0e05a5f7393a8524b7d58b70f7a5.zip
- Update to version 1.4.5, which is based on GTK+ 2.x now
- Unbreak fetching: upstream are using Debian CDN officially - Stop demanding GNU make: builds fine with BSD make as well - Define LICENSE (GPLv2), install couple of docs and sample configuration file while here - Update port description text and project web address
Notes
Notes: svn path=/head/; revision=411216
Diffstat (limited to 'x11/deskmenu')
-rw-r--r--x11/deskmenu/Makefile40
-rw-r--r--x11/deskmenu/distinfo4
-rw-r--r--x11/deskmenu/files/patch-Makefile31
-rw-r--r--x11/deskmenu/files/patch-deskmenu.131
-rw-r--r--x11/deskmenu/pkg-descr8
5 files changed, 67 insertions, 47 deletions
diff --git a/x11/deskmenu/Makefile b/x11/deskmenu/Makefile
index 4153920cd66a..f84d22e4d4f7 100644
--- a/x11/deskmenu/Makefile
+++ b/x11/deskmenu/Makefile
@@ -2,21 +2,39 @@
# $FreeBSD$
PORTNAME= deskmenu
-PORTVERSION= 1.3.0
-PORTREVISION= 5
+PORTVERSION= 1.4.5
CATEGORIES= x11
-MASTER_SITES= http://matt.peterson.org/FreeBSD/ports/ \
- http://gd.tuwien.ac.at/opsys/linux/gentoo/distfiles/
+MASTER_SITES= DEBIAN/pool/main/d/${PORTNAME} GENTOO
+DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= matt@peterson.org
COMMENT= X11 application launcher
-BROKEN= Does not fetch
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2016-04-15
-PLIST_FILES= bin/deskmenu
-USES= gmake
-USE_GNOME= gtk12
-USE_CSTD= gnu89
+LICENSE= GPLv2
+
+USES= pkgconfig
+GNU_CONFIGURE= yes
+USE_GNOME= gtk20
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+PLIST_FILES= bin/deskmenu man/man1/deskmenu.1.gz \
+ @sample\ etc/deskmenurc.sample
+PORTDOCS= AUTHORS ChangeLog
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,-O2 -g ,,' ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's,/etc/deskmenurc,${ETCDIR}rc,' \
+ ${WRKSRC}/example_rc ${WRKSRC}/src/deskmenu.c
+ @${LN} -sf debian/changelog ${WRKSRC}/ChangeLog
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/example_rc ${STAGEDIR}${ETCDIR}rc.sample
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/x11/deskmenu/distinfo b/x11/deskmenu/distinfo
index 9617f27f1604..00f37d5bed27 100644
--- a/x11/deskmenu/distinfo
+++ b/x11/deskmenu/distinfo
@@ -1,2 +1,2 @@
-SHA256 (deskmenu-1.3.0.tar.gz) = 668ed19ff1bd52a486519b14e5b1ade97aaa785282922a8d0bf99b7e99422b03
-SIZE (deskmenu-1.3.0.tar.gz) = 12227
+SHA256 (deskmenu_1.4.5.tar.gz) = a875ee1f7771233575d2662c94223a331985cf532843852ece1fd73f6a6c63f6
+SIZE (deskmenu_1.4.5.tar.gz) = 127599
diff --git a/x11/deskmenu/files/patch-Makefile b/x11/deskmenu/files/patch-Makefile
deleted file mode 100644
index ebf5b6df1902..000000000000
--- a/x11/deskmenu/files/patch-Makefile
+++ /dev/null
@@ -1,31 +0,0 @@
---- Makefile.orig 2001-05-22 18:44:52.000000000 +0800
-+++ Makefile 2014-01-10 14:41:23.000000000 +0800
-@@ -1,8 +1,7 @@
--CC = gcc
--CFLAGS = -g -O2 -Wall `gtk-config --cflags`
--XROOT = /usr/X11
-+CFLAGS += -g -O2 -Wall `gtk12-config --cflags`
-+XROOT = ${LOCALBASE}
- INCLUDES = -I$(XROOT)/include
--LIBS = -lX11 `gtk-config --libs`
-+LIBS = -lX11 `gtk12-config --libs`
- LDPATH = -L$(XROOT)/lib
-
- PROG = deskmenu
-@@ -10,7 +9,6 @@ HEADERS = $(PROG).h
- RCFILE = -DRCFILE=\".deskmenurc\"
- DEBUG = #-DDEBUG
- DEFINES = $(RCFILE) $(DEBUG)
--PREFIX = /usr
-
- OBJS = $(PROG).o popup.o workspaces.o windows.o
-
-@@ -23,7 +21,7 @@ $(OBJS): %.o: %.c $(HEADERS)
- $(CC) $(CFLAGS) $(DEFINES) $(INCLUDES) -c $< -o $@
-
- install: all
-- install $(PROG) $(PREFIX)/bin
-+ $(BSD_INSTALL_PROGRAM) $(PROG) $(DESTDIR)$(PREFIX)/bin
-
- clean:
- rm -f $(PROG) $(OBJS)
diff --git a/x11/deskmenu/files/patch-deskmenu.1 b/x11/deskmenu/files/patch-deskmenu.1
new file mode 100644
index 000000000000..a27598e23276
--- /dev/null
+++ b/x11/deskmenu/files/patch-deskmenu.1
@@ -0,0 +1,31 @@
+--- deskmenu.1.orig 2010-02-14 16:09:36 UTC
++++ deskmenu.1
+@@ -17,9 +17,7 @@ You can use deskmenu for session managem
+ last line of your .xinitrc and using the \-\-quit command line
+ option, which adds a quit option to the menu.
+ .LP
+-NOTE: Deskmenu will do nothing unless you have a ${HOME}/.deskmenurc file or a /etc/deskmenurc (/etc/deskmenurc.debian is automatically generated)
+-.br
+-This manpage is specific to the debian package of deskmenu.
++NOTE: Deskmenu will do nothing unless you have a ${HOME}/.deskmenurc file or a /usr/local/etc/deskmenurc.
+ .br
+ \fBIMPORTANT NOTE:\fR
+ You have to set a keycode, when using this version of keylaunch, in your config file.
+@@ -60,7 +58,7 @@ deskmenu \-\-button=[1...5] \-\-file=/ho
+ .LP
+ \fI${HOME}/.deskmenurc\fP
+ .br
+-\fI/etc/deskmenurc.debian\fP
++\fI/usr/local/etc/deskmenurc\fP
+ .SH "RCFILE"
+ .LP .deskmenurc
+ .br
+@@ -133,7 +131,7 @@ The current developer of Deskmenu.
+ This manpage was written for the Debian GNU/Linux package of
+ this program by
+ Brandon L. Griffith <brandon@debian.org>
+-because the origonal program did not include one. You are
++because the original program did not include one. You are
+ free to edit, translate, convert, or otherwise do anything
+ you wish with this manpage. This program was patched with a diff from Martin Hedenfalk <mhe@hjome.se> to allow submenu recursion.
+ Updated and added to the official deskmenu by
diff --git a/x11/deskmenu/pkg-descr b/x11/deskmenu/pkg-descr
index e56ae8520b69..0b6696bbccbc 100644
--- a/x11/deskmenu/pkg-descr
+++ b/x11/deskmenu/pkg-descr
@@ -1,4 +1,6 @@
-DeskMenu is a root menu program which is activated by clicking the root window.
-This gtk+ program is complementary to the Oroborus window manager.
+DeskMenu is a root menu program which is activated by clicking the root
+window. It is configured from a .deskmenurc file in user's home directory.
+DeskMenu is useful for window managers which do not provide a menu such as
+Oroborus.
-WWW: http://www.kensden.pwp.blueyonder.co.uk/Oroborus/
+WWW: http://www.oroborus.org/