aboutsummaryrefslogtreecommitdiff
path: root/x11/dzen2
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-03-22 08:16:07 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-03-22 08:16:07 +0000
commit5ff4e33fc09e0433096ff217208741e560f37db6 (patch)
tree0eed80486c0c9ee317000732b7da17a2b76db9f5 /x11/dzen2
parent6825f9380c20c8cc3a69580e8fcabda0603db4ff (diff)
downloadports-5ff4e33fc09e0433096ff217208741e560f37db6.tar.gz
ports-5ff4e33fc09e0433096ff217208741e560f37db6.zip
Convert to new options framework left unconverted ports in x* categories
Notes
Notes: svn path=/head/; revision=314894
Diffstat (limited to 'x11/dzen2')
-rw-r--r--x11/dzen2/Makefile22
1 files changed, 9 insertions, 13 deletions
diff --git a/x11/dzen2/Makefile b/x11/dzen2/Makefile
index eb85450c24ad..3f4d501706a2 100644
--- a/x11/dzen2/Makefile
+++ b/x11/dzen2/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: dzen2
-# Date created: May 26 2008
-# Whom: Morten Slot Kristensen
-#
+# Created by: Morten Slot Kristensen
# $FreeBSD$
-#
PORTNAME= dzen2
PORTVERSION= 0.8.5
@@ -18,26 +14,26 @@ USE_XORG= x11
PLIST_FILES= bin/${PORTNAME}
-OPTIONS= XPM "Enable XPM support" On \
- XINERAMA "Enable Xinerama support" On
+OPTIONS_DEFINE= XPM XINERAMA
+OPTIONS_DEFAULT= XPM XINERAMA
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_XPM)
+.if ${PORT_OPTIONS:MXPM}
USE_XORG+= xpm
.endif
-.if !defined(WITHOUT_XINERAMA)
+.if ${PORT_OPTIONS:MXINERAMA}
USE_XORG+= xinerama
.endif
post-patch:
-.if !defined(WITHOUT_XPM)
+.if ${PORT_OPTIONS:MXPM}
${REINPLACE_CMD} -e 's/^LIBS =\(.*\)$$/LIBS =\1 -lXpm/g' \
-e 's/^CFLAGS =\(.*\)$$/CFLAGS =\1 -DDZEN_XPM/g' \
${WRKSRC}/config.mk
.endif
-.if !defined(WITHOUT_XINERAMA)
+.if ${PORT_OPTIONS:MXINERAMA}
${REINPLACE_CMD} -e 's/^LIBS =\(.*\)$$/LIBS =\1 -lXinerama/g' \
-e 's/^CFLAGS =\(.*\)$$/CFLAGS =\1 -DDZEN_XINERAMA/g' \
${WRKSRC}/config.mk
@@ -45,4 +41,4 @@ post-patch:
${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},g' \
${WRKSRC}/config.mk
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>