aboutsummaryrefslogtreecommitdiff
path: root/x11/ecore-imf
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2008-03-11 21:13:53 +0000
committerStanislav Sedov <stas@FreeBSD.org>2008-03-11 21:13:53 +0000
commit9a2e4c8b780fc607dc4b4adabefb354c84401a96 (patch)
treef59767aed29b447d3d80ab987e898598663c27e3 /x11/ecore-imf
parent621c804e48a9fdddd6a00d78585fa8cb20c8460e (diff)
downloadports-9a2e4c8b780fc607dc4b4adabefb354c84401a96.tar.gz
ports-9a2e4c8b780fc607dc4b4adabefb354c84401a96.zip
Notes
Diffstat (limited to 'x11/ecore-imf')
-rw-r--r--x11/ecore-imf/Makefile55
-rw-r--r--x11/ecore-imf/distinfo3
-rw-r--r--x11/ecore-imf/pkg-descr5
-rw-r--r--x11/ecore-imf/pkg-plist6
4 files changed, 69 insertions, 0 deletions
diff --git a/x11/ecore-imf/Makefile b/x11/ecore-imf/Makefile
new file mode 100644
index 000000000000..06781e11477c
--- /dev/null
+++ b/x11/ecore-imf/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: ecore-imf
+# Date created: 17 September 2007
+# Whom: Stanislav Sedov <stas@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= imf
+PORTVERSION= 0.9.9.042
+PORTREVISION= 0
+CATEGORIES= x11
+MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
+ http://download.enlightenment.org/snapshots/2008-01-25/
+PKGNAMEPREFIX= ecore-
+DISTNAME= ecore-${PORTVERSION}
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= Enlightenment core abstraction library (IMF module)
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GNOME= gnomehack pkgconfig gnometarget
+USE_LDCONFIG= yes
+USE_GETOPT_LONG=yes
+USE_EFL= ecore
+BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_imf
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+CONFIGURE_ARGS= --enable-ecore-con \
+ --enable-ecore-config \
+ --disable-ecore-desktop \
+ --disable-ecore-directfb \
+ --disable-ecore-evas \
+ --disable-ecore-file \
+ --disable-ecore-ipc \
+ --disable-ecore-job \
+ --disable-ecore-sdl \
+ --disable-ecore-txt \
+ --disable-ecore-x \
+ --enable-ecore-imf \
+ --disable-ecore-imf_evas
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's,\$$\(top_builddir\)/src/lib/ecore/\.libs,${LOCALBASE}/lib,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore/libecore\.la,-lecore,'\
+ ${BUILD_WRKSRC}/Makefile.in
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/ecore-imf.pc \
+ ${PREFIX}/libdata/pkgconfig/
+
+.include <bsd.port.post.mk>
diff --git a/x11/ecore-imf/distinfo b/x11/ecore-imf/distinfo
new file mode 100644
index 000000000000..4672f6a1c167
--- /dev/null
+++ b/x11/ecore-imf/distinfo
@@ -0,0 +1,3 @@
+MD5 (ecore-0.9.9.042.tar.bz2) = a66df2b5f0b1a6abc47bb50bf2b26846
+SHA256 (ecore-0.9.9.042.tar.bz2) = 26486fd2c80e4000b673f81ce637aa50c17c767e4c2af8f56de5d110e387d136
+SIZE (ecore-0.9.9.042.tar.bz2) = 5285732
diff --git a/x11/ecore-imf/pkg-descr b/x11/ecore-imf/pkg-descr
new file mode 100644
index 000000000000..2559668d0e57
--- /dev/null
+++ b/x11/ecore-imf/pkg-descr
@@ -0,0 +1,5 @@
+A core event abstracter layer and X abstraction layer that makes doing
+selections, Xdnd, general X stuff, and event loops, timeouts and idle handlers
+fast, optimised, and convenient.
+
+WWW: http://enlightenment.sourceforge.net/Libraries/Ecore/
diff --git a/x11/ecore-imf/pkg-plist b/x11/ecore-imf/pkg-plist
new file mode 100644
index 000000000000..2f0ba4d3e68e
--- /dev/null
+++ b/x11/ecore-imf/pkg-plist
@@ -0,0 +1,6 @@
+include/Ecore_IMF.h
+lib/libecore_imf.a
+lib/libecore_imf.la
+lib/libecore_imf.so
+lib/libecore_imf.so.9
+libdata/pkgconfig/ecore-imf.pc