aboutsummaryrefslogtreecommitdiff
path: root/x11/erun
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-07-10 04:01:52 +0000
committerSteve Price <steve@FreeBSD.org>2000-07-10 04:01:52 +0000
commit2abf26ecde986cf03adf2c0faa13296163385949 (patch)
tree9c97317ab8db1a614400c7917ba7dad73bda9479 /x11/erun
parent21f96c05b7ee43fc0d12279139a085f9ad2048ad (diff)
downloadports-2abf26ecde986cf03adf2c0faa13296163385949.tar.gz
ports-2abf26ecde986cf03adf2c0faa13296163385949.zip
Adding erun version 1.2.
A simple epplet for launching arbitrary programs. PR: 19361 Submitted by: Kelly Yancey <kbyanc@posi.net>
Notes
Notes: svn path=/head/; revision=30424
Diffstat (limited to 'x11/erun')
-rw-r--r--x11/erun/Makefile21
-rw-r--r--x11/erun/distinfo1
-rw-r--r--x11/erun/files/patch-aa30
-rw-r--r--x11/erun/pkg-comment1
-rw-r--r--x11/erun/pkg-descr4
-rw-r--r--x11/erun/pkg-plist1
6 files changed, 58 insertions, 0 deletions
diff --git a/x11/erun/Makefile b/x11/erun/Makefile
new file mode 100644
index 000000000000..325381e6c8f8
--- /dev/null
+++ b/x11/erun/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: E-Run 1.2
+# Date created: 17 June 2000
+# Whom: Kelly Yancey <kbyanc@posi.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= E-Run
+PORTVERSION= 1.2
+CATEGORIES= x11
+MASTER_SITES= http://void.mapopolis.com/~jacob/c0de/
+
+MAINTAINER= kbyanc@posi.net
+
+LIB_DEPENDS= epplet.1:${PORTSDIR}/x11-wm/epplets
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_X_PREFIX= yes
+
+.include <bsd.port.mk>
diff --git a/x11/erun/distinfo b/x11/erun/distinfo
new file mode 100644
index 000000000000..37258fcf2c09
--- /dev/null
+++ b/x11/erun/distinfo
@@ -0,0 +1 @@
+MD5 (E-Run-1.2.tar.gz) = 2f57ef2f32bd545bd0522cd0f7613f2b
diff --git a/x11/erun/files/patch-aa b/x11/erun/files/patch-aa
new file mode 100644
index 000000000000..da0d9705f78b
--- /dev/null
+++ b/x11/erun/files/patch-aa
@@ -0,0 +1,30 @@
+--- Makefile.orig Tue Dec 14 11:14:20 1999
++++ Makefile Sun Jun 18 01:38:17 2000
+@@ -1,12 +1,17 @@
+-CFLAGS = -O3 -g
+-LINKFLAGS = -lepplet
++CFLAGS ?= -O3 -g
++LINKFLAGS = -lepplet -L/usr/X11R6/lib
++INCLUDEDIRS = -I/usr/X11R6/include
+
+-CC = gcc
++CFLAGS += $(INCLUDEDIRS)
++
++CC ?= gcc
+
+ EXEC_NAME = E-Run.epplet
+ EXEC_OBJECTS = E-Run.o
+
+-INSTALL_DIR = /usr/local/bin
++PREFIX ?= /usr/local
++INSTALL_DIR = ${PREFIX}/bin
++INSTALL_PROGRAM ?= install -c -m 755
+
+ all: $(EXEC_OBJECTS)
+ $(CC) -o $(EXEC_NAME) $(EXEC_OBJECTS) $(LINKFLAGS)
+@@ -15,4 +20,4 @@
+ rm -f $(EXEC_OBJECTS) $(EXEC_NAME) *~
+
+ install:
+- install -o root -m 0555 $(EXEC_NAME) $(INSTALL_DIR)
++ $(INSTALL_PROGRAM) $(EXEC_NAME) $(INSTALL_DIR)
diff --git a/x11/erun/pkg-comment b/x11/erun/pkg-comment
new file mode 100644
index 000000000000..128a5b198944
--- /dev/null
+++ b/x11/erun/pkg-comment
@@ -0,0 +1 @@
+A simple epplet for launching arbitrary programs
diff --git a/x11/erun/pkg-descr b/x11/erun/pkg-descr
new file mode 100644
index 000000000000..f9cb0358f68a
--- /dev/null
+++ b/x11/erun/pkg-descr
@@ -0,0 +1,4 @@
+This epplet provides a small text entry field for launching programs.
+
+ -Kelly
+ kbyanc@posi.net
diff --git a/x11/erun/pkg-plist b/x11/erun/pkg-plist
new file mode 100644
index 000000000000..4b66b6ac1adf
--- /dev/null
+++ b/x11/erun/pkg-plist
@@ -0,0 +1 @@
+bin/E-Run.epplet