aboutsummaryrefslogtreecommitdiff
path: root/x11/erun
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-06 21:19:35 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-06 21:19:35 +0000
commita71d622b5a834965e22c547f962d23bb58d084aa (patch)
treecfecd135b46d0476587519394af64d09ce872b34 /x11/erun
parent73e859460011b4e5b2ff4888c6ac84355fc398aa (diff)
downloadports-a71d622b5a834965e22c547f962d23bb58d084aa.tar.gz
ports-a71d622b5a834965e22c547f962d23bb58d084aa.zip
Support stage
Notes
Notes: svn path=/head/; revision=338936
Diffstat (limited to 'x11/erun')
-rw-r--r--x11/erun/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/x11/erun/Makefile b/x11/erun/Makefile
index 018f58283edb..df91f92daeae 100644
--- a/x11/erun/Makefile
+++ b/x11/erun/Makefile
@@ -9,9 +9,9 @@ MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= kbyanc
MAINTAINER= gahr@FreeBSD.org
-COMMENT= A simple epplet for launching arbitrary programs
+COMMENT= Simple epplet for launching arbitrary programs
-LIB_DEPENDS= epplet.3:${PORTSDIR}/x11-wm/epplets
+LIB_DEPENDS= libepplet.so:${PORTSDIR}/x11-wm/epplets
PLIST_FILES= bin/E-Run.epplet
@@ -22,12 +22,11 @@ USE_EFL= imlib2
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib -lepplet -lImlib2 -lGL ${PTHREAD_LIBS}
-NO_STAGE= yes
do-build:
cd ${WRKSRC} && ${CC} ${CFLAGS} ${CPPFLAGS} -o ${PORTNAME}.epplet \
${PORTNAME}.c ${LDFLAGS}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}.epplet ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}.epplet ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>