aboutsummaryrefslogtreecommitdiff
path: root/x11/fbdesk
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-17 11:04:07 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-17 11:04:07 +0000
commit1ab4a82f6906a6b1b85732bab297b558db34bc3b (patch)
treec9c099a2ea6ac8c7802c3578589b25e5d5ac1c74 /x11/fbdesk
parent2408fdce5aa82882af7c198d0f80a1bb87cc0864 (diff)
downloadports-1ab4a82f6906a6b1b85732bab297b558db34bc3b.tar.gz
ports-1ab4a82f6906a6b1b85732bab297b558db34bc3b.zip
- Switch to options helpers
- Make imlib2 support non-optional, port doesn't build with it disabled
Notes
Notes: svn path=/head/; revision=397106
Diffstat (limited to 'x11/fbdesk')
-rw-r--r--x11/fbdesk/Makefile18
1 files changed, 4 insertions, 14 deletions
diff --git a/x11/fbdesk/Makefile b/x11/fbdesk/Makefile
index bf8b4a57f76c..e0a3b7fa4285 100644
--- a/x11/fbdesk/Makefile
+++ b/x11/fbdesk/Makefile
@@ -13,10 +13,8 @@ COMMENT= Fluxbox utility to create and manage icons on the desktop
LICENSE= MIT
-LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
-
-OPTIONS_DEFINE= IMLIB2 DOCS
-OPTIONS_DEFAULT= IMLIB2
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
+ libImlib2.so:${PORTSDIR}/graphics/imlib2
USE_XORG= xext xft xpm xrender
USES= pkgconfig
@@ -25,18 +23,10 @@ GNU_CONFIGURE= yes
PORTDOCS= ChangeLog INSTALL README
PLIST_FILES= bin/fbdesk
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MIMLIB2}
-LIB_DEPENDS+= libImlib2.so:${PORTSDIR}/graphics/imlib2
-.else
-CONFIGURE_ARGS+= --disable-imlib2
-.endif
+OPTIONS_DEFINE= DOCS
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>