aboutsummaryrefslogtreecommitdiff
path: root/x11/gmrun/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-05-23 19:10:10 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-05-23 19:10:10 +0000
commit736d37bd4e8453db31deda809c54c1ff063395ce (patch)
tree3b0fc8868113a525b56a8880fa99468214b0dab2 /x11/gmrun/Makefile
parent31221631d91a4bd4f2f2dfcadf4ae2393bcdea56 (diff)
downloadports-736d37bd4e8453db31deda809c54c1ff063395ce.tar.gz
ports-736d37bd4e8453db31deda809c54c1ff063395ce.zip
Notes
Diffstat (limited to 'x11/gmrun/Makefile')
-rw-r--r--x11/gmrun/Makefile25
1 files changed, 14 insertions, 11 deletions
diff --git a/x11/gmrun/Makefile b/x11/gmrun/Makefile
index 260295a56233..b6000dae0236 100644
--- a/x11/gmrun/Makefile
+++ b/x11/gmrun/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gmrun
-PORTVERSION= 0.9
-PORTREVISION= 2
+PORTVERSION= 0.9.2
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,21 +14,25 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A customizable program to run programs, with tab-completion
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+
+USE_GCC= 3.3
USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
+USE_GNOME= gtk20
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack gtk20
-
-.include <bsd.port.pre.mk>
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --disable-stlport
-.if ${OSVERSION} < 500000
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
-.endif
+PORTDOCS= README
+PLIST_FILES= bin/gmrun %%DATADIR%%/gmrunrc
+PLIST_DIRS= %%DATADIR%%
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>