aboutsummaryrefslogtreecommitdiff
path: root/x11/gmrun
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2019-05-27 11:35:27 +0000
committerRenato Botelho <garga@FreeBSD.org>2019-05-27 11:35:27 +0000
commit5c91a4249958490f350d80c89b69c74a0a8c03a0 (patch)
tree6cbfa6e915777bb992b3eaa7dfa0aefdb1d8f07c /x11/gmrun
parent9657c0c5d773ae8b0ed3cbaed6ee96df0f1e1ddf (diff)
downloadports-5c91a4249958490f350d80c89b69c74a0a8c03a0.tar.gz
ports-5c91a4249958490f350d80c89b69c74a0a8c03a0.zip
x11/gmrun: Fix build with GCC architectures [1]
- Add USES=compiler:c++11-lang [1] - Include cstring in src/ci_string.h [1] - Add USES=gnome localbase:ldflags [1] - While here, add mising dependencies and pet portlint PR: 237871 [1] Submitted by: pkubaj@ Sponsored by: Rubicon Communications, LLC (Netgate)
Notes
Notes: svn path=/head/; revision=502783
Diffstat (limited to 'x11/gmrun')
-rw-r--r--x11/gmrun/Makefile19
-rw-r--r--x11/gmrun/files/patch-src__gtkcompletionline.cc10
-rw-r--r--x11/gmrun/files/patch-src__gtkcompletionline.h6
-rw-r--r--x11/gmrun/files/patch-src_ci__string.h10
4 files changed, 29 insertions, 16 deletions
diff --git a/x11/gmrun/Makefile b/x11/gmrun/Makefile
index 8fc5139c059e..5641a5b6377c 100644
--- a/x11/gmrun/Makefile
+++ b/x11/gmrun/Makefile
@@ -3,32 +3,35 @@
PORTNAME= gmrun
PORTVERSION= 0.9.2
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= x11
MASTER_SITES= SF
MAINTAINER= garga@FreeBSD.org
COMMENT= Customizable program to run programs, with tab-completion
-LIB_DEPENDS= libpopt.so:devel/popt
+LICENSE= GPLv2
+
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libpopt.so:devel/popt
+
+USES= compiler:c++11-lang gmake gnome localbase:ldflags pkgconfig
OPTIONS_DEFINE= DOCS
-USES= gmake pkgconfig
-USE_GNOME= gtk20
+USE_GNOME= cairo gdkpixbuf2 gtk20
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --disable-stlport
PORTDOCS= README
-PLIST_FILES= bin/gmrun %%DATADIR%%/gmrunrc
+PLIST_FILES= bin/gmrun ${DATADIR}/gmrunrc
post-patch:
@${REINPLACE_CMD} -e '/my_alphasort/s#const void\*#const struct dirent**#g' \
${WRKSRC}/src/gtkcompletionline.cc
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
diff --git a/x11/gmrun/files/patch-src__gtkcompletionline.cc b/x11/gmrun/files/patch-src__gtkcompletionline.cc
index 347dcaab7b7b..cf319973f937 100644
--- a/x11/gmrun/files/patch-src__gtkcompletionline.cc
+++ b/x11/gmrun/files/patch-src__gtkcompletionline.cc
@@ -1,6 +1,6 @@
---- ./src/gtkcompletionline.cc.orig 2003-11-16 13:55:07.000000000 +0300
-+++ ./src/gtkcompletionline.cc 2010-01-20 21:25:08.847480188 +0300
-@@ -39,6 +39,8 @@
+--- src/gtkcompletionline.cc.orig 2003-11-16 10:55:07 UTC
++++ src/gtkcompletionline.cc
+@@ -39,6 +39,8 @@ static int on_key_press_handler = 0;
/* GLOBALS */
@@ -9,7 +9,7 @@
/* signals */
enum {
UNIQUE,
-@@ -76,14 +78,13 @@
+@@ -76,14 +78,13 @@ static gboolean
on_key_press(GtkCompletionLine *cl, GdkEventKey *event, gpointer data);
/* get_type */
@@ -26,7 +26,7 @@
sizeof(GtkCompletionLine),
sizeof(GtkCompletionLineClass),
(GtkClassInitFunc)gtk_completion_line_class_init,
-@@ -551,10 +552,10 @@
+@@ -551,10 +552,10 @@ parse_tilda(GtkCompletionLine *object)
{
string text = gtk_entry_get_text(GTK_ENTRY(object));
gint where = (gint)text.find("~");
diff --git a/x11/gmrun/files/patch-src__gtkcompletionline.h b/x11/gmrun/files/patch-src__gtkcompletionline.h
index 9db0e9267ad4..6d690681f5c0 100644
--- a/x11/gmrun/files/patch-src__gtkcompletionline.h
+++ b/x11/gmrun/files/patch-src__gtkcompletionline.h
@@ -1,6 +1,6 @@
---- ./src/gtkcompletionline.h.orig 2003-11-16 13:43:32.000000000 +0300
-+++ ./src/gtkcompletionline.h 2010-01-20 21:24:57.489100621 +0300
-@@ -76,7 +76,7 @@
+--- src/gtkcompletionline.h.orig 2003-11-16 10:43:32 UTC
++++ src/gtkcompletionline.h
+@@ -76,7 +76,7 @@ extern "C++" {
void (* cancel)(GtkCompletionLine *cl);
};
diff --git a/x11/gmrun/files/patch-src_ci__string.h b/x11/gmrun/files/patch-src_ci__string.h
new file mode 100644
index 000000000000..140f9547c676
--- /dev/null
+++ b/x11/gmrun/files/patch-src_ci__string.h
@@ -0,0 +1,10 @@
+--- src/ci_string.h.orig 2019-05-27 11:24:56 UTC
++++ src/ci_string.h
+@@ -6,6 +6,7 @@
+ #ifndef __CI_STRING_H__
+ #define __CI_STRING_H__
+
++#include <cstring>
+ #include <string>
+ #include <ctype.h>
+