aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-pie/Makefile
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2015-02-22 13:03:50 +0000
committerNicola Vitale <nivit@FreeBSD.org>2015-02-22 13:03:50 +0000
commitbd3f46e2d6eb4d8a6587f5fce43c196d19a5df70 (patch)
treef84ff1ddedce520b77856e54b79d2aee026c4595 /x11/gnome-pie/Makefile
parent9492955b189e1a55da9d5142696590b0dff9ab0d (diff)
downloadports-bd3f46e2d6eb4d8a6587f5fce43c196d19a5df70.tar.gz
ports-bd3f46e2d6eb4d8a6587f5fce43c196d19a5df70.zip
(Readdition of x11/gnome-pie which was removed on 372767)
Gnome-Pie is a circular application launcher. It is made of several pies, each consisting of multiple slices. The user presses a key stroke which opens the desired pie. By activating one of its slices, applications may be launched, key presses may be simulated or files can be opened. WWW: http://simmesimme.github.io/gnome-pie.html
Notes
Notes: svn path=/head/; revision=379603
Diffstat (limited to 'x11/gnome-pie/Makefile')
-rw-r--r--x11/gnome-pie/Makefile57
1 files changed, 57 insertions, 0 deletions
diff --git a/x11/gnome-pie/Makefile b/x11/gnome-pie/Makefile
new file mode 100644
index 000000000000..7d7003411103
--- /dev/null
+++ b/x11/gnome-pie/Makefile
@@ -0,0 +1,57 @@
+# Created by: Nicola Vitale <nivit@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= gnome-pie
+PORTVERSION= 0.5.7
+PORTREVISION= 0
+CATEGORIES= x11
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Circular application launcher
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= valac:${PORTSDIR}/lang/vala
+RUN_DEPENDS= gnome-settings-daemon>=2.32.1_4:${PORTSDIR}/sysutils/gnome-settings-daemon
+LIB_DEPENDS= libbamf3.so:${PORTSDIR}/sysutils/bamf \
+ libgee-0.8.so:${PORTSDIR}/devel/libgee \
+ libunique-1.0.so:${PORTSDIR}/x11-toolkits/unique
+
+DOCS_CMAKE_ON= -DINSTALL_DOCS:BOOL=ON
+
+GH_ACCOUNT= Simmesimme
+GH_COMMIT= 6ee3a64
+GH_PROJECT= Gnome-Pie
+GH_TAGNAME= v${PORTVERSION}
+
+INSTALLS_ICONS= yes
+
+MANPAGES_CMAKE_OFF= -DNO_INSTALL_MANPAGES:BOOL=ON
+
+NLS_CMAKE_OFF= -DINSTALL_NLS:BOOL=OFF
+NLS_CMAKE_ON= -DINSTALL_NLS:BOOL=ON
+NLS_USES= gettext
+
+OPTIONS_DEFAULT= MANPAGES
+OPTIONS_DEFINE= DOCS MANPAGES NLS
+OPTIONS_SUB= yes
+
+PLIST_SUB= DESKTOPDIR=${DESKTOPDIR}
+
+REINPLACE_ARGS= -e 's,%%DATADIR%%,${DATADIR},1' \
+ -e 's,%%DESKTOPDIR%%,${DESKTOPDIR},1' \
+ -e 's,%%PREFIX%%,${PREFIX},1' -i.bak \
+ -e '/has_resize_grip/d' -i ''
+
+USES= cmake pkgconfig
+USE_GITHUB= yes
+USE_GNOME= cairo gconf2 gnomemenus3 gtk30 librsvg2 libwnck3
+USE_XORG= xtst
+
+post-patch:
+ ${REINPLACE_CMD} ${WRKSRC}/src/actions/actionRegistry.vala \
+ ${WRKSRC}/src/gui/indicator.vala \
+ ${WRKSRC}/src/utilities/paths.vala \
+ ${WRKSRC}/resources/ui/*.ui
+
+.include <bsd.port.mk>