aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-session
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-01-01 18:02:34 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-01-01 18:02:34 +0000
commit149cdd59f629ad9c77cde3e5eb19d31074b7f715 (patch)
treeae2774029402f9f806e53e1c1f14e49f8c7b8fde /x11/gnome-session
parent9dac381d0b7452e1053372d572ab0fc6d5ff809d (diff)
downloadports-149cdd59f629ad9c77cde3e5eb19d31074b7f715.tar.gz
ports-149cdd59f629ad9c77cde3e5eb19d31074b7f715.zip
Notes
Diffstat (limited to 'x11/gnome-session')
-rw-r--r--x11/gnome-session/Makefile1
-rw-r--r--x11/gnome-session/files/patch-gnome-session_gsm-app.c18
2 files changed, 19 insertions, 0 deletions
diff --git a/x11/gnome-session/Makefile b/x11/gnome-session/Makefile
index f2066695feb4..3cb30b8c6715 100644
--- a/x11/gnome-session/Makefile
+++ b/x11/gnome-session/Makefile
@@ -4,6 +4,7 @@
PORTNAME= gnome-session
PORTVERSION= 3.14.0
+PORTREVISION= 1
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
diff --git a/x11/gnome-session/files/patch-gnome-session_gsm-app.c b/x11/gnome-session/files/patch-gnome-session_gsm-app.c
new file mode 100644
index 000000000000..99dae02a7143
--- /dev/null
+++ b/x11/gnome-session/files/patch-gnome-session_gsm-app.c
@@ -0,0 +1,18 @@
+Work around for the https://bugzilla.gnome.org/show_bug.cgi?id=739424 bug
+
+Reduces the time gnome-session will consider application, like gnome-shell,
+crashes to be fatal. And drop the user back to the login screen.
+This will hopefully allow gnome-shell to restart after triggering the bug
+above.
+
+--- gnome-session/gsm-app.c.orig 2015-01-01 17:20:24.798482241 +0100
++++ gnome-session/gsm-app.c 2015-01-01 17:20:38.627540889 +0100
+@@ -30,7 +30,7 @@
+ #define GSM_APP_GET_PRIVATE(o) (G_TYPE_INSTANCE_GET_PRIVATE ((o), GSM_TYPE_APP, GsmAppPrivate))
+
+ /* If a component crashes twice within a minute, we count that as a fatal error */
+-#define _GSM_APP_RESPAWN_RATELIMIT_SECONDS 60
++#define _GSM_APP_RESPAWN_RATELIMIT_SECONDS 3
+
+ struct _GsmAppPrivate
+ {