aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-shell
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-08-05 19:13:24 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-08-05 19:13:24 +0000
commitd129587b5d568b0ff5300386f1e1b706c349f38e (patch)
treee398c7b6ea5203fd3953999e6dd9d6c83c9ec931 /x11/gnome-shell
parentc13de12f75988e599e389d9c77ed92db8d927185 (diff)
downloadports-d129587b5d568b0ff5300386f1e1b706c349f38e.tar.gz
ports-d129587b5d568b0ff5300386f1e1b706c349f38e.zip
The FreeBSD GNOME team proudly presents GNOME 3.16 for FreeBSD.
The offical GNOME 3.16 release notes can be found at https://help.gnome.org/misc/release-notes/3.16/ Upgrade instructions for port users: Delete the old tracker package with: # pkg delete -f tracker And user port upgrade tool of choice to upgrade. Thanks to Antoine Brodin for running the exp-runs. This release was made possible by the following people: Gustau Perez Ting-Wei_Lan PR: 201980
Notes
Notes: svn path=/head/; revision=393607
Diffstat (limited to 'x11/gnome-shell')
-rw-r--r--x11/gnome-shell/Makefile12
-rw-r--r--x11/gnome-shell/distinfo4
-rw-r--r--x11/gnome-shell/files/patch-src_shell-global.c31
-rw-r--r--x11/gnome-shell/pkg-plist205
4 files changed, 93 insertions, 159 deletions
diff --git a/x11/gnome-shell/Makefile b/x11/gnome-shell/Makefile
index 5186e5334bfa..a2b74d6d81c4 100644
--- a/x11/gnome-shell/Makefile
+++ b/x11/gnome-shell/Makefile
@@ -1,9 +1,8 @@
# Created by: Pawel Worach <pawel.worach@gmail.com>
# $FreeBSD$
-# $MCom: ports/trunk/x11/gnome-shell/Makefile 20036 2014-11-03 08:23:27Z kwm $
PORTNAME= gnome-shell
-PORTVERSION= 3.14.4
+PORTVERSION= 3.16.3
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -28,7 +27,6 @@ LIB_DEPENDS= libstartup-notification-1.so:${PORTSDIR}/x11/startup-notification \
libclutter-1.0.so:${PORTSDIR}/graphics/clutter \
libgjs.so:${PORTSDIR}/lang/gjs
RUN_DEPENDS= py*-dbus>=0:${PORTSDIR}/devel/py-dbus \
- gdm>=0:${PORTSDIR}/x11/gdm \
gnome-control-center:${PORTSDIR}/sysutils/gnome-control-center \
ca_root_nss>=0:${PORTSDIR}/security/ca_root_nss
@@ -36,17 +34,17 @@ PORTSCOUT= limitw:1,even
USES= compiler:c11 cpe gettext gmake libtool pathfix pkgconfig \
tar:xz webplugin:native
-USE_GNOME= evolutiondataserver3 gnomedesktop3 gnomeprefix \
- gtk30 intlhack introspection
+USE_GNOME= evolutiondataserver3 gnomedesktop3 gtk30 intlhack \
+ introspection
USE_XORG= x11 xfixes sm
USE_GSTREAMER1= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-WEBPLUGIN_DIR= ${PREFIX}/lib/
+WEBPLUGIN_NAME= libgnome-shell-browser-plugin.so
+WEBPLUGIN_DIR= ${PREFIX}/lib/mozilla/plugins/
WEBPLUGIN_FILES=libgnome-shell-browser-plugin.so
CONFIGURE_ARGS+=--enable-compile-warnings=no \
--with-ca-certificates=${LOCALBASE}/share/certs/ca-root-nss.crt
-CONFIGURE_ENV+= BROWSER_PLUGIN_DIR=${PREFIX}/lib/
CPPFLAGS+= -I${LOCALASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
diff --git a/x11/gnome-shell/distinfo b/x11/gnome-shell/distinfo
index 3171f85f7352..f7bc31a16203 100644
--- a/x11/gnome-shell/distinfo
+++ b/x11/gnome-shell/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome3/gnome-shell-3.14.4.tar.xz) = 43336da7edece72bf298f1749510abb8470b625585e551c8b45258981435fd80
-SIZE (gnome3/gnome-shell-3.14.4.tar.xz) = 1597744
+SHA256 (gnome3/gnome-shell-3.16.3.tar.xz) = 227eff19fdf50fd7ac605e8068454a6a6bc6d1bd73281b28305c3cd8a91190cb
+SIZE (gnome3/gnome-shell-3.16.3.tar.xz) = 1593148
diff --git a/x11/gnome-shell/files/patch-src_shell-global.c b/x11/gnome-shell/files/patch-src_shell-global.c
deleted file mode 100644
index d770f8b45ec4..000000000000
--- a/x11/gnome-shell/files/patch-src_shell-global.c
+++ /dev/null
@@ -1,31 +0,0 @@
---- src/shell-global.c.orig 2014-10-13 22:57:06.000000000 +0200
-+++ src/shell-global.c 2014-10-20 15:37:28.727759860 +0200
-@@ -1240,13 +1240,13 @@
- {
- GPtrArray *arr;
- gsize len;
--
--#if defined __linux__
- char *buf;
- char *buf_p;
- char *buf_end;
- GError *error = NULL;
-
-+#if defined __linux__
-+
- if (!g_file_get_contents ("/proc/self/cmdline", &buf, &len, &error))
- {
- g_warning ("failed to get /proc/self/cmdline: %s", error->message);
-@@ -1281,6 +1281,12 @@
- }
-
- g_ptr_array_add (arr, NULL);
-+#elif defined __FreeBSD__
-+ if (!g_file_get_contents ("/proc/curproc/cmdline", &buf, &len, &error))
-+ {
-+ g_warning ("failed to get /proc/curproc/cmdline: %s", error->message);
-+ return;
-+ }
- #else
- return;
- #endif
diff --git a/x11/gnome-shell/pkg-plist b/x11/gnome-shell/pkg-plist
index 1ef1d900b4f8..80e1ff0136b4 100644
--- a/x11/gnome-shell/pkg-plist
+++ b/x11/gnome-shell/pkg-plist
@@ -5,12 +5,12 @@ bin/gnome-shell-perf-tool
lib/gnome-shell/Gvc-1.0.typelib
lib/gnome-shell/Shell-0.1.typelib
lib/gnome-shell/ShellJS-0.1.typelib
-%%WEBPLUGIN_DIR%%gnome-shell/ShellMenu-0.1.typelib
+lib/gnome-shell/ShellMenu-0.1.typelib
lib/gnome-shell/St-1.0.typelib
lib/gnome-shell/libgnome-shell-js.so
-%%WEBPLUGIN_DIR%%gnome-shell/libgnome-shell-menu.so
+lib/gnome-shell/libgnome-shell-menu.so
lib/gnome-shell/libgnome-shell.so
-lib/libgnome-shell-browser-plugin.so
+%%WEBPLUGIN_DIR%%libgnome-shell-browser-plugin.so
libexec/gnome-shell-calendar-server
libexec/gnome-shell-hotplug-sniffer
libexec/gnome-shell-perf-helper
@@ -26,123 +26,87 @@ share/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
share/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
share/dbus-1/services/org.gnome.Shell.CalendarServer.service
share/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
-share/doc/shell/ShellApp.html
-share/doc/shell/ShellAppSystem.html
-share/doc/shell/ShellAppUsage.html
-share/doc/shell/ShellEmbeddedWindow.html
-share/doc/shell/ShellGenericContainer.html
-share/doc/shell/ShellGlobal.html
-share/doc/shell/ShellGtkEmbed.html
-share/doc/shell/ShellMountOperation.html
-share/doc/shell/ShellSlicer.html
-share/doc/shell/ShellStack.html
-share/doc/shell/ShellTpClient.html
-share/doc/shell/ShellTrayIcon.html
-share/doc/shell/ShellTrayManager.html
-share/doc/shell/ShellWM.html
-share/doc/shell/ShellWindowTracker.html
-share/doc/shell/annotation-glossary.html
-share/doc/shell/api-index-full.html
-share/doc/shell/ch01.html
-share/doc/shell/ch02.html
-share/doc/shell/ch03.html
-share/doc/shell/ch04.html
-share/doc/shell/ch05.html
-share/doc/shell/ch06.html
-share/doc/shell/deprecated-api-index.html
-share/doc/shell/gdbus-org.gnome.Shell.SearchProvider.html
-share/doc/shell/gdbus-org.gnome.Shell.SearchProvider2.html
-share/doc/shell/home.png
-share/doc/shell/index.html
-share/doc/shell/index.sgml
-share/doc/shell/left-insensitive.png
-share/doc/shell/left.png
-share/doc/shell/object-tree.html
-share/doc/shell/right-insensitive.png
-share/doc/shell/right.png
-share/doc/shell/shell-shell-keybinding-modes.html
-share/doc/shell/shell-shell-polkit-authentication-agent.html
-share/doc/shell/shell-shell-recorder.html
-share/doc/shell/shell-shell-util.html
-share/doc/shell/shell.devhelp2
-share/doc/shell/style.css
-share/doc/shell/up-insensitive.png
-share/doc/shell/up.png
-share/doc/st/StBin.html
-share/doc/st/StBoxLayout.html
-share/doc/st/StButton.html
-share/doc/st/StDrawingArea.html
-share/doc/st/StEntry.html
-share/doc/st/StIcon.html
-share/doc/st/StLabel.html
-share/doc/st/StScrollView.html
-share/doc/st/StScrollable.html
-share/doc/st/StTable.html
-share/doc/st/StTextureCache.html
-share/doc/st/StThemeNodeTransition.html
-share/doc/st/StWidget.html
-share/doc/st/StWidgetAccessible.html
-share/doc/st/annotation-glossary.html
-share/doc/st/api-index-full.html
-share/doc/st/base.html
-share/doc/st/containers.html
-share/doc/st/deprecated-api-index.html
-share/doc/st/home.png
-share/doc/st/index.html
-share/doc/st/index.sgml
-share/doc/st/left-insensitive.png
-share/doc/st/left.png
-share/doc/st/object-tree.html
-share/doc/st/pt01.html
-share/doc/st/right-insensitive.png
-share/doc/st/right.png
-share/doc/st/st-st-theme-context.html
-share/doc/st/st-st-theme-node.html
-share/doc/st/st-st-theme.html
-share/doc/st/st.devhelp2
-share/doc/st/style.css
-share/doc/st/styling.html
-share/doc/st/up-insensitive.png
-share/doc/st/up.png
-share/doc/st/widgets.html
share/gnome-control-center/keybindings/50-gnome-shell-system.xml
-share/gnome-shell/perf-background.xml
-share/gnome-shell/theme/calendar-arrow-left.svg
-share/gnome-shell/theme/calendar-arrow-right.svg
-share/gnome-shell/theme/calendar-today.svg
-share/gnome-shell/theme/checkbox-focused.svg
-share/gnome-shell/theme/checkbox-off-focused.svg
-share/gnome-shell/theme/checkbox-off.svg
-share/gnome-shell/theme/checkbox.svg
-share/gnome-shell/theme/close-window.svg
-share/gnome-shell/theme/close.svg
-share/gnome-shell/theme/corner-ripple-ltr.png
-share/gnome-shell/theme/corner-ripple-rtl.png
-share/gnome-shell/theme/dash-placeholder.svg
-share/gnome-shell/theme/filter-selected-ltr.svg
-share/gnome-shell/theme/filter-selected-rtl.svg
-share/gnome-shell/theme/gnome-shell.css
-share/gnome-shell/theme/logged-in-indicator.svg
-share/gnome-shell/theme/message-tray-background.png
-share/gnome-shell/theme/more-results.svg
-share/gnome-shell/theme/noise-texture.png
-share/gnome-shell/theme/page-indicator-active.svg
-share/gnome-shell/theme/page-indicator-checked.svg
-share/gnome-shell/theme/page-indicator-hover.svg
-share/gnome-shell/theme/page-indicator-inactive.svg
-share/gnome-shell/theme/panel-button-border.svg
-share/gnome-shell/theme/panel-button-highlight-narrow.svg
-share/gnome-shell/theme/panel-button-highlight-wide.svg
-share/gnome-shell/theme/process-working.svg
-share/gnome-shell/theme/running-indicator.svg
-share/gnome-shell/theme/source-button-border.svg
-share/gnome-shell/theme/summary-counter.svg
-share/gnome-shell/theme/toggle-off-intl.svg
-share/gnome-shell/theme/toggle-off-us.svg
-share/gnome-shell/theme/toggle-on-intl.svg
-share/gnome-shell/theme/toggle-on-us.svg
-share/gnome-shell/theme/ws-switch-arrow-down.png
-share/gnome-shell/theme/ws-switch-arrow-up.png
+%%DATADIR%%/gnome-shell-theme.gresource
+%%DATADIR%%/perf-background.xml
+share/gtk-doc/html/shell/ShellApp.html
+share/gtk-doc/html/shell/ShellAppSystem.html
+share/gtk-doc/html/shell/ShellAppUsage.html
+share/gtk-doc/html/shell/ShellEmbeddedWindow.html
+share/gtk-doc/html/shell/ShellGenericContainer.html
+share/gtk-doc/html/shell/ShellGlobal.html
+share/gtk-doc/html/shell/ShellGtkEmbed.html
+share/gtk-doc/html/shell/ShellMountOperation.html
+share/gtk-doc/html/shell/ShellStack.html
+share/gtk-doc/html/shell/ShellTpClient.html
+share/gtk-doc/html/shell/ShellTrayIcon.html
+share/gtk-doc/html/shell/ShellTrayManager.html
+share/gtk-doc/html/shell/ShellWM.html
+share/gtk-doc/html/shell/ShellWindowTracker.html
+share/gtk-doc/html/shell/annotation-glossary.html
+share/gtk-doc/html/shell/api-index-full.html
+share/gtk-doc/html/shell/ch01.html
+share/gtk-doc/html/shell/ch02.html
+share/gtk-doc/html/shell/ch03.html
+share/gtk-doc/html/shell/ch04.html
+share/gtk-doc/html/shell/ch05.html
+share/gtk-doc/html/shell/ch06.html
+share/gtk-doc/html/shell/deprecated-api-index.html
+share/gtk-doc/html/shell/gdbus-org.gnome.Shell.SearchProvider.html
+share/gtk-doc/html/shell/gdbus-org.gnome.Shell.SearchProvider2.html
+share/gtk-doc/html/shell/home.png
+share/gtk-doc/html/shell/index.html
+share/gtk-doc/html/shell/index.sgml
+share/gtk-doc/html/shell/left-insensitive.png
+share/gtk-doc/html/shell/left.png
+share/gtk-doc/html/shell/object-tree.html
+share/gtk-doc/html/shell/right-insensitive.png
+share/gtk-doc/html/shell/right.png
+share/gtk-doc/html/shell/shell-shell-action-modes.html
+share/gtk-doc/html/shell/shell-shell-polkit-authentication-agent.html
+share/gtk-doc/html/shell/shell-shell-recorder.html
+share/gtk-doc/html/shell/shell-shell-util.html
+share/gtk-doc/html/shell/shell.devhelp2
+share/gtk-doc/html/shell/style.css
+share/gtk-doc/html/shell/up-insensitive.png
+share/gtk-doc/html/shell/up.png
+share/gtk-doc/html/st/StBin.html
+share/gtk-doc/html/st/StBoxLayout.html
+share/gtk-doc/html/st/StButton.html
+share/gtk-doc/html/st/StDrawingArea.html
+share/gtk-doc/html/st/StEntry.html
+share/gtk-doc/html/st/StIcon.html
+share/gtk-doc/html/st/StLabel.html
+share/gtk-doc/html/st/StScrollView.html
+share/gtk-doc/html/st/StScrollable.html
+share/gtk-doc/html/st/StTable.html
+share/gtk-doc/html/st/StTextureCache.html
+share/gtk-doc/html/st/StThemeNodeTransition.html
+share/gtk-doc/html/st/StWidget.html
+share/gtk-doc/html/st/StWidgetAccessible.html
+share/gtk-doc/html/st/annotation-glossary.html
+share/gtk-doc/html/st/api-index-full.html
+share/gtk-doc/html/st/base.html
+share/gtk-doc/html/st/containers.html
+share/gtk-doc/html/st/deprecated-api-index.html
+share/gtk-doc/html/st/home.png
+share/gtk-doc/html/st/index.html
+share/gtk-doc/html/st/index.sgml
+share/gtk-doc/html/st/left-insensitive.png
+share/gtk-doc/html/st/left.png
+share/gtk-doc/html/st/object-tree.html
+share/gtk-doc/html/st/pt01.html
+share/gtk-doc/html/st/right-insensitive.png
+share/gtk-doc/html/st/right.png
+share/gtk-doc/html/st/st-st-theme-context.html
+share/gtk-doc/html/st/st-st-theme-node.html
+share/gtk-doc/html/st/st-st-theme.html
+share/gtk-doc/html/st/st.devhelp2
+share/gtk-doc/html/st/style.css
+share/gtk-doc/html/st/styling.html
+share/gtk-doc/html/st/up-insensitive.png
+share/gtk-doc/html/st/up.png
+share/gtk-doc/html/st/widgets.html
share/locale/af/LC_MESSAGES/gnome-shell.mo
share/locale/an/LC_MESSAGES/gnome-shell.mo
share/locale/ar/LC_MESSAGES/gnome-shell.mo
@@ -176,6 +140,7 @@ share/locale/hi/LC_MESSAGES/gnome-shell.mo
share/locale/hu/LC_MESSAGES/gnome-shell.mo
share/locale/ia/LC_MESSAGES/gnome-shell.mo
share/locale/id/LC_MESSAGES/gnome-shell.mo
+share/locale/is/LC_MESSAGES/gnome-shell.mo
share/locale/it/LC_MESSAGES/gnome-shell.mo
share/locale/ja/LC_MESSAGES/gnome-shell.mo
share/locale/kk/LC_MESSAGES/gnome-shell.mo
@@ -194,6 +159,7 @@ share/locale/nb/LC_MESSAGES/gnome-shell.mo
share/locale/ne/LC_MESSAGES/gnome-shell.mo
share/locale/nl/LC_MESSAGES/gnome-shell.mo
share/locale/nn/LC_MESSAGES/gnome-shell.mo
+share/locale/oc/LC_MESSAGES/gnome-shell.mo
share/locale/or/LC_MESSAGES/gnome-shell.mo
share/locale/pa/LC_MESSAGES/gnome-shell.mo
share/locale/pl/LC_MESSAGES/gnome-shell.mo
@@ -214,6 +180,7 @@ share/locale/th/LC_MESSAGES/gnome-shell.mo
share/locale/tr/LC_MESSAGES/gnome-shell.mo
share/locale/ug/LC_MESSAGES/gnome-shell.mo
share/locale/uk/LC_MESSAGES/gnome-shell.mo
+share/locale/uz@cyrillic/LC_MESSAGES/gnome-shell.mo
share/locale/vi/LC_MESSAGES/gnome-shell.mo
share/locale/zh_CN/LC_MESSAGES/gnome-shell.mo
share/locale/zh_HK/LC_MESSAGES/gnome-shell.mo