aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2022-01-31 21:56:04 +0000
committerNeel Chauhan <nc@FreeBSD.org>2022-01-31 21:56:04 +0000
commiteaefe7d4ecf41c002de61c21fb214ef390ab0476 (patch)
treef08ded94a5a2288cd13515856125766d875ba870 /x11/gnome
parentdbffc60b6641f6ae68f1ebfd61c6cde8a2f21b10 (diff)
downloadports-eaefe7d4ecf41c002de61c21fb214ef390ab0476.tar.gz
ports-eaefe7d4ecf41c002de61c21fb214ef390ab0476.zip
x11/gnome: Move from x11/gnome3
The reason for the move is because GNOME has moved beyond version 3, bumping directly to 40 and iterating major release versions from there. The Ports version of GNOME is currently at 41, making x11/gnome3 misnamed also. Differential Revision: https://reviews.freebsd.org/D33959
Diffstat (limited to 'x11/gnome')
-rw-r--r--x11/gnome/Makefile78
-rw-r--r--x11/gnome/pkg-descr4
-rw-r--r--x11/gnome/pkg-descr-lite5
-rw-r--r--x11/gnome/pkg-message11
-rw-r--r--x11/gnome/pkg-message-lite23
5 files changed, 121 insertions, 0 deletions
diff --git a/x11/gnome/Makefile b/x11/gnome/Makefile
new file mode 100644
index 000000000000..e15e127dab4f
--- /dev/null
+++ b/x11/gnome/Makefile
@@ -0,0 +1,78 @@
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
+
+PORTNAME= gnome
+PORTVERSION= 41
+CATEGORIES?= x11 gnome
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Metaport for the GNOME integrated X11 desktop
+
+FLAVORS= full lite
+FLAVOR?= full
+
+RUN_DEPENDS?= dconf-editor:devel/dconf-editor \
+ gdm>=3.0.0:x11/gdm \
+ gnome-session>=3.0.0:x11/gnome-session \
+ gnome-themes-extra>=3.28:x11-themes/gnome-themes-extra \
+ gnome-icon-theme-extras>=3.0.0:misc/gnome-icon-theme-extras \
+ gnome-icon-theme-symbolic>=3.0.0:x11-themes/gnome-icon-theme-symbolic \
+ gnome-keyring>=3.0.0:security/gnome-keyring \
+ gnome-power-manager>=3.0.0:sysutils/gnome-power-manager \
+ orca>=3.0.0:accessibility/orca \
+ gnome-shell>=3.0.0:x11/gnome-shell \
+ gnome-shell-extensions>=3.0.0:x11/gnome-shell-extensions \
+ gnome-tweaks:deskutils/gnome-tweaks \
+ sushi>=0:x11-fm/sushi \
+ nautilus>=3.0.0:x11-fm/nautilus \
+ ${LOCALBASE}/share/fonts/bitstream-vera/Vera.ttf:x11-fonts/bitstream-vera \
+ yelp>=3.0.0:x11/yelp \
+ zenity>=3.0.0:x11/zenity \
+ seahorse>=3.0.0:security/seahorse \
+ gnome-control-center>=3.0.0:sysutils/gnome-control-center \
+ ${LOCALBASE}/share/gnome-background-properties/gnome-backgrounds.xml:x11-themes/gnome-backgrounds \
+ caribou>=0:accessibility/caribou \
+ ${LOCALBASE}/share/sounds/freedesktop/index.theme:audio/freedesktop-sound-theme
+
+OPTIONS_DEFINE= DOCS
+
+USES= metaport
+
+.if ${FLAVOR} ==lite
+OPTIONS_EXCLUDE= DOCS
+PKGNAMESUFFIX= -lite
+COMMENT= The "meta-port" of the GNOME desktop slimmed down for only the basics
+PKGMESSAGE= ${.CURDIR}/pkg-message-lite
+DESCR= ${.CURDIR}/pkg-descr-lite
+.endif
+
+.if ${FLAVOR} == "full"
+RUN_DEPENDS+= epiphany>=3.0.0:www/epiphany \
+ gucharmap>=3.0.0:deskutils/gucharmap \
+ gnome-characters>=3.0.0:deskutils/gnome-characters \
+ gnome-calendar>=3.0:deskutils/gnome-calendar \
+ eog>=3.0.0:graphics/eog \
+ eog-plugins>=3.0.0:graphics/eog-plugins \
+ gedit>=3.0.0:editors/gedit \
+ gedit-plugins>=3.0.0:editors/gedit-plugins \
+ gnome-terminal>=3.0.0:x11/gnome-terminal \
+ brasero>=3.0.0:sysutils/brasero \
+ accerciser>=3.0.0:accessibility/accerciser \
+ gnome-calculator>=3.0.0:math/gnome-calculator \
+ gnome-utils>=3.6.0:deskutils/gnome-utils \
+ file-roller>=3.0.0:archivers/file-roller \
+ evince>=3.0.0:graphics/evince \
+ vino>=3.0.0:net/vino \
+ vinagre>=3.0.0:net/vinagre \
+ gnome-games>=3.0.0:games/gnome-games \
+ totem>=3.0.0:multimedia/totem \
+ gconf-editor>=3.0.0:sysutils/gconf-editor \
+ gnome-color-manager>=0:graphics/gnome-color-manager \
+ evolution>=3.0.0:mail/evolution \
+ cheese>=3.0.0:multimedia/cheese
+
+.endif # !gnome3-lite section
+
+DOCS_RUN_DEPENDS= gnome-user-docs>=0:misc/gnome-user-docs \
+ gnome-getting-started-docs>=0:misc/gnome-getting-started-docs
+
+.include <bsd.port.mk>
diff --git a/x11/gnome/pkg-descr b/x11/gnome/pkg-descr
new file mode 100644
index 000000000000..36c88d60edc6
--- /dev/null
+++ b/x11/gnome/pkg-descr
@@ -0,0 +1,4 @@
+This metaport installs the entire GNOME 3 desktop, including
+the user applications released with it.
+
+WWW: https://www.FreeBSD.org/gnome/
diff --git a/x11/gnome/pkg-descr-lite b/x11/gnome/pkg-descr-lite
new file mode 100644
index 000000000000..1bf12a7d1064
--- /dev/null
+++ b/x11/gnome/pkg-descr-lite
@@ -0,0 +1,5 @@
+This metaport installs the pieces of the GNOME desktop that are needed to
+provide a functional desktop. The x11/gnome metaport, contains the full
+version of the GNOME desktop environment.
+
+WWW: https://www.FreeBSD.org/gnome/
diff --git a/x11/gnome/pkg-message b/x11/gnome/pkg-message
new file mode 100644
index 000000000000..895e224de582
--- /dev/null
+++ b/x11/gnome/pkg-message
@@ -0,0 +1,11 @@
+[
+{ type: install
+ message: <<EOM
+Congratulations! GNOME has been successfully installed on your system.
+For help on starting it up, as well as answers to common questions, and
+some known issues, please see the FreeBSD GNOME homepage at:
+
+ http://www.FreeBSD.org/gnome/
+EOM
+}
+]
diff --git a/x11/gnome/pkg-message-lite b/x11/gnome/pkg-message-lite
new file mode 100644
index 000000000000..05fadc44c124
--- /dev/null
+++ b/x11/gnome/pkg-message-lite
@@ -0,0 +1,23 @@
+[
+{ type: install
+ message: <<EOM
+The GNOME desktop Lite edition has been successfully installed.
+
+The Lite edition only includes the minimal components to get a working GNOME
+Desktop. The user then has to install prefered applications like editor, web
+browser or e-mail client. If you wish to install the full desktop, you can
+remove this port, and install the x11/gnome port or package. That can be
+best accomplished using the following commands:
+
+# pkg_delete gnome-lite
+# cd /usr/ports/x11/gnome
+# make install clean
+
+Alternatively, you can install additional GNOME components individually
+using either their ports or packages.
+
+For more help on using GNOME on FreeBSD, please see the FreeBSD GNOME project
+site at http://www.FreeBSD.org/gnome.
+EOM
+}
+]