aboutsummaryrefslogtreecommitdiff
path: root/x11/gnustep-app
diff options
context:
space:
mode:
authorDavid Chisnall <theraven@FreeBSD.org>2013-08-28 18:26:01 +0000
committerDavid Chisnall <theraven@FreeBSD.org>2013-08-28 18:26:01 +0000
commit3bec8741ffe1e70c5dbabd1ee86bfdf05f1c3e99 (patch)
treeab5064afd823ae17563635026226e53774a6614d /x11/gnustep-app
parent7108c85b56ca17f7e1daaa73f17c74c7d4ec630c (diff)
downloadports-3bec8741ffe1e70c5dbabd1ee86bfdf05f1c3e99.tar.gz
ports-3bec8741ffe1e70c5dbabd1ee86bfdf05f1c3e99.zip
Update to latest GNUstep core libraries.
Update dependent packages with more recent releases. Remove old and bit-rotted ones. Switch to using clang 3.3 and libobjc2 1.7 by default, so modern Objective-C features work out of the box and remove a lot of configurable options for sub-optimal (and, often, unsupported / deprecated upstream) configurations. Take maintainership of GNUstep-related ports. Several of the ports left in have scary warnings which mean that they are likely broken in lots of cases. Future commits will fix them. Approved by: bapt
Notes
Notes: svn path=/head/; revision=325546
Diffstat (limited to 'x11/gnustep-app')
-rw-r--r--x11/gnustep-app/Makefile117
-rw-r--r--x11/gnustep-app/pkg-descr1
2 files changed, 118 insertions, 0 deletions
diff --git a/x11/gnustep-app/Makefile b/x11/gnustep-app/Makefile
new file mode 100644
index 000000000000..2fa742e062ef
--- /dev/null
+++ b/x11/gnustep-app/Makefile
@@ -0,0 +1,117 @@
+# New ports collection makefile for: gnustep-app
+# Date created: 28 Oct 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnustep-app
+PORTVERSION= 2.0.0
+PORTREVISION= 1
+CATEGORIES= x11 gnustep
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= theraven@FreeBSD.org
+COMMENT= Metaport for GNUstep applications
+
+NO_BUILD= yes
+NO_INSTALL= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_BASE= yes
+USE_GNUSTEP_GUI= yes
+USE_GNUSTEP_BACK= yes
+
+USE_GNUSTEP_SYSTEM_LIBS+= \
+ PreferencePanes:deskutils/preferencepanes \
+
+USE_GNUSTEP_LOCAL_LIBS+= \
+ Pantomime:mail/pantomime \
+ Addresses:mail/addresses \
+ SlideShow:graphics/gnustep-slideshowkit \
+ WizardKit:devel/wizardkit \
+ HighlighterKit:devel/highlighterkit \
+ GSKrab:x11/gskrab \
+ Encore:devel/fortytwo-encore \
+ BDB:databases/fortytwo-bdb \
+ FT:graphics/fortytwo \
+ CameraKit:graphics/camerakit \
+ Toolbox:deskutils/toolboxkit \
+
+USE_GNUSTEP_LOCAL_BUNDLES+= \
+ Cddb:audio/cddb-bundle \
+
+USE_GNUSTEP_SYSTEM_APPS+= \
+ Gorm:devel/gorm \
+ GShisen:games/gshisen \
+ GWorkspace:deskutils/gworkspace \
+ Terminal:x11/terminal.app \
+ GSPdf:print/gspdf \
+ SystemPreferences:deskutils/systempreferences \
+ WrapperFactory:deskutils/gnustep-wrapper \
+ GRubik:games/grubik \
+ ClipBook:deskutils/gworkspace-clipbook \
+ MDFinder:deskutils/gworkspace-gwmetadata \
+
+USE_GNUSTEP_LOCAL_APPS+= \
+ GNUMail:mail/gnumail \
+ EasyDiff:textproc/easydiff \
+ ImageViewer:graphics/imageviewer \
+ SlideShow:graphics/gnustep-slideshow \
+ Preview:graphics/preview \
+ TimeMon:sysutils/timemon \
+ Cenon:graphics/cenon \
+ PRICE:graphics/price \
+ EdenMath:math/edenmath \
+ Zipper:archivers/zipper \
+ Camera:graphics/camera \
+ Ladder:games/gnustep-ladder \
+ Charmap:deskutils/charmap \
+ GTAMSAnalyzer:science/gtamsanalyzer \
+ Paje:science/paje \
+ AClock:x11-clocks/aclock \
+ LapisPuzzle:games/lapispuzzle \
+ Waiho:ftp/waiho \
+ Affiche:deskutils/affiche \
+ GMastermind:games/gmastermind \
+ Jigsaw:games/jigsaw \
+ NoteBook:deskutils/gnustep-notebook \
+ HelpViewer:deskutils/helpviewer \
+ Duncan:textproc/duncan \
+ Jishyo:japanese/jishyo \
+ GMines:games/gmines \
+ InnerSpace:x11/innerspace \
+ FTP:ftp/gnustep-ftp \
+ batmon:sysutils/batmon \
+ RemoteDesk:net/remotedesk \
+ DisplayCalibrator:deskutils/displaycalibrator \
+ Poe:multimedia/poe \
+ MPDCon:audio/mpdcon \
+ PlopFolio:deskutils/plopfolio \
+ CDPlayer:audio/gnustep-cdplayer \
+ GScheme:lang/gscheme \
+ NeXTGo:games/nextgo \
+ Expense:finance/expense \
+ FreeTar:archivers/freetar \
+ Localize:textproc/localize \
+ AppWrapper:deskutils/appwrapper \
+ Pixen:graphics/pixen \
+ Cartotheque:deskutils/cartotheque \
+ LuserNET:news/lusernet \
+ Popup:textproc/popup \
+ Fortunate:games/fortunate \
+ BioCocoa:biology/biococoa \
+ Sudoku:games/gnustep-sudoku \
+ LaternaMagica:graphics/laternamagica \
+ SimpleAgenda:deskutils/simpleagenda \
+
+USE_GNUSTEP_LOCAL_TOOLS+= \
+ zillion:net/zillion \
+ adtool:mail/addresses-goodies \
+
+
+USE_GNUSTEP_LOCAL_SERVICES+= \
+ LaTeX:textproc/latex-service \
+
+.include <bsd.port.mk>
diff --git a/x11/gnustep-app/pkg-descr b/x11/gnustep-app/pkg-descr
new file mode 100644
index 000000000000..7374d1ea36bd
--- /dev/null
+++ b/x11/gnustep-app/pkg-descr
@@ -0,0 +1 @@
+Collection of GNUstep software.