aboutsummaryrefslogtreecommitdiff
path: root/x11/gromit
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
commit216b5a285fdcc1456a307fcc60f3507c20d613eb (patch)
treed0c8617b772b8f0a175d436d938b8d844590b41f /x11/gromit
parentb829518a7d432b7cc2546fde7f032238d1db13dc (diff)
downloadports-216b5a285fdcc1456a307fcc60f3507c20d613eb.tar.gz
ports-216b5a285fdcc1456a307fcc60f3507c20d613eb.zip
- Fix missing library problems when the linker enforces explicit linking
PR: 192062 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=366215
Diffstat (limited to 'x11/gromit')
-rw-r--r--x11/gromit/Makefile4
-rw-r--r--x11/gromit/files/patch-Makefile5
2 files changed, 3 insertions, 6 deletions
diff --git a/x11/gromit/Makefile b/x11/gromit/Makefile
index e93812e17915..bead657e8d78 100644
--- a/x11/gromit/Makefile
+++ b/x11/gromit/Makefile
@@ -10,9 +10,9 @@ MASTER_SITES= http://www.home.unix-ag.org/simon/gromit/
MAINTAINER= ports@FreeBSD.org
COMMENT= GRaphics Over Miscellaneous Objects (Gromit)
-USE_GNOME= gtk20
USES= pkgconfig
-CFLAGS+= -lm
+USE_GNOME= gtk20
+USE_XORG= x11
DOCS= AUTHORS ChangeLog README
diff --git a/x11/gromit/files/patch-Makefile b/x11/gromit/files/patch-Makefile
index 0f41bedb2776..e0309e0a8bd6 100644
--- a/x11/gromit/files/patch-Makefile
+++ b/x11/gromit/files/patch-Makefile
@@ -1,6 +1,3 @@
-
-$FreeBSD$
-
--- Makefile.orig
+++ Makefile
@@ -7,4 +7,4 @@
@@ -8,4 +5,4 @@ $FreeBSD$
gromit: gromit.c Makefile
- gcc -DG_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DPANGO_DISABLE_DEPRECATED -DGDK_MULTIHEAD_SAFE -DGTK_MULTIHEAD_SAFE -o gromit gromit.c -Wall `pkg-config --libs --cflags gtk+-2.0`
-+ ${CC} -DG_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DPANGO_DISABLE_DEPRECATED -DGDK_MULTIHEAD_SAFE -DGTK_MULTIHEAD_SAFE -o gromit gromit.c ${CFLAGS} `pkg-config --libs --cflags gtk+-2.0`
++ ${CC} -DG_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DPANGO_DISABLE_DEPRECATED -DGDK_MULTIHEAD_SAFE -DGTK_MULTIHEAD_SAFE -o gromit gromit.c ${CFLAGS} `pkg-config --libs --cflags gtk+-2.0 x11` -lm