aboutsummaryrefslogtreecommitdiff
path: root/x11/gromit
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-01-05 13:05:48 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-01-05 13:05:48 +0000
commit80425be42c983b5fee9051a677be9caefdc55d8e (patch)
tree23de0a51c7e833ef3bdac4fcd99f19d57e31b1fb /x11/gromit
parenta47f41affe62f7c5f6ce2618634788a65ba318bf (diff)
downloadports-80425be42c983b5fee9051a677be9caefdc55d8e.tar.gz
ports-80425be42c983b5fee9051a677be9caefdc55d8e.zip
- Stage support
- Add missing OPTIONS_DEFINE
Notes
Notes: svn path=/head/; revision=338762
Diffstat (limited to 'x11/gromit')
-rw-r--r--x11/gromit/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/x11/gromit/Makefile b/x11/gromit/Makefile
index 91dd0a8d9a01..e93812e17915 100644
--- a/x11/gromit/Makefile
+++ b/x11/gromit/Makefile
@@ -16,16 +16,17 @@ CFLAGS+= -lm
DOCS= AUTHORS ChangeLog README
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/gromit ${PREFIX}/bin
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/gromitrc ${EXAMPLESDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/gromit ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/gromitrc ${STAGEDIR}${EXAMPLESDIR}
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>