aboutsummaryrefslogtreecommitdiff
path: root/x11/guake
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-07-01 21:08:43 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-07-01 21:08:43 +0000
commit0285fbcb071a637871272c1071f5d4a1fa1beba3 (patch)
treea28c3a287ec2afc72fb2457d60265bcb26853b9a /x11/guake
parent81ad2ee85c456a35b8307e4d056764ebdc1f98f7 (diff)
downloadports-0285fbcb071a637871272c1071f5d4a1fa1beba3.tar.gz
ports-0285fbcb071a637871272c1071f5d4a1fa1beba3.zip
- Fix problems with the location of the locale directory by setting
CPPFLAGS and LIBS instead of using a patch - Use option helpers for NLS option - Add USES=libtool
Notes
Notes: svn path=/head/; revision=360094
Diffstat (limited to 'x11/guake')
-rw-r--r--x11/guake/Makefile19
-rw-r--r--x11/guake/files/patch-po__Makefile.in.in12
-rw-r--r--x11/guake/pkg-plist1
3 files changed, 10 insertions, 22 deletions
diff --git a/x11/guake/Makefile b/x11/guake/Makefile
index 42cef870bb6b..717efc54082a 100644
--- a/x11/guake/Makefile
+++ b/x11/guake/Makefile
@@ -2,7 +2,7 @@
PORTNAME= guake
PORTVERSION= 0.4.4.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11
MASTER_SITES= http://distfiles.gentoo.org/distfiles/ \
http://nivit.altervista.org/FreeBSD/ports/distfiles/
@@ -22,6 +22,9 @@ RUN_DEPENDS= py${PYTHON_SUFFIX}-dbus>=0.84.0:${PORTSDIR}/devel/py-dbus \
py${PYTHON_SUFFIX}-vte>=0.26.2_1:${PORTSDIR}/x11-toolkits/py-vte \
py${PYTHON_SUFFIX}-xdg>=0.19:${PORTSDIR}/devel/py-xdg
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
+
#GH_ACCOUNT= Guake
#GH_TAGNAME= ${PORTVERSION:R}
#GH_COMMIT= 88af26c
@@ -30,8 +33,8 @@ GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-NLS_CONFIGURE_ON= --localedir=${PREFIX}/share/locale
-NLS_CONFIGURE_OFF= --disable-nls
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
OPTIONS_DEFINE= MANPAGES NLS
OPTIONS_DEFAULT= MANPAGES
@@ -45,7 +48,7 @@ REINPLACE_FILES= guake guake-prefs prefs.py
#USE_GITHUB= yes
USE_GNOME= gtk20 pygnome2
USE_PYTHON= 2
-USES= desktop-file-utils gmake pkgconfig
+USES= desktop-file-utils gmake libtool pkgconfig
WRKSRC= ${WRKDIR}/${DISTNAME}
@@ -55,11 +58,9 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
MAKE_ENV+= man_MANS=""
.endif
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-.else
-REINPLACE_ARGS= -E -e 's,(USE_NLS=)yes,\1no,'
-REINPLACE_FILES= ../configure
+.if ! ${PORT_OPTIONS:MNLS}
+REINPLACE_ARGS+= -e 's,\(USE_NLS=\)yes,\1no,'
+REINPLACE_FILES+= ../configure
.endif
post-patch:
diff --git a/x11/guake/files/patch-po__Makefile.in.in b/x11/guake/files/patch-po__Makefile.in.in
deleted file mode 100644
index e8ffa7a3b07a..000000000000
--- a/x11/guake/files/patch-po__Makefile.in.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./po/Makefile.in.in.orig 2013-01-18 22:40:08.000000000 +0100
-+++ ./po/Makefile.in.in 2013-01-18 22:40:34.000000000 +0100
-@@ -34,7 +34,8 @@
- datarootdir = @datarootdir@
- libdir = @libdir@
- DATADIRNAME = @DATADIRNAME@
--itlocaledir = $(prefix)/$(DATADIRNAME)/locale
-+#itlocaledir = $(prefix)/$(DATADIRNAME)/locale
-+itlocaledir = @localedir@
- subdir = po
- install_sh = @install_sh@
- # Automake >= 1.8 provides @mkdir_p@.
diff --git a/x11/guake/pkg-plist b/x11/guake/pkg-plist
index f074f969eb3b..2581177460c3 100644
--- a/x11/guake/pkg-plist
+++ b/x11/guake/pkg-plist
@@ -24,7 +24,6 @@ bin/guake-prefs
%%PYTHON_SITELIBDIR%%/guake/dbusiface.pyc
%%PYTHON_SITELIBDIR%%/guake/dbusiface.pyo
%%PYTHON_SITELIBDIR%%/guake/globalhotkeys.a
-%%PYTHON_SITELIBDIR%%/guake/globalhotkeys.la
%%PYTHON_SITELIBDIR%%/guake/globalhotkeys.so
%%PYTHON_SITELIBDIR%%/guake/globals.py
%%PYTHON_SITELIBDIR%%/guake/globals.pyc