aboutsummaryrefslogtreecommitdiff
path: root/x11/hhpc
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2017-12-18 22:39:38 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2017-12-18 22:39:38 +0000
commitf0294bafaac6bf3e212ef5cb364589912dc12c82 (patch)
tree903a58bbdc36b4797c1dd2c45ad7418d469b320f /x11/hhpc
parent594d6b95bb9b9e3987334c7187c96f88cc29188a (diff)
downloadports-f0294bafaac6bf3e212ef5cb364589912dc12c82.tar.gz
ports-f0294bafaac6bf3e212ef5cb364589912dc12c82.zip
New port: x11/hhpc: Small and easy to use console text editor
PR: 224345 Submitted by: Dmitri Goutnik <dg@syrec.org> Approved by: adamw (mentor) Differential Revision: https://reviews.freebsd.org/D13499
Notes
Notes: svn path=/head/; revision=456690
Diffstat (limited to 'x11/hhpc')
-rw-r--r--x11/hhpc/Makefile31
-rw-r--r--x11/hhpc/distinfo3
-rw-r--r--x11/hhpc/files/patch-Makefile23
-rw-r--r--x11/hhpc/pkg-descr13
4 files changed, 70 insertions, 0 deletions
diff --git a/x11/hhpc/Makefile b/x11/hhpc/Makefile
new file mode 100644
index 000000000000..35e6ef824d33
--- /dev/null
+++ b/x11/hhpc/Makefile
@@ -0,0 +1,31 @@
+# Created by: Dmitri Goutnik <dg@syrec.org>
+# $FreeBSD$
+
+PORTNAME= hhpc
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.3.1
+CATEGORIES= x11
+
+MAINTAINER= dg@syrec.org
+COMMENT= Small X11 utility to hide the mouse pointer when unused
+
+LICENSE= BSD3CLAUSE
+
+USES= gmake localbase pkgconfig
+USE_XORG= x11
+USE_GITHUB= yes
+GH_ACCOUNT= aktau
+ALL_TARGET= release
+
+PLIST_FILES= bin/hhpc
+
+PORTDOCS= README.md
+
+OPTIONS_DEFINE= DOCS
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/hhpc ${STAGEDIR}${PREFIX}/bin/
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/x11/hhpc/distinfo b/x11/hhpc/distinfo
new file mode 100644
index 000000000000..ea3fd0b216dc
--- /dev/null
+++ b/x11/hhpc/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1513268001
+SHA256 (aktau-hhpc-v0.3.1_GH0.tar.gz) = f75cc4c4542d833e2aa9fbc3bfd2b658b6a21354d5d546dad49eb0efc6134417
+SIZE (aktau-hhpc-v0.3.1_GH0.tar.gz) = 5487
diff --git a/x11/hhpc/files/patch-Makefile b/x11/hhpc/files/patch-Makefile
new file mode 100644
index 000000000000..9f468326800c
--- /dev/null
+++ b/x11/hhpc/files/patch-Makefile
@@ -0,0 +1,23 @@
+--- Makefile.orig 2014-08-25 15:37:45 UTC
++++ Makefile
+@@ -51,7 +51,7 @@ CFLAGS_COMMON ?= \
+ -pedantic \
+ -std=c99
+
+-CFLAGS ?= $(CFLAGS_COMMON)
++CFLAGS += $(CFLAGS_COMMON)
+
+ CC ?= cc $(CFLAGS)
+
+@@ -66,10 +66,7 @@ debug: CFLAGS += $(WARN) \
+ -DDEBUG
+ debug: $(EXECUTABLE)
+
+-release: CFLAGS += \
+- -s \
+- -O2 \
+- -DNDEBUG
++release: CFLAGS += -DNDEBUG
+ release: $(EXECUTABLE)
+
+ $(EXECUTABLE): $(OBJECTS)
diff --git a/x11/hhpc/pkg-descr b/x11/hhpc/pkg-descr
new file mode 100644
index 000000000000..f34eb2792e81
--- /dev/null
+++ b/x11/hhpc/pkg-descr
@@ -0,0 +1,13 @@
+hhpc is an utility that hides the mouse pointer in X11. It functions by
+grabbing your mouse pointer at startup and replacing its bitmap with an
+empty one (thus hiding it). Then, it waits for the X server to notify it
+when a user tries to move or click the pointer. At this point, hhpc
+relinquishes control, replays the action the user just tried to execute and
+waits for the specified number of seconds (flag -i) before trying to grab
+the pointer and hide it again.
+
+Should hhpc not work out for you, unclutter is a good alternative. hhpc was
+created because unclutter doesn't seem to interoperate properly with
+hardware accelerated surfaces like those of video players using VAAPI.
+
+WWW: https://github.com/aktau/hhpc