aboutsummaryrefslogtreecommitdiff
path: root/x11/hs-xmobar
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2011-05-09 05:28:57 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2011-05-09 05:28:57 +0000
commit0c76a8384fc1de4958eb1228befbee727f00c596 (patch)
tree28680b3da252da7f45a2d25108e4e2a6e41a77e5 /x11/hs-xmobar
parentf2febc81eeab0d296325ecc49e1825762e5cd5d7 (diff)
downloadports-0c76a8384fc1de4958eb1228befbee727f00c596.tar.gz
ports-0c76a8384fc1de4958eb1228befbee727f00c596.zip
- Please welcome GHC 7.0.3
GHC in the ports tree has been updated to 7.0.3 and all other Haskell ports are also updated to their corresponding Haskell Platform versions, or latest versions. We would like to acknowledge the support of the FreeBSD Donations Team and Eotvos Lorand University, Faculty of Informatics who contributed to the server that we used for testing. We would also like to thank all the testers who tested FreeBSD Haskell ports and provided their feedback. PR: ports/156642 Approved by: tabthorpe (mentor) Obtained from: FreeBSD Haskell
Notes
Notes: svn path=/head/; revision=273838
Diffstat (limited to 'x11/hs-xmobar')
-rw-r--r--x11/hs-xmobar/Makefile14
-rw-r--r--x11/hs-xmobar/distinfo4
-rw-r--r--x11/hs-xmobar/pkg-plist4
3 files changed, 10 insertions, 12 deletions
diff --git a/x11/hs-xmobar/Makefile b/x11/hs-xmobar/Makefile
index f2547f51e397..7d9b254a1065 100644
--- a/x11/hs-xmobar/Makefile
+++ b/x11/hs-xmobar/Makefile
@@ -5,20 +5,22 @@
# $FreeBSD$
PORTNAME= xmobar
-PORTVERSION= 0.11.1
+PORTVERSION= 0.12
CATEGORIES= x11 haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= A minimalistic text based status bar
-USE_HACKAGE= X11>=1.3.0
+LICENSE= BSD
+
+USE_CABAL= mtl parsec stm X11>=1.3.0
USE_XORG= x11
EXECUTABLE= xmobar
STANDALONE= yes
PORTDATA= *
-INSTALL_PORTDATA= ${INSTALL_DATA} ${WRKSRC}/xmobar.config-sample ${DATADIR}
+INSTALL_PORTDATA= ${INSTALL_DATA} ${WRKSRC}/samples/xmobar.config ${DATADIR}
OPTIONS= XFT "Use Xft to render text (UTF-8 support included)" off \
UTF8 "UTF-8 support" on \
@@ -32,7 +34,7 @@ CONFIGURE_ARGS+= --flags="-with_inotify -with_iwlib"
.if defined(WITH_XFT)
CONFIGURE_ARGS+= --flags="with_xft"
-USE_HACKAGE+= utf8-string X11-xft>=0.2
+USE_CABAL+= utf8-string X11-xft>=0.2
.else
CONFIGURE_ARGS+= --flags="-with_xft"
.endif
@@ -40,7 +42,7 @@ CONFIGURE_ARGS+= --flags="-with_xft"
.if defined(WITH_UTF8)
CONFIGURE_ARGS+= --flags="with_utf8"
.if !defined(WITH_XFT)
-USE_HACKAGE+= utf8-string
+USE_CABAL+= utf8-string
.endif
.else
CONFIGURE_ARGS+= --flags="-with_utf8"
@@ -48,7 +50,7 @@ CONFIGURE_ARGS+= --flags="-with_utf8"
.if defined(WITH_MPD)
CONFIGURE_ARGS+= --flags="with_mpd"
-USE_HACKAGE+= libmpd
+USE_CABAL+= libmpd
.else
CONFIGURE_ARGS+= --flags="-with_mpd"
.endif
diff --git a/x11/hs-xmobar/distinfo b/x11/hs-xmobar/distinfo
index 6b3657508f3d..2255f62bfedf 100644
--- a/x11/hs-xmobar/distinfo
+++ b/x11/hs-xmobar/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/xmobar-0.11.1.tar.gz) = 753b755b96852008bbbf8c79933d9ebb87554bf7e562888e8d6fb5b8320a6a73
-SIZE (cabal/xmobar-0.11.1.tar.gz) = 45872
+SHA256 (cabal/xmobar-0.12.tar.gz) = 633b7985dbaebd58864f591ea7ff8b44f5a69b4e3d0a592df01daf8fe11a5d31
+SIZE (cabal/xmobar-0.12.tar.gz) = 52630
diff --git a/x11/hs-xmobar/pkg-plist b/x11/hs-xmobar/pkg-plist
deleted file mode 100644
index f4b7e0083752..000000000000
--- a/x11/hs-xmobar/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-@comment $FreeBSD$
-bin/xmobar
-%%NOPORTDOCS%%%%DOCSDIR%%/LICENSE
-%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%