aboutsummaryrefslogtreecommitdiff
path: root/x11/i3status
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2016-01-12 12:42:59 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2016-01-12 12:42:59 +0000
commit19eb680d72135f900caa3d34445c18ec5fdaedc5 (patch)
tree43bab8aad3b9e8c4ea14f8e9ed533ccdf087e757 /x11/i3status
parentecf94441cc4f4c6278984d7c8524f8bae398cdc7 (diff)
downloadports-19eb680d72135f900caa3d34445c18ec5fdaedc5.tar.gz
ports-19eb680d72135f900caa3d34445c18ec5fdaedc5.zip
Notes
Diffstat (limited to 'x11/i3status')
-rw-r--r--x11/i3status/Makefile5
-rw-r--r--x11/i3status/files/no-pulseaudio.diff (renamed from x11/i3status/files/patch-Makefile)11
-rw-r--r--x11/i3status/files/patch-src_print__volume.c11
3 files changed, 16 insertions, 11 deletions
diff --git a/x11/i3status/Makefile b/x11/i3status/Makefile
index 166fb0cd08d8..9366b9d4ae7b 100644
--- a/x11/i3status/Makefile
+++ b/x11/i3status/Makefile
@@ -10,6 +10,8 @@ COMMENT= Small program for generating a status bar
LICENSE= BSD3CLAUSE
+OPTIONS_DEFINE= PULSEAUDIO
+
LIB_DEPENDS= libconfuse.so:${PORTSDIR}/devel/libconfuse \
libyajl.so:${PORTSDIR}/devel/yajl
@@ -17,6 +19,9 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USES= gmake tar:bzip2
+PULSEAUDIO_EXTRA_PATCHES_OFF= ${FILESDIR}/no-pulseaudio.diff
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
+
post-patch:
@${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|g' ${WRKSRC}/i3status.c
diff --git a/x11/i3status/files/patch-Makefile b/x11/i3status/files/no-pulseaudio.diff
index 26d27a6838de..232ea05ba8df 100644
--- a/x11/i3status/files/patch-Makefile
+++ b/x11/i3status/files/no-pulseaudio.diff
@@ -12,3 +12,14 @@
src/%.o: src/%.c include/i3status.h
$(CC) $(CPPFLAGS) $(CFLAGS) -c -o $@ $<
@echo " CC $<"
+--- src/print_volume.c.orig 2016-01-12 12:27:47 UTC
++++ src/print_volume.c
+@@ -60,7 +60,7 @@ void print_volume(yajl_gen json_gen, cha
+ free(instance);
+ }
+
+-#ifndef __OpenBSD__
++#if !defined(__OPENBSD__) && !defined(__FreeBSD__)
+ /* Try PulseAudio first */
+
+ /* If the device name has the format "pulse[:N]" where N is the
diff --git a/x11/i3status/files/patch-src_print__volume.c b/x11/i3status/files/patch-src_print__volume.c
deleted file mode 100644
index 4fc73597ca45..000000000000
--- a/x11/i3status/files/patch-src_print__volume.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/print_volume.c.orig 2016-01-12 12:27:47 UTC
-+++ src/print_volume.c
-@@ -60,7 +60,7 @@ void print_volume(yajl_gen json_gen, cha
- free(instance);
- }
-
--#ifndef __OpenBSD__
-+#if !defined(__OPENBSD__) && !defined(__FreeBSD__)
- /* Try PulseAudio first */
-
- /* If the device name has the format "pulse[:N]" where N is the